summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Palus2019-10-08 08:03:25 (GMT)
committerJan Palus2019-10-08 08:03:25 (GMT)
commitaeb8c59dd8d2000d06495c36721326bc1a54187f (patch)
treef0bd25851445665f8126fa983b571c81f5a561d9
parentf0b9aa9b4318a205164b94d65f34c7788d9434f8 (diff)
downloadqt5-qtwebkit-aeb8c59dd8d2000d06495c36721326bc1a54187f.zip
qt5-qtwebkit-aeb8c59dd8d2000d06495c36721326bc1a54187f.tar.gz
adjusted upstream patch to fix build with icu 65
-rw-r--r--icu65.patch50
-rw-r--r--qt5-qtwebkit.spec2
2 files changed, 52 insertions, 0 deletions
diff --git a/icu65.patch b/icu65.patch
new file mode 100644
index 0000000..e3b7d07
--- /dev/null
+++ b/icu65.patch
@@ -0,0 +1,50 @@
+------------------------------------------------------------------------
+r250747 | commit-queue@webkit.org | 2019-10-04 23:51:37 +0200 (pią, 04 paź 2019) | 16 lines
+
+Fix build with icu 65.1
+https://bugs.webkit.org/show_bug.cgi?id=202600
+
+Patch by Heiko Becker <heirecka@exherbo.org> on 2019-10-04
+Reviewed by Konstantin Tokarev.
+
+Source/WebCore:
+
+* dom/Document.cpp:
+(WebCore::isValidNameNonASCII):
+(WebCore::Document::parseQualifiedName):
+
+Source/WTF:
+
+* wtf/URLHelpers.cpp:
+(WTF::URLHelpers::allCharactersInIDNScriptWhiteList):
+
+Index: Source/WebCore/dom/Document.cpp
+===================================================================
+--- Source/WebCore/dom/Document.cpp (revision 250746)
++++ Source/WebCore/dom/Document.cpp (revision 250747)
+@@ -4954,12 +4954,12 @@
+ unsigned i = 0;
+
+ UChar32 c;
+- U16_NEXT(characters, i, length, c)
++ U16_NEXT(characters, i, length, c);
+ if (!isValidNameStart(c))
+ return false;
+
+ while (i < length) {
+- U16_NEXT(characters, i, length, c)
++ U16_NEXT(characters, i, length, c);
+ if (!isValidNamePart(c))
+ return false;
+ }
+@@ -5019,7 +5019,7 @@
+
+ for (unsigned i = 0; i < length; ) {
+ UChar32 c;
+- U16_NEXT(qualifiedName, i, length, c)
++ U16_NEXT(qualifiedName, i, length, c);
+ if (c == ':') {
+ if (sawColon)
+ return Exception { InvalidCharacterError };
+
+------------------------------------------------------------------------
diff --git a/qt5-qtwebkit.spec b/qt5-qtwebkit.spec
index 4d26220..2cf7014 100644
--- a/qt5-qtwebkit.spec
+++ b/qt5-qtwebkit.spec
@@ -42,6 +42,7 @@ License: LGPL v2+
Group: X11/Libraries
Source0: https://github.com/qtwebkit/qtwebkit/releases/download/qtwebkit-%{version}-%{snap}/qtwebkit-%{version}-%{snap}.tar.xz
# Source0-md5: 5e7ade75ad0df9047826e625e4f262fc
+Patch0: icu65.patch
# from FC
Patch102: qtwebkit-5.212.0_cmake_cmp0071.patch
Patch108: x32.patch
@@ -185,6 +186,7 @@ Dokumentacja do bibliotek Qt5 WebKit w formacie QCH.
%prep
%setup -q -n qtwebkit-%{version}-%{snap}
+%patch0 -p0
%patch102 -p1
%patch108 -p1