summaryrefslogtreecommitdiff
path: root/qt5-qtsensors.spec
diff options
context:
space:
mode:
Diffstat (limited to 'qt5-qtsensors.spec')
-rw-r--r--qt5-qtsensors.spec14
1 files changed, 8 insertions, 6 deletions
diff --git a/qt5-qtsensors.spec b/qt5-qtsensors.spec
index 13502ff..cc3c5a8 100644
--- a/qt5-qtsensors.spec
+++ b/qt5-qtsensors.spec
@@ -4,10 +4,10 @@
#
# Conditional build:
%bcond_with bootstrap # disable features to able to build without installed qt5
-%bcond_without qch # documentation in QCH format
+%bcond_without doc # Documentation
%if %{with bootstrap}
-%undefine with_qch
+%undefine with_doc
%endif
%define orgname qtsensors
@@ -27,7 +27,7 @@ URL: http://www.qt.io/
BuildRequires: Qt5Core-devel >= %{qtbase_ver}
BuildRequires: Qt5Qml-devel >= %{qtdeclarative_ver}
BuildRequires: Qt5Quick-devel >= %{qtdeclarative_ver}
-%if %{with qch}
+%if %{with doc}
BuildRequires: qt5-assistant >= %{qttools_ver}
%endif
BuildRequires: qt5-build >= %{qtbase_ver}
@@ -133,15 +133,17 @@ Przykłady do biblioteki Qt5 Sensors.
%build
qmake-qt5
%{__make}
-%{__make} %{!?with_qch:html_}docs
+%{?with_doc:%{__make} docs}
%install
rm -rf $RPM_BUILD_ROOT
%{__make} install \
INSTALL_ROOT=$RPM_BUILD_ROOT
-%{__make} install_%{!?with_qch:html_}docs \
+%if %{with doc}
+%{__make} install_docs \
INSTALL_ROOT=$RPM_BUILD_ROOT
+%endif
# useless symlinks
%{__rm} $RPM_BUILD_ROOT%{_libdir}/libQt5*.so.5.?
@@ -207,11 +209,11 @@ rm -rf $RPM_BUILD_ROOT
%{qt5dir}/mkspecs/modules/qt_lib_sensors.pri
%{qt5dir}/mkspecs/modules/qt_lib_sensors_private.pri
+%if %{with doc}
%files doc
%defattr(644,root,root,755)
%{_docdir}/qt5-doc/qtsensors
-%if %{with qch}
%files doc-qch
%defattr(644,root,root,755)
%{_docdir}/qt5-doc/qtsensors.qch