summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Rękorajski2017-05-23 09:31:21 (GMT)
committerJan Rękorajski2017-05-23 09:31:21 (GMT)
commit7b72fe568f4dc20a2325a799fd98c7608f79e0dd (patch)
tree2602e74471d23efe39470921186ef4cdb1983ccd
parent8463f1292559b5d8b32b728e394dd77e1734cb5d (diff)
downloadqt5-qtdeclarative-7b72fe568f4dc20a2325a799fd98c7608f79e0dd.zip
qt5-qtdeclarative-7b72fe568f4dc20a2325a799fd98c7608f79e0dd.tar.gz
- drop qch bcond
-rw-r--r--qt5-qtdeclarative.spec14
1 files changed, 4 insertions, 10 deletions
diff --git a/qt5-qtdeclarative.spec b/qt5-qtdeclarative.spec
index e92c4a9..774e607 100644
--- a/qt5-qtdeclarative.spec
+++ b/qt5-qtdeclarative.spec
@@ -2,14 +2,12 @@
# Conditional build:
%bcond_with bootstrap # disable features to able to build without installed qt5
# -- build targets
-%bcond_without doc
-%bcond_without qch # documentation in QCH format
+%bcond_without doc # Documentation
%bcond_without qm # QM translations
%bcond_without qtxmlpatterns # XmlListModel plugin (Qt5XmlPatterns based)
%if %{with bootstrap}
%undefine with_doc
-%undefine with_qch
%undefine with_qm
%undefine with_qtxmlpatterns
%endif
@@ -38,7 +36,7 @@ BuildRequires: Qt5Sql-devel >= %{qtbase_ver}
BuildRequires: Qt5Test-devel >= %{qtbase_ver}
BuildRequires: Qt5Widgets-devel >= %{qtbase_ver}
%{?with_qtxmlpatterns:BuildRequires: Qt5XmlPatterns-devel >= %{qtxmlpatterns_ver}}
-%if %{with qch}
+%if %{with doc}
BuildRequires: qt5-assistant >= %{qttools_ver}
%endif
BuildRequires: qt5-build >= %{qtbase_ver}
@@ -248,9 +246,7 @@ Przykłady do bibliotek Qt5 Declarative.
qmake-qt5
%{__make}
-%if %{with doc}
-%{__make} %{!?with_qch:html_}docs
-%endif
+%{?with_doc:%{__make} docs}
%if %{with qm}
cd qttranslations-opensource-src-%{version}
@@ -267,7 +263,7 @@ install -d $RPM_BUILD_ROOT%{_bindir}
INSTALL_ROOT=$RPM_BUILD_ROOT
%if %{with doc}
-%{__make} install_%{!?with_qch:html_}docs \
+%{__make} install_docs \
INSTALL_ROOT=$RPM_BUILD_ROOT
%endif
@@ -530,13 +526,11 @@ rm -rf $RPM_BUILD_ROOT
%{_docdir}/qt5-doc/qtqml
%{_docdir}/qt5-doc/qtquick
-%if %{with qch}
%files doc-qch
%defattr(644,root,root,755)
%{_docdir}/qt5-doc/qtqml.qch
%{_docdir}/qt5-doc/qtquick.qch
%endif
-%endif
%files examples -f examples.files
%defattr(644,root,root,755)