summaryrefslogtreecommitdiff
path: root/python3-dip.spec
diff options
context:
space:
mode:
authorJakub Bogusz2011-11-06 07:40:04 (GMT)
committercvs2git2012-06-24 12:13:13 (GMT)
commita46e9361040b3621c8bbadc91854fe9039245b53 (patch)
treeb7980e6c09c51affc4bc0283f896de24ab2162e6 /python3-dip.spec
downloadpython3-dip-a46e9361040b3621c8bbadc91854fe9039245b53.zip
python3-dip-a46e9361040b3621c8bbadc91854fe9039245b53.tar.gz
- new; requires PyQt4 built for python3
Changed files: python3-dip.spec -> 1.1
Diffstat (limited to 'python3-dip.spec')
-rw-r--r--python3-dip.spec55
1 files changed, 55 insertions, 0 deletions
diff --git a/python3-dip.spec b/python3-dip.spec
new file mode 100644
index 0000000..6a2a105
--- /dev/null
+++ b/python3-dip.spec
@@ -0,0 +1,55 @@
+Summary: Application Framework for Python 3 and PyQt
+Summary(pl.UTF-8): Szkielet dla aplikacji opartych na Pythonie 3 i PyQt
+Name: python3-dip
+Version: 0.3
+Release: 1
+License: GPL v2 with exception or commercial
+Group: Development/Languages/Python
+Source0: http://www.riverbankcomputing.com/static/Downloads/dip/dip-gpl-%{version}.tar.gz
+# Source0-md5: 581af6402d37678fe0013e71cab49d48
+URL: http://www.riverbankcomputing.com/static/Docs/dip/
+BuildRequires: python3-devel >= 3.2
+BuildRequires: rpm-pythonprov
+BuildRequires: rpmbuild(macros) >= 1.219
+Requires: python-modules
+Requires: python3-PyQt4 >= 4.7.5
+Requires: QtGui >= 4.6
+BuildArch: noarch
+BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+dip is an application framework for Python and PyQt.
+
+This version supports Python 3.x.
+
+%description -l pl.UTF-8
+dip to szkielet dla aplikacji opartych na Pythonie i PyQt.
+
+Ta wersja jest przeznaczona dla Pythona 3.x.
+
+%prep
+%setup -q -n dip-gpl-%{version}
+
+%build
+%{__python3} setup.py build
+
+%install
+rm -rf $RPM_BUILD_ROOT
+%{__python3} setup.py install \
+ --optimize=2 \
+ --root=$RPM_BUILD_ROOT
+
+# distinguish from python 2 version
+mv $RPM_BUILD_ROOT%{_bindir}/dip-automate{,-3}
+mv $RPM_BUILD_ROOT%{_bindir}/dip-builder{,-3}
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(644,root,root,755)
+%doc ChangeLog GPL-Exception.txt LICENSE-Commercial.txt NEWS README doc/_build/html
+%attr(755,root,root) %{_bindir}/dip-automate-3
+%attr(755,root,root) %{_bindir}/dip-builder-3
+%{py3_sitescriptdir}/dip
+%{py3_sitescriptdir}/dip_gpl-%{version}-py*.egg-info