summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Bogusz2022-03-12 09:51:04 (GMT)
committerJakub Bogusz2022-03-12 09:51:04 (GMT)
commit6028a54019aac67e2d1da1d76a2c48d1cb267bb8 (patch)
tree00e40e4a53090edbb153625d06986df7c1ff8699
parent70f05750bf5c878718b037bd7496ead3638e7332 (diff)
downloadpython-sphinx_rtd_theme-6028a54019aac67e2d1da1d76a2c48d1cb267bb8.zip
python-sphinx_rtd_theme-6028a54019aac67e2d1da1d76a2c48d1cb267bb8.tar.gz
- added docutils patch (allow docutils 0.18.x)
-rw-r--r--python-sphinx_rtd_theme-docutils.patch11
-rw-r--r--python-sphinx_rtd_theme.spec12
2 files changed, 18 insertions, 5 deletions
diff --git a/python-sphinx_rtd_theme-docutils.patch b/python-sphinx_rtd_theme-docutils.patch
new file mode 100644
index 0000000..ea5f6ef
--- /dev/null
+++ b/python-sphinx_rtd_theme-docutils.patch
@@ -0,0 +1,11 @@
+--- sphinx_rtd_theme-1.0.0/setup.py.orig 2021-09-13 21:18:57.000000000 +0200
++++ sphinx_rtd_theme-1.0.0/setup.py 2022-03-12 10:04:42.605720636 +0100
+@@ -119,7 +119,7 @@ setup(
+ python_requires='>=2.7,!=3.0.*,!=3.1.*,!=3.2.*,!=3.3.*',
+ install_requires=[
+ 'sphinx>=1.6',
+- 'docutils<0.18',
++ 'docutils<0.19',
+ ],
+ tests_require=[
+ 'pytest',
diff --git a/python-sphinx_rtd_theme.spec b/python-sphinx_rtd_theme.spec
index c5980f9..be555d9 100644
--- a/python-sphinx_rtd_theme.spec
+++ b/python-sphinx_rtd_theme.spec
@@ -8,13 +8,14 @@
Summary: ReadTheDocs.org theme for Sphinx
Summary(pl.UTF-8): Motyw ReadTheDocs.org dla Sphinksa
Name: python-%{module}
-Version: 0.4.3
-Release: 5
+Version: 1.0.0
+Release: 1
License: MIT
Group: Libraries/Python
#Source0Download: https://pypi.org/simple/sphinx_rtd_theme/
Source0: https://files.pythonhosted.org/packages/source/s/sphinx_rtd_theme/%{module}-%{version}.tar.gz
-# Source0-md5: 6c50f30bc39046f497d336039a0c13fa
+# Source0-md5: fdfc7d2e102cb96eca0f6155dde7403e
+Patch0: %{name}-docutils.patch
URL: https://github.com/snide/sphinx_rtd_theme/
BuildRequires: rpm-pythonprov
BuildRequires: rpmbuild(macros) >= 1.714
@@ -27,7 +28,7 @@ BuildRequires: python-readthedocs-sphinx-ext
%endif
%endif
%if %{with python3}
-BuildRequires: python3-modules >= 1:3.3
+BuildRequires: python3-modules >= 1:3.4
BuildRequires: python3-setuptools
%if %{with tests}
BuildRequires: python3-pytest
@@ -49,7 +50,7 @@ wykonany przez readthedocs.org.
Summary: ReadTheDocs.org theme for Sphinx
Summary(pl.UTF-8): Motyw ReadTheDocs.org dla Sphinksa
Group: Libraries/Python
-Requires: python3-modules >= 1:3.3
+Requires: python3-modules >= 1:3.4
%description -n python3-%{module}
This is a mobile-friendly Sphinx theme made for readthedocs.org.
@@ -60,6 +61,7 @@ wykonany przez readthedocs.org.
%prep
%setup -q -n %{module}-%{version}
+%patch0 -p1
%build
%if %{with python2}