summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArkadiusz Miƛkiewicz2005-06-29 14:12:08 (GMT)
committercvs2git2012-06-24 12:13:13 (GMT)
commite2bab32dc081ee906bb63729405604ce5a7e3b53 (patch)
treebf86ebba1ab4ecac04dccf4ce1794fb520704bf5
downloadpython-scipy-e2bab32dc081ee906bb63729405604ce5a7e3b53.zip
python-scipy-e2bab32dc081ee906bb63729405604ce5a7e3b53.tar.gz
- new
Changed files: python-scipy.spec -> 1.1
-rw-r--r--python-scipy.spec54
1 files changed, 54 insertions, 0 deletions
diff --git a/python-scipy.spec b/python-scipy.spec
new file mode 100644
index 0000000..949ec0f
--- /dev/null
+++ b/python-scipy.spec
@@ -0,0 +1,54 @@
+# TODO:
+# - atlas, lapack support
+# - rework files
+%define module scipy
+Summary: A library of scientific tools
+Name: python-%{module}
+Version: 0.3.2
+Release: 1
+License: BSD
+Group: Development/Languages/Python
+Source0: http://www.scipy.org/download/scipy/src/SciPy_complete-%{version}.tar.gz
+# Source0-md5: 5ae2280ab2c4c653cb0ff8479e81284a
+URL: http://www.scipy.org/
+BuildRequires: python
+BuildRequires: f2py
+BuildRequires: python-devel >= 1:2.3
+BuildRequires: python-numpy-devel
+BuildRequires: gcc-g77
+BuildRequires: X11-devel
+%pyrequires_eq python-modules
+BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+SciPy is an open source library of scientific tools for Python. SciPy
+supplements the popular Numeric module, gathering a variety of high
+level science and engineering modules together as a single package.
+
+%prep
+%setup -q -n SciPy_complete-%{version}
+
+%build
+CFLAGS="%{rpmcflags}"
+export CFLAGS
+python setup.py build
+
+%install
+rm -rf $RPM_BUILD_ROOT
+
+python setup.py install \
+ --root=$RPM_BUILD_ROOT \
+ --optimize=2
+
+find $RPM_BUILD_ROOT%{py_sitedir} -name '*.py' | \
+ grep -v examples | \
+ xargs rm
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(644,root,root,755)
+%doc DEVELOPERS.txt THANKS.txt
+%dir %{py_sitedir}/*
+%{py_sitedir}/*/*