summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorElan Ruusamäe2013-01-29 22:22:44 (GMT)
committerElan Ruusamäe2013-01-29 22:22:44 (GMT)
commit2ed233fb3f5c7cd96acbfc33ba3c9714a5373bdb (patch)
tree02003a41abc9884bbf9f4c80fd977f0e5d121c21
downloadpython-rbtools-2ed233fb3f5c7cd96acbfc33ba3c9714a5373bdb.zip
python-rbtools-2ed233fb3f5c7cd96acbfc33ba3c9714a5373bdb.tar.gz
new, version 0.4.3
based on fedora RBtools package efd52e12230ed1315df7fea005f3a026b149586c
-rw-r--r--no_ez_setup.patch27
-rw-r--r--python-rbtools.spec55
2 files changed, 82 insertions, 0 deletions
diff --git a/no_ez_setup.patch b/no_ez_setup.patch
new file mode 100644
index 0000000..dfe8c8b
--- /dev/null
+++ b/no_ez_setup.patch
@@ -0,0 +1,27 @@
+From 35f008977b773a850e929b285880397d19d93890 Mon Sep 17 00:00:00 2001
+From: Stephen Gallagher <sgallagh@redhat.com>
+Date: Mon, 15 Mar 2010 12:43:08 -0400
+Subject: [PATCH] Disable ez_setup when installing by RPM
+
+---
+ setup.py | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/setup.py b/setup.py
+index 7553c4a2e8c8288a2a9ba48ab4d7bcf7ad9ef44d..b21edbd9bf07cc0ea58a7f89c47acfe9151aade3 100755
+--- a/setup.py
++++ b/setup.py
+@@ -23,8 +23,8 @@
+ # OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+ # SOFTWARE.
+
+-from ez_setup import use_setuptools
+-use_setuptools()
++#from ez_setup import use_setuptools
++#use_setuptools()
+
+ from setuptools import setup, find_packages
+ from setuptools.command.test import test
+--
+1.8.1
+
diff --git a/python-rbtools.spec b/python-rbtools.spec
new file mode 100644
index 0000000..fab4949
--- /dev/null
+++ b/python-rbtools.spec
@@ -0,0 +1,55 @@
+%define module rbtools
+Summary: Tools for use with ReviewBoard
+Name: python-%{module}
+Version: 0.4.3
+Release: 1
+License: MIT
+Group: Applications/Networking
+Source0: http://downloads.reviewboard.org/releases/RBTools/0.4/RBTools-%{version}.tar.gz
+# Source0-md5: fc76cbe3a9f023a012966577bdd300d6
+Patch1001: no_ez_setup.patch
+URL: http://www.review-board.org/
+BuildRequires: python-devel
+BuildRequires: python-distribute
+BuildRequires: rpm-pythonprov
+BuildRequires: rpmbuild(macros) >= 1.219
+Requires: python-setuptools
+Requires: python-simplejson
+Obsoletes: RBTools
+BuildArch: noarch
+BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+RBTools provides client tools for interacting with a ReviewBoard
+code-review server.
+
+%prep
+%setup -q -n RBTools-%{version}
+%{__rm} -r RBTools*.egg-info
+%patch1001 -p1
+
+%build
+%{__python} setup.py build
+
+%install
+rm -rf $RPM_BUILD_ROOT
+%{__python} setup.py install \
+ --skip-build \
+ --optimize=2 \
+ --root=$RPM_BUILD_ROOT
+
+%py_postclean
+
+# While %{_bindir}/post-review also exists for this purpose,
+# it is still sensible to make postreview.py executable
+install -p rbtools/postreview.py $RPM_BUILD_ROOT%{py_sitescriptdir}/%{module}/postreview.py
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(644,root,root,755)
+%doc AUTHORS NEWS README
+%attr(755,root,root) %{_bindir}/post-review
+%{py_sitescriptdir}/%{module}
+%{py_sitescriptdir}/RBTools*.egg-info/