summaryrefslogtreecommitdiff
path: root/python-pyvorbis.spec
diff options
context:
space:
mode:
authordjrzulf2003-04-29 23:52:21 (GMT)
committercvs2git2012-06-24 12:13:13 (GMT)
commitb4298777904ffe7f11e8a9dadeec7306e92230c4 (patch)
treed4bae364639051ce751b5b69e8054200a6b4fbf8 /python-pyvorbis.spec
downloadpython-pyvorbis-b4298777904ffe7f11e8a9dadeec7306e92230c4.zip
python-pyvorbis-b4298777904ffe7f11e8a9dadeec7306e92230c4.tar.gz
- based on python-pyogg and alt linux,
Changed files: python-pyvorbis.spec -> 1.1
Diffstat (limited to 'python-pyvorbis.spec')
-rw-r--r--python-pyvorbis.spec70
1 files changed, 70 insertions, 0 deletions
diff --git a/python-pyvorbis.spec b/python-pyvorbis.spec
new file mode 100644
index 0000000..0303a6e
--- /dev/null
+++ b/python-pyvorbis.spec
@@ -0,0 +1,70 @@
+%include /usr/lib/rpm/macros.python
+%define module pyvorbis
+Name: python-%{module}
+Version: 1.2
+Release: 1
+Summary: A Python module for the the Ogg/Vorbis library
+Summary(pl): Moduł pythona do biblioteki Ogg/Vorbis
+Group: Libraries/Python
+License: GPL
+URL: http://www.andrewchatham.com/pyogg/
+Source0: http://www.andrewchatham.com/pyogg/download/%{module}-%{version}.tar.gz
+Requires: python-modules
+Requires: libvorbis
+Requires: python-pyogg
+BuildRequires: python-devel
+BuildRequires: libvorbis-devel
+BuildRequires: python-pyogg-devel
+BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+pyvorbis is a wrapper for libvorbis, a compressed audio format library.
+
+%description -l pl
+pyvorbis jest wrapperem dla biblioteki libvorbis, formatu skompresowanego.
+
+%package devel
+Summary: pyogg header and example programs
+Group: Development/Languages/Python
+Requires: %{name} = %{version}
+
+%description devel
+pyvorbis is a wrapper for libvorbis, a compressed audio format library.
+
+Install python-pyvorbis-devel if you need the API documentation and example
+programs.
+
+%description devel -l pl
+pyvorbis jest wrapperem dla biblioteki libvorbis, formatu skompresowanego.
+
+Zainstaluj tę paczkę jeśli potrzebujesz dokumentację API oraz przykładowe
+programy.
+
+%prep
+%setup -q -n %{module}-%{version}
+
+%build
+python config_unix.py --prefix %{_prefix}
+python setup.py config
+python setup.py build
+
+%install
+rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT%{py_incdir}/%{module}
+python setup.py install --root $RPM_BUILD_ROOT
+
+install -m644 src/*.h $RPM_BUILD_ROOT%{py_incdir}/%{module}
+chmod -x test/*
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(644,root,root,755)
+%{py_sitedir}/ogg
+%doc AUTHORS ChangeLog README NEWS
+
+%files devel
+%defattr(644,root,root,755)
+%{py_incdir}/%{module}
+%doc test/*