summaryrefslogtreecommitdiff
path: root/python-enum.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-enum.spec')
-rw-r--r--python-enum.spec16
1 files changed, 4 insertions, 12 deletions
diff --git a/python-enum.spec b/python-enum.spec
index 1db0660..2dd9422 100644
--- a/python-enum.spec
+++ b/python-enum.spec
@@ -66,32 +66,24 @@ Dokumentacja API %{module}.
%build
%if %{with python2}
-%{__python} setup.py build --build-base build-2 %{?with_tests:test}
+%py_build %{?with_tests:test}
%endif
%if %{with python3}
-%{__python3} setup.py build --build-base build-3 %{?with_tests:test}
+%py3_build %{?with_tests:test}
%endif
%install
rm -rf $RPM_BUILD_ROOT
%if %{with python2}
-%{__python} setup.py \
- build --build-base build-2 \
- install --skip-build \
- --optimize=2 \
- --root=$RPM_BUILD_ROOT
+%py_install
%py_postclean
%endif
%if %{with python3}
-%{__python3} setup.py \
- build --build-base build-3 \
- install --skip-build \
- --optimize=2 \
- --root=$RPM_BUILD_ROOT
+%py3_install
%endif