summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Bogusz2021-02-06 16:14:22 (GMT)
committerJakub Bogusz2021-02-06 16:14:22 (GMT)
commitb1958328809ccafdd1b967d54fb75cbf59c7c7cb (patch)
treec81dee56e866ac71ba6c27d56005f6ed01ccaae6
parent0a2b7beb2556c495a6cdd46fa041b6b2e9cfdf64 (diff)
downloadpython-blockdiag-b1958328809ccafdd1b967d54fb75cbf59c7c7cb.zip
python-blockdiag-b1958328809ccafdd1b967d54fb75cbf59c7c7cb.tar.gz
- disable network tests
-rw-r--r--python-blockdiag.spec8
1 files changed, 5 insertions, 3 deletions
diff --git a/python-blockdiag.spec b/python-blockdiag.spec
index 0134f0b..1a9f0ae 100644
--- a/python-blockdiag.spec
+++ b/python-blockdiag.spec
@@ -98,8 +98,9 @@ Funkcje:
%py_build
%if %{with tests}
+# disable tests requiring network
PYTHONPATH=$(pwd)/src \
-nosetests-%{py_ver} src/blockdiag/tests
+nosetests-%{py_ver} src/blockdiag/tests -e 'test_app_cleans_up_images|test_generate_diagram\.test_generate|ghostscript_not_found_test'
%endif
%endif
@@ -107,9 +108,10 @@ nosetests-%{py_ver} src/blockdiag/tests
%py3_build
%if %{with tests}
-# disable test which fails on utf-8 vs latin-1 inconsistency
+# disable tests requiring network
+# test_setup_inline_svg_is_true_with_multibytes fails on utf-8 vs latin-1 inconsistency
PYTHONPATH=$(pwd)/src \
-nosetests-%{py3_ver} src/blockdiag/tests -e test_setup_inline_svg_is_true_with_multibytes
+nosetests-%{py3_ver} src/blockdiag/tests -e 'test_app_cleans_up_images|test_generate_diagram\.test_generate|ghostscript_not_found_test|test_setup_inline_svg_is_true_with_multibytes'
%endif
%endif