summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJacek Konieczny2015-11-28 17:06:42 (GMT)
committerJacek Konieczny2015-11-28 17:06:42 (GMT)
commit747a9fbf4a2936806578b841f18b1781bc2b0c0d (patch)
treecc10e281afb0df85be4e2242eed39d81dbbcb5d1
parent0c138dae1f050a375a380335349a2c2b48b54eec (diff)
downloadpython-billiard-747a9fbf4a2936806578b841f18b1781bc2b0c0d.zip
python-billiard-747a9fbf4a2936806578b841f18b1781bc2b0c0d.tar.gz
automatic change: use py_build/py_install macros
-rw-r--r--python-billiard.spec16
1 files changed, 4 insertions, 12 deletions
diff --git a/python-billiard.spec b/python-billiard.spec
index 91980c7..23b2da0 100644
--- a/python-billiard.spec
+++ b/python-billiard.spec
@@ -78,7 +78,7 @@ Dokumentacja API %{module}.
%if %{with python2}
CC="%{__cc}" \
CFLAGS="%{rpmcppflags} %{rpmcflags}" \
-%{__python} setup.py build --build-base build-2 %{?with_tests:test}
+%py_build %{?with_tests:test}
%if %{with doc}
cd Doc
@@ -91,28 +91,20 @@ cd ..
%if %{with python3}
CC="%{__cc}" \
CFLAGS="%{rpmcppflags} %{rpmcflags}" \
-%{__python3} setup.py build --build-base build-3 %{?with_tests:test}
+%py3_build %{?with_tests:test}
%endif
%install
rm -rf $RPM_BUILD_ROOT
%if %{with python2}
-%{__python} setup.py \
- build --build-base build-2 \
- install --skip-build \
- --optimize=2 \
- --root=$RPM_BUILD_ROOT
+%py_install
%py_postclean
%endif
%if %{with python3}
-%{__python3} setup.py \
- build --build-base build-3 \
- install --skip-build \
- --optimize=2 \
- --root=$RPM_BUILD_ROOT
+%py3_install
%endif
%clean