summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbeorn2007-10-09 18:33:21 (GMT)
committercvs2git2012-06-24 12:13:13 (GMT)
commit273611e310ffb3dacea89a33d1e4fd088571e5e3 (patch)
tree6aa21b432518d1ed5ef364a552fb1b55a8c3bddb
downloadpython-POW-273611e310ffb3dacea89a33d1e4fd088571e5e3.zip
python-POW-273611e310ffb3dacea89a33d1e4fd088571e5e3.tar.gz
- initial
- builds and works, but needs support for Python 2.5 (egg-info) Changed files: python-POW.spec -> 1.1
-rw-r--r--python-POW.spec45
1 files changed, 45 insertions, 0 deletions
diff --git a/python-POW.spec b/python-POW.spec
new file mode 100644
index 0000000..1f226d5
--- /dev/null
+++ b/python-POW.spec
@@ -0,0 +1,45 @@
+%define module POW
+#
+Summary: OpenSSL bindings for Python
+Summary(pl.UTF-8): Interfejs OpenSSL dla Pythona
+Name: python-%{module}
+Version: 0.7
+Release: 0.1
+License: BSD
+Group: Libraries/Python
+Source0: http://dl.sourceforge.net/pow/%{module}-%{version}.tar.gz
+# Source0-md5: e2d83a9f564cfd0ea1e1aa6488a05247
+URL: http://sourceforge.net/projects/pow/
+BuildRequires: openssl-devel >= 0.9.6
+BuildRequires: python-devel >= 1:2.4
+BuildRequires: rpmbuild(macros) >= 1.219
+%pyrequires_eq python-modules
+BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+Python interface to the OpenSSL library.
+
+%description -l pl.UTF-8
+Interfejs Pythona do biblioteki OpenSSL.
+
+%prep
+%setup -q -n %{module}-%{version}
+
+%install
+rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT%{py_sitedir}
+
+python setup.py install \
+ --root=$RPM_BUILD_ROOT \
+ --optimize=2
+
+%py_postclean
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(644,root,root,755)
+%doc README docs/*.pdf
+%dir %{py_sitedir}/%{module}/*.py[co]
+%attr(755,root,root) %{py_sitedir}/%{module}/*.so