summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArtur Frysiak2006-11-03 10:33:34 (GMT)
committercvs2git2012-06-24 12:13:13 (GMT)
commit391f4966c74734e9bec98e4f8a3d6921b7f7577a (patch)
tree77d74737d7711c7d982ab129a0c9dadb0aec7348
parente1f08a4e6380cb2eaeb14b5f6f97db429dd676bb (diff)
downloadpython-IPy-391f4966c74734e9bec98e4f8a3d6921b7f7577a.zip
python-IPy-391f4966c74734e9bec98e4f8a3d6921b7f7577a.tar.gz
- initial versionauto/th/python-IPy-0_51-1
Changed files: python-IPy.spec -> 1.4
-rw-r--r--python-IPy.spec47
1 files changed, 23 insertions, 24 deletions
diff --git a/python-IPy.spec b/python-IPy.spec
index c2f120f..38fd355 100644
--- a/python-IPy.spec
+++ b/python-IPy.spec
@@ -1,45 +1,44 @@
-
-%define module IPy
-
-Summary: A Python module for handling IPv4 and IPv6 Addresses and Networks
-Summary(pl): Moduł języka Python do obsługi adresów i sieci IPv4 oraz IPv6
+%define module IPy
+Summary: Class and tools for handling of IPv4 and IPv6 addresses and networks
Name: python-%{module}
-Version: 0.42
+Version: 0.51
Release: 1
-License: GPL
+License: BSD
Group: Libraries/Python
-Source0: http://c0re.23.nu/c0de/IPy/%{module}-%{version}.tar.gz
-# Source0-md5: 76bb49482b8c99a49505331558d0eb71
-URL: http://c0re.23.nu/c0de/IPy/
-BuildRequires: python
-%pyrequires_eq python-modules
-BuildArch: noarch
+Source0: http://cheeseshop.python.org/packages/source/I/IPy/%{module}-%{version}.tar.gz
+# Source0-md5: 46328d18e7c4c6191a9ba7af7afc3e9e
+URL: http://software.inl.fr/trac/trac.cgi/wiki/IPy
+BuildRequires: python-devel >= 1:2.5
+BuildRequires: rpmbuild(macros) >= 1.174
+%pyrequires_eq python-modules
BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
%description
-A Python module for handling IPv4 and IPv6 Addresses and Networks.
-
-%description -l pl
-Moduł języka Python do obsługi adresów i sieci IPv4 oraz IPv6.
+The IP class allows a comfortable parsing and handling for most notations in
+use for IPv4 and IPv6 Addresses and Networks. It was greatly inspired bei
+RIPE's Perl module NET::IP's interface but doesn't share the Implementation. It
+doesn't share non-CIDR netmasks, so funky stuff lixe a netmask 0xffffff0f can't
+be done here.
%prep
%setup -q -n %{module}-%{version}
+
+%build
python setup.py build
%install
rm -rf $RPM_BUILD_ROOT
python setup.py install \
- --root=$RPM_BUILD_ROOT \
- --optimize=2
-
-%py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
-%py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
+ --single-version-externally-managed \
+ --optimize=2 \
+ --root $RPM_BUILD_ROOT
%clean
rm -rf $RPM_BUILD_ROOT
%files
%defattr(644,root,root,755)
-%doc example/*.py CHANGES README THANKS
-%{py_sitescriptdir}/*.py[co]
+%doc README AUTHORS COPYING
+%attr(755,root,root) %{py_sitescriptdir}/*.py[co]
+%{py_sitescriptdir}/*.egg-info