summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArkadiusz Miśkiewicz2013-04-29 20:43:08 (GMT)
committerArkadiusz Miśkiewicz2013-04-29 20:43:08 (GMT)
commit3526549d80c58915d3f725e8cac082aab5452d8f (patch)
treef7236c8fd05c990e7c78c904ff06b6545251451e
parent0d0bb80bf2d0745e6991a78327da498243fba93b (diff)
downloadpldnotify-3526549d80c58915d3f725e8cac082aab5452d8f.zip
pldnotify-3526549d80c58915d3f725e8cac082aab5452d8f.tar.gz
- handle github archive url (bitcoin.spec as example)
-rwxr-xr-xpldnotify.awk5
1 files changed, 5 insertions, 0 deletions
diff --git a/pldnotify.awk b/pldnotify.awk
index 5ad01fb..c16e759 100755
--- a/pldnotify.awk
+++ b/pldnotify.awk
@@ -278,6 +278,11 @@ function get_links(url,filename, errno,link,oneline,retval,odp,wholeodp,lowero
d("github tarball url, mungled url to: " url)
}
+ if (url ~/^(http|https):\/\/github.com\/.*\/(.*)\/archive\//) {
+ gsub("\/archive\/.*", "/tags", url)
+ d("github archive url, mungled url to: " url)
+ }
+
if (url ~/^(http|https):\/\/cgit\..*\/(.*)\/snapshot\//) {
gsub("\/snapshot\/.*", "/", url)
d("cgit snapshot tarball url, mungled url to: " url)