summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArkadiusz Miśkiewicz2013-02-17 17:42:58 (GMT)
committerArkadiusz Miśkiewicz2013-02-17 17:42:58 (GMT)
commit12c316e23f3d4ebf982037561bdd0b5b494dfd5d (patch)
treeb25645899d92b6cd9759cb365ca3f4d2018b5e26
parent3e915ae3607dbdd9d6acf940476dfd7e428aac1a (diff)
downloadpldnotify-12c316e23f3d4ebf982037561bdd0b5b494dfd5d.zip
pldnotify-12c316e23f3d4ebf982037561bdd0b5b494dfd5d.tar.gz
If link ends up with at least 2 digit version directory then we check for links inside that directory, too (catches phonon-backend-vlc.spec or other kde stuff).
-rwxr-xr-xpldnotify.awk7
1 files changed, 6 insertions, 1 deletions
diff --git a/pldnotify.awk b/pldnotify.awk
index 998488c..9d38d00 100755
--- a/pldnotify.awk
+++ b/pldnotify.awk
@@ -378,7 +378,12 @@ if (USE_PERL) {
continue
}
- retval = (retval " " link)
+ # link ends with at least 2 digit version
+ mlink = ""
+ if (link ~ /^.*\/[0-9\.]+[0-9]\/$/)
+ mlink = get_links(link)
+
+ retval = (retval " " link " " mlink)
d("href(\"\"): " link)
} else if (lowerodp ~ /href=[ \t]*'[^']*'/) {
sub(/[hH][rR][eE][fF]=[ \t]*'/,"href='",odp)