summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorradek2007-04-30 13:07:19 (GMT)
committercvs2git2012-06-24 12:13:13 (GMT)
commit38601a52620dfb46549b9f85d12dbace0b0bf446 (patch)
tree6b6e0eec4d11a5180ba45230b4e18acda9f7fee7
downloadperl-XML-RSS-Liberal-38601a52620dfb46549b9f85d12dbace0b0bf446.zip
perl-XML-RSS-Liberal-38601a52620dfb46549b9f85d12dbace0b0bf446.tar.gz
Changed files: perl-XML-RSS-Liberal.spec -> 1.1
-rw-r--r--perl-XML-RSS-Liberal.spec60
1 files changed, 60 insertions, 0 deletions
diff --git a/perl-XML-RSS-Liberal.spec b/perl-XML-RSS-Liberal.spec
new file mode 100644
index 0000000..2c9b50c
--- /dev/null
+++ b/perl-XML-RSS-Liberal.spec
@@ -0,0 +1,60 @@
+#
+# Conditional build:
+%bcond_without tests # do not perform "make test"
+#
+%include /usr/lib/rpm/macros.perl
+%define pdir XML
+%define pnam RSS-Liberal
+Summary: XML::RSS::Liberal - XML::RSS With A Liberal Parser
+#Summary(pl.UTF-8):
+Name: perl-XML-RSS-Liberal
+Version: 0.03_01
+Release: 1
+# same as perl
+License: GPL v1+ or Artistic
+Group: Development/Languages/Perl
+Source0: http://www.cpan.org/modules/by-authors/id/D/DM/DMAKI/XML-RSS-Liberal-0.03_01.tar.gz
+# Source0-md5: 2d626250801895d50a41e32aca6f0cd7
+URL: http://search.cpan.org/dist/XML-RSS-Liberal/
+BuildRequires: perl-devel >= 1:5.8.0
+BuildRequires: rpm-perlprov >= 4.1-13
+%if %{with tests}
+BuildRequires: perl(XML::Liberal)
+BuildRequires: perl-XML-RSS-LibXML >= 0.30
+%endif
+BuildArch: noarch
+BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+XML::RSS::Liberal is a subclass of XML::RSS::LibXML, for those of you who
+want to parse broken RSS files (as they often are). It uses XML::Liberal as
+its core parser, and therefore it can parse whatever broken XML you provided,
+so as long as XML::Liberal can tolerate it.
+
+# %description -l pl.UTF-8
+# TODO
+
+%prep
+%setup -q -n %{pdir}-%{pnam}-0.03
+
+%build
+%{__perl} Makefile.PL \
+ INSTALLDIRS=vendor
+%{__make}
+
+%{?with_tests:%{__make} test}
+
+%install
+rm -rf $RPM_BUILD_ROOT
+
+%{__make} install \
+ DESTDIR=$RPM_BUILD_ROOT
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(644,root,root,755)
+%doc Changes
+%{perl_vendorlib}/XML/RSS/*.pm
+%{_mandir}/man3/*