summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authoraredridel2011-05-11 02:25:07 (GMT)
committercvs2git2012-06-24 12:13:13 (GMT)
commitd77e991b10bd4eb887faf3fb0479ce9a797d062e (patch)
tree1035160613095578633f68e2bd577bc46cb60da2
downloadperl-Test-TCP-d77e991b10bd4eb887faf3fb0479ce9a797d062e.zip
perl-Test-TCP-d77e991b10bd4eb887faf3fb0479ce9a797d062e.tar.gz
Changed files: perl-Test-TCP.spec -> 1.1
-rw-r--r--perl-Test-TCP.spec59
1 files changed, 59 insertions, 0 deletions
diff --git a/perl-Test-TCP.spec b/perl-Test-TCP.spec
new file mode 100644
index 0000000..6587e6f
--- /dev/null
+++ b/perl-Test-TCP.spec
@@ -0,0 +1,59 @@
+#
+# Conditional build:
+%bcond_without tests # do not perform "make test"
+#
+%define pdir Test
+%define pnam TCP
+%include /usr/lib/rpm/macros.perl
+Summary: Test::TCP - testing TCP program
+#Summary(pl.UTF-8):
+Name: perl-Test-TCP
+Version: 1.12
+Release: 1
+# same as perl
+License: GPL v1+ or Artistic
+Group: Development/Languages/Perl
+Source0: http://www.cpan.org/modules/by-module/Test/%{pdir}-%{pnam}-%{version}.tar.gz
+# Source0-md5: 70a89d33fc35380711046b637246f99f
+# generic URL, check or change before uncommenting
+#URL: http://search.cpan.org/dist/Test-TCP/
+BuildRequires: perl-devel >= 1:5.8.0
+BuildRequires: rpm-perlprov >= 4.1-13
+%if %{with tests}
+BuildRequires: perl(Test::SharedFork) >= 0.14
+%endif
+BuildArch: noarch
+BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+Test::TCP is test utilities for TCP/IP programs.
+
+
+
+# %description -l pl.UTF-8
+# TODO
+
+%prep
+%setup -q -n %{pdir}-%{pnam}-%{version}
+
+%build
+%{__perl} Makefile.PL \
+ INSTALLDIRS=vendor
+%{__make}
+
+%{?with_tests:%{__make} test}
+
+%install
+rm -rf $RPM_BUILD_ROOT
+
+%{__make} pure_install \
+ DESTDIR=$RPM_BUILD_ROOT
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(644,root,root,755)
+%doc Changes README
+%{perl_vendorlib}/Test/*.pm
+%{_mandir}/man3/*