summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArkadiusz Miśkiewicz2011-09-25 12:59:47 (GMT)
committercvs2git2012-06-24 12:13:13 (GMT)
commitf945e87feae4e50bc28ba68520ee5bad7b6317db (patch)
treef9cf881448fcbaf684c1b89d4a311d807fe339e6
downloadperl-Qt4-f945e87feae4e50bc28ba68520ee5bad7b6317db.zip
perl-Qt4-f945e87feae4e50bc28ba68520ee5bad7b6317db.tar.gz
Changed files: perl-Qt4.spec -> 1.1
-rw-r--r--perl-Qt4.spec71
1 files changed, 71 insertions, 0 deletions
diff --git a/perl-Qt4.spec b/perl-Qt4.spec
new file mode 100644
index 0000000..bc56472
--- /dev/null
+++ b/perl-Qt4.spec
@@ -0,0 +1,71 @@
+
+%define _state stable
+%define orgname perlqt
+%define qtver 4.7.4
+
+# Conditional build:
+%bcond_with tests # do not perform "make test"
+#
+%include /usr/lib/rpm/macros.perl
+%define pdir PerlQt
+Summary: Qt4 - A Perl module interface to Qt4
+Summary(pl.UTF-8): Qt4 - interfejs Perla do Qt4
+Name: perl-Qt4
+Version: 4.7.1
+Release: 1
+License: GPL
+Group: Development/Languages/Perl
+Source0: ftp://ftp.kde.org/pub/kde/%{_state}/%{version}/src/%{orgname}-%{version}.tar.bz2
+# Source0-md5: 2f21df2a106d33c4ec626568e9c1d506
+URL: http://www.kde.org/
+BuildRequires: smokeqt-devel >= %{version}
+BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+This module provides bindings to the Qt 4 libraries for Perl.
+
+%description -l pl.UTF-8
+Moduł dostarcza dowiązania do Qt 4 dla Perla.
+
+# which package provides this?
+%define _noautoreq 'perl(Qt::_internal)'
+
+%prep
+%setup -q -n %{orgname}-%{version}
+
+%build
+install -d build
+cd build
+%cmake \
+ -DCUSTOM_PERL_SITE_ARCH_DIR=%{perl_vendorarch} \
+ ../
+%{__make}
+
+%install
+rm -rf $RPM_BUILD_ROOT
+
+%{__make} -C build/ install \
+ DESTDIR=$RPM_BUILD_ROOT \
+ kde_htmldir=%{_kdedocdir}
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%post -p /sbin/ldconfig
+%postun -p /sbin/ldconfig
+
+%files
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/prcc4_bin
+%attr(755,root,root) %{_bindir}/puic4
+%attr(755,root,root) %{_bindir}/qdbusxml2perl
+%{_includedir}/perlqt
+%{perl_vendorarch}/*.pm
+%dir %{perl_vendorarch}/QtCore4
+%{perl_vendorarch}/QtCore4/*.pm
+%dir %{perl_vendorarch}/auto
+%dir %{perl_vendorarch}/auto/*
+%attr(755,root,root) %{perl_vendorarch}/auto/*/*.so
+%dir %{_datadir}/perlqt
+%{_datadir}/perlqt/cmake
+%attr(755,root,root) %{_datadir}/perlqt/doxsubpp.pl