summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorradek2004-11-23 00:17:18 (GMT)
committercvs2git2012-06-24 12:13:13 (GMT)
commitda8c8555623c6f6be00f8e79574e86fef0d2214f (patch)
treedfa918a7e04ee953e329145a654f42aa7ffee709
downloadperl-NetAddr-IP-Count-AC-STABLE.zip
perl-NetAddr-IP-Count-AC-STABLE.tar.gz
Changed files: perl-NetAddr-IP-Count.spec -> 1.1
-rw-r--r--perl-NetAddr-IP-Count.spec56
1 files changed, 56 insertions, 0 deletions
diff --git a/perl-NetAddr-IP-Count.spec b/perl-NetAddr-IP-Count.spec
new file mode 100644
index 0000000..67d2d47
--- /dev/null
+++ b/perl-NetAddr-IP-Count.spec
@@ -0,0 +1,56 @@
+#
+# Conditional build:
+%bcond_without tests # do not perform "make test"
+#
+%include /usr/lib/rpm/macros.perl
+%define pdir NetAddr
+%define pnam IP-Count
+Summary: NetAddr::IP::Count - Count hosts in named subnets
+#Summary(pl):
+Name: perl-NetAddr-IP-Count
+Version: 2.01
+Release: 1
+License: unknown
+Group: Development/Languages/Perl
+Source0: http://www.cpan.org/modules/by-module/NetAddr/%{pdir}-%{pnam}-%{version}.tar.gz
+# Source0-md5: daeebeba0f1983f00faba52bbc076872
+BuildRequires: perl-devel >= 1:5.8.0
+BuildRequires: rpm-perlprov >= 4.1-13
+%if %{with tests}
+BuildRequires: perl-NetAddr-IP
+%endif
+BuildArch: noarch
+BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+This module implements a symplistic way to match individual IP Addresses
+to subnets. It can be used to, among other things, help analyze HTTPD
+logs.
+
+# %description -l pl
+# TODO
+
+%prep
+%setup -q -n %{pdir}-%{pnam}-%{version}
+
+%build
+%{__perl} Makefile.PL \
+ INSTALLDIRS=vendor
+%{__make}
+
+%{?with_tests:%{__make} test}
+
+%install
+rm -rf $RPM_BUILD_ROOT
+
+%{__make} install \
+ DESTDIR=$RPM_BUILD_ROOT
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(644,root,root,755)
+%doc Changes sample.pl
+%{perl_vendorlib}/NetAddr/IP/*.pm
+%{_mandir}/man3/*