summaryrefslogtreecommitdiff
path: root/perl-Net-CIDR.spec
diff options
context:
space:
mode:
authorElan Ruusamäe2005-06-08 10:30:31 (GMT)
committercvs2git2012-06-24 12:13:13 (GMT)
commit15e2d0ca8e82896516b762b88bdbb22fd2916c19 (patch)
tree10d1f312f228fada09b5dd030d86a80002870637 /perl-Net-CIDR.spec
downloadperl-Net-CIDR-15e2d0ca8e82896516b762b88bdbb22fd2916c19.zip
perl-Net-CIDR-15e2d0ca8e82896516b762b88bdbb22fd2916c19.tar.gz
- created using cpan2rpm and pldspan
Changed files: perl-Net-CIDR.spec -> 1.1
Diffstat (limited to 'perl-Net-CIDR.spec')
-rw-r--r--perl-Net-CIDR.spec49
1 files changed, 49 insertions, 0 deletions
diff --git a/perl-Net-CIDR.spec b/perl-Net-CIDR.spec
new file mode 100644
index 0000000..06291e4
--- /dev/null
+++ b/perl-Net-CIDR.spec
@@ -0,0 +1,49 @@
+#
+# Conditional build:
+%bcond_without tests # do not perform "make test"
+#
+%include /usr/lib/rpm/macros.perl
+%define pdir Net
+%define pnam CIDR
+Summary: Net::CIDR - Manipulate IPv4/IPv6 netblocks in CIDR notation
+Name: perl-Net-CIDR
+Version: 0.10
+Release: 0.1
+License: GPL v1+ or Artistic
+Group: Development/Languages/Perl
+Source0: http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
+# Source0-md5: 34811457393f13b7efc52ec9a2c8809d
+BuildRequires: perl-devel >= 1:5.8.0
+BuildRequires: rpm-perlprov >= 4.1-13
+BuildArch: noarch
+BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+The Net::CIDR package contains functions that manipulate lists of IP
+netblocks expressed in CIDR notation. The Net::CIDR functions handle
+both IPv4 and IPv6 addresses.
+
+%prep
+%setup -q -n %{pdir}-%{pnam}-%{version}
+
+%build
+%{__perl} Makefile.PL \
+ INSTALLDIRS=vendor
+%{__make}
+
+%{?with_tests:%{__make} test}
+
+%install
+rm -rf $RPM_BUILD_ROOT
+
+%{__make} install \
+ DESTDIR=$RPM_BUILD_ROOT
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(644,root,root,755)
+%doc Changes README
+%{perl_vendorlib}/Net/*.pm
+%{_mandir}/man3/*