summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Bogusz2002-12-07 00:42:37 (GMT)
committercvs2git2012-06-24 12:13:13 (GMT)
commita3414315a6ac81b9cf62528dafdd63653c614275 (patch)
tree4d55b2ec6759778b44e0977d85052217580f179b
parent6926fcb9769e7c63312854662ac0b958ef5bbb33 (diff)
downloadperl-Math-CDF-a3414315a6ac81b9cf62528dafdd63653c614275.zip
perl-Math-CDF-a3414315a6ac81b9cf62528dafdd63653c614275.tar.gz
- new
Changed files: perl-Math-CDF.spec -> 1.1
-rw-r--r--perl-Math-CDF.spec68
1 files changed, 68 insertions, 0 deletions
diff --git a/perl-Math-CDF.spec b/perl-Math-CDF.spec
new file mode 100644
index 0000000..ed3d7a6
--- /dev/null
+++ b/perl-Math-CDF.spec
@@ -0,0 +1,68 @@
+#
+# Conditional build:
+# _without_tests - do not perform "make test"
+#
+%include /usr/lib/rpm/macros.perl
+%define pdir Math
+%define pnam CDF
+Summary: Math::CDF - probabilities and quantiles for several statistical functions
+Summary(pl): Math::CDF - prawdopodobieństwa i kwantyle dla niektórych funkcji statystycznych
+Name: perl-Math-CDF
+Version: 0.1
+Release: 1
+# non-commercial because of some parts of DCDFLIB
+License: non-commercial
+Group: Development/Languages/Perl
+Source0: ftp://ftp.cpan.org/pub/CPAN/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
+Patch0: %{name}-system-dcdflib.patch
+BuildRequires: dcdflib.c-devel
+BuildRequires: perl >= 5.6
+BuildRequires: rpm-perlprov >= 3.0.3-16
+BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+This module provides a Perl interface to the DCDFLIB. Functions are
+available for 7 continuous distributions (Beta, Chi-square, F, Gamma,
+Normal, Poisson and T-distribution) and for two discrete distributions
+(Binomial and Negative Binomial). Optional non-centrality parameters
+are available for the Chi-square, F and T-distributions. Cumulative
+probabilities are available for all 9 distributions and quantile
+functions are available for the 7 continuous distributions.
+
+%description -l pl
+Ten moduł udostępnia perlowy interfejs do biblioteki DCDFLIB. Dostępne
+są funkcje dla 7 rozkładów ciągłych (Beta, Chi-kwadrat, F, Gamma,
+normalnego, Poissona, t Studenta) oraz dwóch dyskretnych (dwumianowego
+i odwrotnego dwumianowego). Dostępne są opcjonalne parametry
+niecentralności dla rozkładów Chi-kwadrat, F i t Studenta. Funkcje
+rozkładu prawdopodobieństwa są dostępne dla wszystkich 9 rozkładów, a
+funkcje kwantyli dla 7 ciągłych rozkładów.
+
+%prep
+%setup -q -n %{pdir}-%{pnam}-%{version}
+%patch -p1
+
+%build
+perl Makefile.PL
+%{__make} OPTIMIZE="%{rpmcflags}"
+
+%{!?_without_tests:%{__make} test}
+
+%install
+rm -rf $RPM_BUILD_ROOT
+
+%{__make} install \
+ DESTDIR=$RPM_BUILD_ROOT
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(644,root,root,755)
+%doc Changes README
+%{perl_sitearch}/Math/CDF.pm
+%dir %{perl_sitearch}/auto/Math/CDF
+%{perl_sitearch}/auto/Math/CDF/CDF.bs
+%attr(755,root,root) %{perl_sitearch}/auto/Math/CDF/CDF.so
+%{perl_sitearch}/auto/Math/CDF/autosplit.ix
+%{_mandir}/man3/*