summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Bogusz2015-02-04 18:55:51 (GMT)
committerJakub Bogusz2015-02-04 18:55:51 (GMT)
commit34cc5b7e30b02b6efb52e28614028421e8fcc2fb (patch)
treecbc8fc13f54df8a3fab9796acc3e483cc852e93a
downloadperl-List-AllUtils-34cc5b7e30b02b6efb52e28614028421e8fcc2fb.zip
perl-List-AllUtils-34cc5b7e30b02b6efb52e28614028421e8fcc2fb.tar.gz
-rw-r--r--perl-List-AllUtils.spec64
1 files changed, 64 insertions, 0 deletions
diff --git a/perl-List-AllUtils.spec b/perl-List-AllUtils.spec
new file mode 100644
index 0000000..b1669ba
--- /dev/null
+++ b/perl-List-AllUtils.spec
@@ -0,0 +1,64 @@
+#
+# Conditional build:
+%bcond_without tests # do not perform "make test"
+#
+%define pdir List
+%define pnam AllUtils
+%include /usr/lib/rpm/macros.perl
+Summary: List::AllUtils - combines List::Util and List::MoreUtils in one bite-sized package
+Summary(pl.UTF-8): List::AllUtils - połączenie List::Util oraz List::MoreUtils w jednym bałym pakiecie
+Name: perl-List-AllUtils
+Version: 0.09
+Release: 1
+License: Artistic v2.0
+Group: Development/Languages/Perl
+Source0: http://www.cpan.org/modules/by-module/List/%{pdir}-%{pnam}-%{version}.tar.gz
+# Source0-md5: 3e2dfeeef80c4e1952443c6b7d48583c
+URL: http://search.cpan.org/dist/List-AllUtils/
+BuildRequires: perl-devel >= 1:5.8.0
+BuildRequires: rpm-perlprov >= 4.1-13
+%if %{with tests}
+BuildRequires: perl-List-MoreUtils >= 0.28
+BuildRequires: perl-Scalar-List-Utils >= 1.31
+BuildRequires: perl-Test-Simple >= 0.88
+BuildRequires: perl-Test-Warnings
+%endif
+BuildArch: noarch
+BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+Are you sick of trying to remember whether a particular helper is
+defined in List::Util or List::MoreUtils? I sure am. Now you
+don't have to remember. This module will export all of the functions
+that either of those two modules defines.
+
+%description -l pl.UTF-8
+Jesteś zmęczony pamiętaniem, czy jakaś funkcja pomocnicza jest
+zdefiniowana w List::Util, czy List::MoreUtils? Ja tak. Teraz nie
+musisz pamiętać. Ten moduł eksportuje wszystkie funkcje definiowane
+przez dowolny z tych dwóch modułów.
+
+%prep
+%setup -q -n %{pdir}-%{pnam}-%{version}
+
+%build
+%{__perl} Makefile.PL \
+ INSTALLDIRS=vendor
+%{__make}
+
+%{?with_tests:%{__make} test}
+
+%install
+rm -rf $RPM_BUILD_ROOT
+
+%{__make} pure_install \
+ DESTDIR=$RPM_BUILD_ROOT
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(644,root,root,755)
+%doc Changes
+%{perl_vendorlib}/List/AllUtils.pm
+%{_mandir}/man3/List::AllUtils.3pm*