summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorradek2009-03-01 20:23:02 (GMT)
committercvs2git2012-06-24 12:13:13 (GMT)
commitc9709d2358ada86e00791be3db99a9a55c4977e5 (patch)
tree8c48c3aaeb20ffe8cb072335a1134f0ae8a31b68
downloadperl-Class-C3-Adopt-NEXT-c9709d2358ada86e00791be3db99a9a55c4977e5.zip
perl-Class-C3-Adopt-NEXT-c9709d2358ada86e00791be3db99a9a55c4977e5.tar.gz
- new
Changed files: perl-Class-C3-Adopt-NEXT.spec -> 1.1
-rw-r--r--perl-Class-C3-Adopt-NEXT.spec61
1 files changed, 61 insertions, 0 deletions
diff --git a/perl-Class-C3-Adopt-NEXT.spec b/perl-Class-C3-Adopt-NEXT.spec
new file mode 100644
index 0000000..f9b7161
--- /dev/null
+++ b/perl-Class-C3-Adopt-NEXT.spec
@@ -0,0 +1,61 @@
+#
+# Conditional build:
+%bcond_without tests # do not perform "make test"
+#
+%include /usr/lib/rpm/macros.perl
+%define pdir Class
+%define pnam C3-Adopt-NEXT
+Summary: Class::C3::Adopt::NEXT - make NEXT suck less
+#Summary(pl.UTF-8):
+Name: perl-Class-C3-Adopt-NEXT
+Version: 0.07
+Release: 1
+# same as perl
+License: GPL v1+ or Artistic
+Group: Development/Languages/Perl
+Source0: http://www.cpan.org/modules/by-module/Class/%{pdir}-%{pnam}-%{version}.tar.gz
+# Source0-md5: 717030a4d5abe25d494124dc935b1158
+URL: http://search.cpan.org/dist/Class-C3-Adopt-NEXT/
+BuildRequires: perl-devel >= 1:5.8.0
+BuildRequires: rpm-perlprov >= 4.1-13
+%if %{with tests}
+BuildRequires: perl-List-MoreUtils
+BuildRequires: perl-MRO-Compat
+BuildRequires: perl-Test-Exception
+%endif
+BuildArch: noarch
+BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+This module is intended as a drop-in replacement for NEXT, supporting the same
+interface, but using Class::C3 to do the hard work. You can then write new
+code without NEXT, and migrate individual source files to use Class::C3 or
+method modifiers as appropriate, at whatever pace you're comfortable with.
+
+# %description -l pl.UTF-8
+# TODO
+
+%prep
+%setup -q -n %{pdir}-%{pnam}-%{version}
+
+%build
+%{__perl} Makefile.PL \
+ INSTALLDIRS=vendor
+%{__make}
+
+%{?with_tests:%{__make} test}
+
+%install
+rm -rf $RPM_BUILD_ROOT
+
+%{__make} pure_install \
+ DESTDIR=$RPM_BUILD_ROOT
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(644,root,root,755)
+%doc Changes
+%{perl_vendorlib}/Class/C3/Adopt/*.pm
+%{_mandir}/man3/*