summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Bogusz2012-10-28 12:07:12 (GMT)
committerJakub Bogusz2012-10-28 12:07:12 (GMT)
commit01e89423c13632c8f92300e8ab3fdab5aeef5798 (patch)
tree511f44bb6a0e32e238717e372a1878995789ee25
downloadperl-CSS-Tiny-01e89423c13632c8f92300e8ab3fdab5aeef5798.zip
perl-CSS-Tiny-01e89423c13632c8f92300e8ab3fdab5aeef5798.tar.gz
-rw-r--r--perl-CSS-Tiny.spec62
1 files changed, 62 insertions, 0 deletions
diff --git a/perl-CSS-Tiny.spec b/perl-CSS-Tiny.spec
new file mode 100644
index 0000000..7428cd7
--- /dev/null
+++ b/perl-CSS-Tiny.spec
@@ -0,0 +1,62 @@
+#
+# Conditional build:
+%bcond_without tests # do not perform "make test"
+#
+%define pdir CSS
+%define pnam Tiny
+%include /usr/lib/rpm/macros.perl
+Summary: CSS::Tiny - Read/Write .css files with as little code as possible
+Summary(pl.UTF-8): CSS::Tiny - odczyt/zapis plików .css przy użyciu jak najmniejszego kodu
+Name: perl-CSS-Tiny
+Version: 1.19
+Release: 1
+# same as perl
+License: GPL v1+ or Artistic
+Group: Development/Languages/Perl
+Source0: http://www.cpan.org/modules/by-module/CSS/%{pdir}-%{pnam}-%{version}.tar.gz
+# Source0-md5: f3f2f3d67d35d0e2b4c3b53c8b3f9483
+URL: http://search.cpan.org/dist/CSS-Tiny/
+BuildRequires: perl-devel >= 1:5.8.0
+BuildRequires: rpm-perlprov >= 4.1-13
+%if %{with tests}
+BuildRequires: perl-Test-Simple >= 0.47
+%endif
+BuildArch: noarch
+BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+CSS::Tiny is a Perl class to read and write .css stylesheets with as
+little code as possible, reducing load time and memory overhead.
+CSS.pm requires about 2.6 meg of RAM to load, which is a large amount
+of overhead if you only want to do trivial things.
+
+%description -l pl.UTF-8
+CSS::Tiny to klasa Perla do odczytu i zapisu arkuszy styli .css przy
+użyciu jak najmniejszej ilości kodu, co zmniejsza czas ładowania i
+narzut pamięciowy. CSS.pm wymaga około 2.6MB RAM, co jest znacznym
+narzutem, jeśli chce się zrobić coś prostego.
+
+%prep
+%setup -q -n %{pdir}-%{pnam}-%{version}
+
+%build
+%{__perl} Makefile.PL \
+ INSTALLDIRS=vendor
+%{__make}
+
+%{?with_tests:%{__make} test}
+
+%install
+rm -rf $RPM_BUILD_ROOT
+
+%{__make} pure_install \
+ DESTDIR=$RPM_BUILD_ROOT
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(644,root,root,755)
+%doc Changes
+%{perl_vendorlib}/CSS/Tiny.pm
+%{_mandir}/man3/CSS::Tiny.3pm*