summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Bogusz2002-08-15 17:54:58 (GMT)
committercvs2git2012-06-24 12:13:13 (GMT)
commit82e16733e13b96ea131d9d08dc6e992ddda195ff (patch)
tree2292e47ee92f62aa14b0ec5379bdae5871a56ceb
downloadperl-Audio-SoundFile-82e16733e13b96ea131d9d08dc6e992ddda195ff.zip
perl-Audio-SoundFile-82e16733e13b96ea131d9d08dc6e992ddda195ff.tar.gz
Changed files: perl-Audio-SoundFile.spec -> 1.1
-rw-r--r--perl-Audio-SoundFile.spec64
1 files changed, 64 insertions, 0 deletions
diff --git a/perl-Audio-SoundFile.spec b/perl-Audio-SoundFile.spec
new file mode 100644
index 0000000..9ecc7dc
--- /dev/null
+++ b/perl-Audio-SoundFile.spec
@@ -0,0 +1,64 @@
+#
+# Conditional build:
+# _without_tests - do not perform "make test"
+%include /usr/lib/rpm/macros.perl
+%define pdir Audio
+%define pnam SoundFile
+Summary: Audio::SoundFile Perl module - interface to libsndfile, a sound I/O library
+Summary(pl): Moduł Perla Audio::SoundFile - interfejs do libsndfile
+Name: perl-Audio-SoundFile
+Version: 0.14
+Release: 1
+License: Artistic or GPL
+Group: Development/Languages/Perl
+Source0: ftp://ftp.cpan.org/pub/CPAN/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
+BuildRequires: libsndfile-devel
+BuildRequires: perl >= 5.6
+BuildRequires: perl-PDL
+BuildRequires: rpm-perlprov >= 3.0.3-16
+BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+This module provides interface to libsndfile. With this library, you
+will be able to read, write, and manipulate sound data of more than 10
+formats. Also, in addition to read/write interface using usual Perl
+scalar, this module provides interface using PDL object directly.
+Since PDL provides efficient method to handle large bytestream, sound
+processing is much faster if this module and PDL is used in pair.
+
+%description -l pl
+Ten moduł udostępnia interfejs do libsndfile. Biblioteka ta pozwala na
+odczyt, zapis i obróbkę danych dźwiękowych w ponad 10 formatach.
+Ponadto, oprócz interfejsu używającego perlowych skalarów, ten moduł
+udostępnia interfejs używający bezpośrednio obiektu PDL. Ponieważ PDL
+udostępnia wydajne sposoby na obsługę dużych strumieni danych,
+przetwarzanie dźwięku jest szybsze przy współpracy z PDL.
+
+%prep
+%setup -q -n %{pdir}-%{pnam}-%{version}
+
+%build
+perl Makefile.PL
+%{__make} OPTIMIZE="%{rpmcflags}"
+
+%{!?_without_tests:%{__make} test}
+
+%install
+rm -rf $RPM_BUILD_ROOT
+
+%{__make} install \
+ DESTDIR=$RPM_BUILD_ROOT
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(644,root,root,755)
+%doc README*
+%{perl_sitearch}/Audio/SoundFile.pm
+%{perl_sitearch}/Audio/SoundFile
+%dir %{perl_sitearch}/auto/Audio/SoundFile
+%dir %{perl_sitearch}/auto/Audio/SoundFile/*
+%{perl_sitearch}/auto/Audio/SoundFile/*/*.bs
+%attr(755,root,root) %{perl_sitearch}/auto/Audio/SoundFile/*/*.so
+%{_mandir}/man3/*