summaryrefslogtreecommitdiff
path: root/perl-Algorithm-Huffman.spec
diff options
context:
space:
mode:
authorradek2002-08-31 12:24:13 (GMT)
committercvs2git2012-06-24 12:13:13 (GMT)
commitba5ab7fbc251ef077ba2a0043500361a5929bd0c (patch)
tree46b1b6f8c955e382c4f5d855c7674ac70af627be /perl-Algorithm-Huffman.spec
downloadperl-Algorithm-Huffman-ba5ab7fbc251ef077ba2a0043500361a5929bd0c.zip
perl-Algorithm-Huffman-ba5ab7fbc251ef077ba2a0043500361a5929bd0c.tar.gz
- new, STBR
Changed files: perl-Algorithm-Huffman.spec -> 1.1
Diffstat (limited to 'perl-Algorithm-Huffman.spec')
-rw-r--r--perl-Algorithm-Huffman.spec57
1 files changed, 57 insertions, 0 deletions
diff --git a/perl-Algorithm-Huffman.spec b/perl-Algorithm-Huffman.spec
new file mode 100644
index 0000000..6792e09
--- /dev/null
+++ b/perl-Algorithm-Huffman.spec
@@ -0,0 +1,57 @@
+#
+# Conditional build:
+# _without_tests - do not perform "make test"
+%include /usr/lib/rpm/macros.perl
+%define pdir Algorithm
+%define pnam Huffman
+Summary: Algorithm::Huffman - Implementation of the Huffman algorithm
+Summary(pl): Algorithm::Huffman - Implementacja algorytmu Huffmana
+Name: perl-Algorithm-Huffman
+Version: 0.05
+Release: 1
+License: GPL/Artistic
+Group: Development/Languages/Perl
+Source0: ftp://ftp.cpan.org/pub/CPAN/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
+BuildRequires: perl >= 5.6
+BuildRequires: rpm-perlprov >= 3.0.3-26
+%if %{?_without_tests:0}%{!?_without_tests:1}
+BuildRequires: perl-Heap
+BuildRequires: perl-Scalar-List-Utils
+BuildRequires: perl-String-Random
+BuildRequires: perl-Test-Exception
+BuildRequires: perl-Test-ManyParams
+BuildRequires: perl-Test-Simple
+BuildRequires: perl-Tree-DAG_Node
+%endif
+BuildArch: noarch
+BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+This modules implements the huffman algorithm. The aim is to create
+a good coding scheme for a given list of different characters (or even
+strings) and their occurence numbers.
+
+# %description -l pl
+# TODO
+
+%prep
+%setup -q -n %{pdir}-%{pnam}-%{version}
+
+%build
+perl Makefile.PL
+%{__make}
+
+%{!?_without_tests:%{__make} test}
+
+%install
+rm -rf $RPM_BUILD_ROOT
+
+%{__make} install DESTDIR=$RPM_BUILD_ROOT
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(644,root,root,755)
+%{perl_sitelib}/%{pdir}/*.pm
+%{_mandir}/man3/*