summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Palus2024-02-27 11:08:24 (GMT)
committerJan Palus2024-02-27 11:08:24 (GMT)
commite4d01706a85a0c10752ae89ab409ac3cfbe8b4c4 (patch)
tree3b033d82f7799465dc3719490db2c69baaad1ba3
parentb347e04d4bdc44633a9bee02611ee11a610f5e5f (diff)
downloadpciutils-e4d01706a85a0c10752ae89ab409ac3cfbe8b4c4.zip
pciutils-e4d01706a85a0c10752ae89ab409ac3cfbe8b4c4.tar.gz
-rw-r--r--hwdata.patch4
-rw-r--r--pciutils-pci_h.patch4
-rw-r--r--pciutils-pcimodules.patch4
-rw-r--r--pciutils.spec6
4 files changed, 10 insertions, 8 deletions
diff --git a/hwdata.patch b/hwdata.patch
index a7fa8c7..c54bb42 100644
--- a/hwdata.patch
+++ b/hwdata.patch
@@ -12,8 +12,8 @@
--- pciutils-3.9.0/Makefile.orig 2022-12-16 10:21:43.588532476 +0100
+++ pciutils-3.9.0/Makefile 2022-12-16 10:23:46.251274298 +0100
@@ -152,11 +152,13 @@
- $(INSTALL) -c -m 755 $(STRIP) lspci$(EXEEXT) $(DESTDIR)$(LSPCIDIR)
$(INSTALL) -c -m 755 $(STRIP) setpci$(EXEEXT) $(DESTDIR)$(SBINDIR)
+ $(INSTALL) -c -m 755 $(STRIP) pcilmr$(EXEEXT) $(DESTDIR)$(SBINDIR)
$(INSTALL) -c -m 755 update-pciids $(DESTDIR)$(SBINDIR)
+ifneq ($(PCI_IDS),)
ifneq ($(IDSDIR),)
@@ -22,6 +22,6 @@
$(INSTALL) -c -m 644 $(PCI_IDS) $(DESTDIR)$(SBINDIR)
endif
+endif
- $(INSTALL) -c -m 644 lspci.8 setpci.8 update-pciids.8 $(DESTDIR)$(MANDIR)/man8
+ $(INSTALL) -c -m 644 lspci.8 setpci.8 pcilmr.8 update-pciids.8 $(DESTDIR)$(MANDIR)/man8
$(INSTALL) -c -m 644 pcilib.7 $(DESTDIR)$(MANDIR)/man7
$(INSTALL) -c -m 644 pci.ids.5 $(DESTDIR)$(MANDIR)/man5
diff --git a/pciutils-pci_h.patch b/pciutils-pci_h.patch
index 4741efd..2b35928 100644
--- a/pciutils-pci_h.patch
+++ b/pciutils-pci_h.patch
@@ -1,13 +1,13 @@
--- pciutils/pciutils.h.orig Sat Mar 30 16:39:24 2002
+++ pciutils/pciutils.h Sun Aug 18 21:51:27 2002
@@ -6,8 +6,8 @@
- * Can be freely distributed and used under the terms of the GNU GPL.
+ * SPDX-License-Identifier: GPL-2.0-or-later
*/
-#include "lib/pci.h"
-#include "lib/sysdep.h"
+#include "pci/pci.h"
+#include "pci/sysdep.h"
+ #include "bitops.h"
/*
- * gcc predefines macro __MINGW32__ for all MinGW targets.
diff --git a/pciutils-pcimodules.patch b/pciutils-pcimodules.patch
index 4bbd01b..5d5413b 100644
--- a/pciutils-pcimodules.patch
+++ b/pciutils-pcimodules.patch
@@ -4,8 +4,8 @@
export
--all: lib/$(PCIIMPLIB) lspci$(EXEEXT) setpci$(EXEEXT) example$(EXEEXT) lspci.8 setpci.8 pcilib.7 pci.ids.5 update-pciids update-pciids.8 $(PCI_IDS)
-+all: lib/$(PCIIMPLIB) lspci$(EXEEXT) setpci$(EXEEXT) pcimodules example$(EXEEXT) lspci.8 setpci.8 pcilib.7 pci.ids.5 update-pciids update-pciids.8 $(PCI_IDS)
+-all: lib/$(PCIIMPLIB) lspci$(EXEEXT) setpci$(EXEEXT) example$(EXEEXT) lspci.8 setpci.8 pcilib.7 pci.ids.5 update-pciids update-pciids.8 $(PCI_IDS) pcilmr$(EXEEXT) pcilmr.8
++all: lib/$(PCIIMPLIB) lspci$(EXEEXT) setpci$(EXEEXT) pcimodules example$(EXEEXT) lspci.8 setpci.8 pcilib.7 pci.ids.5 update-pciids update-pciids.8 $(PCI_IDS) pcilmr$(EXEEXT) pcilmr.8
lib/$(PCIIMPLIB): $(PCIINC) force
$(MAKE) -C lib all
diff --git a/pciutils.spec b/pciutils.spec
index cd2eb9d..51373b2 100644
--- a/pciutils.spec
+++ b/pciutils.spec
@@ -20,12 +20,12 @@ Summary(sv.UTF-8): PCI-bussrelaterade verktyg
Summary(uk.UTF-8): Утиліти роботи з PCI пристроями
Summary(zh_CN.UTF-8): PCI 总线相关的工具。
Name: pciutils
-Version: 3.10.0
+Version: 3.11.1
Release: 1
License: GPL v2+
Group: Applications/System
Source0: https://mj.ucw.cz/download/linux/pci/%{name}-%{version}.tar.gz
-# Source0-md5: ca53b87d2a94cdbbba6e09aca90924bd
+# Source0-md5: 0eec4c00519bfaf50012720c04cc7566
Source1: http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
# Source1-md5: 1ac48f433b1995044e14c24513992211
Patch0: %{name}-pci_h.patch
@@ -342,11 +342,13 @@ rm -rf $RPM_BUILD_ROOT
%defattr(644,root,root,755)
%doc ChangeLog README TODO
%attr(755,root,root) %{_sbindir}/lspci
+%attr(755,root,root) %{_sbindir}/pcilmr
%attr(755,root,root) %{_sbindir}/setpci
%attr(755,root,root) %{_sbindir}/pcimodules
%attr(755,root,root) %{_sbindir}/update-pciids
%{_mandir}/man7/pcilib.7*
%{_mandir}/man8/lspci.8*
+%{_mandir}/man8/pcilmr.8*
%{_mandir}/man8/setpci.8*
%{_mandir}/man8/update-pciids.8*
%lang(ja) %{_mandir}/ja/man8/*