summaryrefslogtreecommitdiff
path: root/patch-scripts.spec
diff options
context:
space:
mode:
authorArkadiusz Miƛkiewicz2004-06-27 13:09:58 (GMT)
committercvs2git2012-06-24 12:13:13 (GMT)
commitb69fb07a2ee56c2b9ca7fd58e82fcff599770146 (patch)
tree6eaa86d142f59ea03fa060c1007067e1da5fb5b3 /patch-scripts.spec
downloadpatch-scripts-b69fb07a2ee56c2b9ca7fd58e82fcff599770146.zip
patch-scripts-b69fb07a2ee56c2b9ca7fd58e82fcff599770146.tar.gz
- new
Changed files: patch-scripts.spec -> 1.1
Diffstat (limited to 'patch-scripts.spec')
-rw-r--r--patch-scripts.spec37
1 files changed, 37 insertions, 0 deletions
diff --git a/patch-scripts.spec b/patch-scripts.spec
new file mode 100644
index 0000000..9096068
--- /dev/null
+++ b/patch-scripts.spec
@@ -0,0 +1,37 @@
+%include /usr/lib/rpm/macros.perl
+Summary: Collection of scripts for managing patches
+Name: patch-scripts
+Version: 0.18
+Release: 1
+License: GPL
+Group: Applications/Text
+Source0: http://www.zip.com.au/~akpm/linux/patches/%{name}-%{version}/%{name}-%{version}.tar.gz
+# Source0-md5: 0987804e9486ddc1bb73bed78eedc5dc
+URL: http://www.zip.com.au/~akpm/linux/patches
+BuildRequires: rpm-perlprov >= 4.1-13
+BuildArch: noarch
+BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+Collection of scripts for managing patches (used for example for
+kernel patches managment).
+
+%prep
+%setup -q -n %{name}
+
+%install
+rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
+
+for f in *; do
+ [ -x "$f" -a ! -d "$f" ] && install "$f" $RPM_BUILD_ROOT%{_datadir}/%{name}/
+done
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(644,root,root,755)
+%doc *.txt
+%dir %{_datadir}/%{name}
+%attr(755,root,root) %{_datadir}/%{name}/*