summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Palus2024-04-09 18:25:50 (GMT)
committerJan Palus2024-04-09 18:25:50 (GMT)
commit2447b999abb3243f28e99568149c2d4192d2256c (patch)
tree578b5d285eeabd6bb5975a4adff0408ca9cefbc0
parent2f1798968c0b8712582a74826180e4a63d11d2b1 (diff)
downloadopenchange-2447b999abb3243f28e99568149c2d4192d2256c.zip
openchange-2447b999abb3243f28e99568149c2d4192d2256c.tar.gz
add fixes for samba >= 4.20
- compilation fix from fedora customized so it compiles with earlier samba versions too - adjusted link patch for new private library names
-rw-r--r--openchange-link.patch30
-rw-r--r--openchange.spec2
-rw-r--r--samba-4.20.patch463
3 files changed, 491 insertions, 4 deletions
diff --git a/openchange-link.patch b/openchange-link.patch
index 3882fb7..8ae0363 100644
--- a/openchange-link.patch
+++ b/openchange-link.patch
@@ -1,11 +1,33 @@
---- openchange-openchange-2.3-VULCAN/config.mk.in.orig 2015-05-22 23:30:25.141933097 +0200
-+++ openchange-openchange-2.3-VULCAN/config.mk.in 2015-05-22 23:30:28.665266286 +0200
-@@ -68,7 +68,7 @@
+--- openchange-openchange-2.3-VULCAN.orig/configure.ac 2024-04-09 11:55:51.678247965 +0200
++++ openchange-openchange-2.3-VULCAN/configure.ac 2024-04-09 20:15:46.847384577 +0200
+@@ -464,6 +464,18 @@
+ AC_CHECK_HEADER([samba/version.h],, AC_MSG_ERROR([Could not find Samba4 headers. Re-run ./configure with --with-samba=XXX where
+ XXX is the prefix that Samba4 was installed to.]))
+
++AC_MSG_CHECKING(samba private libraries suffix)
++samba_private_libdir="$($PKG_CONFIG --variable=libdir samba-hostconfig)/samba"
++if test -e "$samba_private_libdir/libndr-samba-private-samba.so"; then
++ SMB_PRIV_LIB_SFX=private-samba
++elif test -e "$samba_private_libdir/libndr-samba-samba4.so"; then
++ SMB_PRIV_LIB_SFX=samba4
++else
++ AC_MSG_ERROR([failed])
++fi
++AC_MSG_RESULT($SMB_PRIV_LIB_SFX)
++AC_SUBST(SMB_PRIV_LIB_SFX)
++
+ . `dirname $0`/script/samba4_ver.sh
+
+ OC_CHECK_SAMBA_VERSION([$SAMBA4_RELEASE],[$SAMBA4_GIT_VER-GIT-$SAMBA4_GIT_REV])
+--- openchange-openchange-2.3-VULCAN.orig/config.mk.in 2024-04-09 19:08:35.278698007 +0200
++++ openchange-openchange-2.3-VULCAN/config.mk.in 2024-04-09 18:58:37.035533217 +0200
+@@ -68,7 +68,8 @@
TALLOC_LIBS=@TALLOC_LIBS@
CFLAGS+=$(SAMBA_CFLAGS) $(LDB_CFLAGS) $(TALLOC_CFLAGS) $(TDB_CFLAGS) $(THREAD_CFLAGS) $(NANOMSG_CFLAGS)
-LIBS+=$(SAMBA_LIBS) $(LDB_LIBS) $(TALLOC_LIBS) $(THREAD_LIBS)
-+LIBS+=$(SAMBA_LIBS) $(LDB_LIBS) $(TALLOC_LIBS) $(THREAD_LIBS) -ltevent-util -lsamba-errors -lndr-krb5pac ${libdir}/samba/libcli-ldap-common-samba4.so ${libdir}/samba/libcliauth-samba4.so ${libdir}/samba/libdcerpc-samba-samba4.so ${libdir}/samba/libldbsamba-samba4.so ${libdir}/samba/libndr-samba-samba4.so ${libdir}/samba/libsamba-debug-samba4.so ${libdir}/samba/libsamba-security-samba4.so ${libdir}/samba/libsamdb-common-samba4.so
++SMB_PRIV_LIB_SFX=@SMB_PRIV_LIB_SFX@
++LIBS+=$(SAMBA_LIBS) $(LDB_LIBS) $(TALLOC_LIBS) $(THREAD_LIBS) -ltevent-util -lsamba-errors -lndr-krb5pac ${libdir}/samba/libcli-ldap-common-$(SMB_PRIV_LIB_SFX).so ${libdir}/samba/libcliauth-$(SMB_PRIV_LIB_SFX).so ${libdir}/samba/libdcerpc-samba-$(SMB_PRIV_LIB_SFX).so ${libdir}/samba/libldbsamba-$(SMB_PRIV_LIB_SFX).so ${libdir}/samba/libndr-samba-$(SMB_PRIV_LIB_SFX).so ${libdir}/samba/libsamba-debug-$(SMB_PRIV_LIB_SFX).so ${libdir}/samba/libsamba-security-$(SMB_PRIV_LIB_SFX).so ${libdir}/samba/libsamdb-common-$(SMB_PRIV_LIB_SFX).so
LDFLAGS+=@LDFLAGS@
THREAD_LIBS=@THREAD_LIBS@
diff --git a/openchange.spec b/openchange.spec
index dcd6082..eb5dc5c 100644
--- a/openchange.spec
+++ b/openchange.spec
@@ -31,6 +31,7 @@ Patch9: samba-4.11.patch
Patch10: samba-4.12.patch
Patch11: %{name}-nanomsg.patch
Patch12: samba-4.15.patch
+Patch13: samba-4.20.patch
URL: https://github.com/openchange
BuildRequires: QtCore-devel >= 4.3.0
BuildRequires: QtGui-devel >= 4.3.0
@@ -229,6 +230,7 @@ Wtyczka Nagiosa do sprawdzania usług Exchange/OpenChange.
%patch10 -p1
%patch11 -p1
%patch12 -p1
+%patch13 -p1
# no switch for verbose mode, enable manually :/
%{__sed} -i -e 's/^ @\(\$(\(PIDL\|CC\|CXX\|MOC\)\)/ \1/' Makefile
diff --git a/samba-4.20.patch b/samba-4.20.patch
new file mode 100644
index 0000000..1f9885d
--- /dev/null
+++ b/samba-4.20.patch
@@ -0,0 +1,463 @@
+diff --color -ur openchange-openchange-2.3-VULCAN.orig/asyncemsmdb.idl openchange-openchange-2.3-VULCAN/asyncemsmdb.idl
+--- openchange-openchange-2.3-VULCAN.orig/asyncemsmdb.idl 2015-05-16 17:22:04.000000000 +0200
++++ openchange-openchange-2.3-VULCAN/asyncemsmdb.idl 2024-04-09 12:13:43.642624178 +0200
+@@ -1,5 +1,6 @@
+ #include "idl_types.h"
+
++cpp_quote("#include <inttypes.h>")
+ cpp_quote("#include <gen_ndr/ndr_misc.h>")
+
+ [
+diff --color -ur openchange-openchange-2.3-VULCAN.orig/exchange.idl openchange-openchange-2.3-VULCAN/exchange.idl
+--- openchange-openchange-2.3-VULCAN.orig/exchange.idl 2024-04-09 11:55:51.644915544 +0200
++++ openchange-openchange-2.3-VULCAN/exchange.idl 2024-04-09 12:13:43.639290950 +0200
+@@ -1,6 +1,7 @@
+ #include "idl_types.h"
+
+ cpp_quote("#include <util/debug.h>")
++cpp_quote("#include <inttypes.h>")
+ cpp_quote("#include <gen_ndr/ndr_misc.h>")
+
+ /*
+diff --color -ur openchange-openchange-2.3-VULCAN.orig/libmapi/libmapi_private.h openchange-openchange-2.3-VULCAN/libmapi/libmapi_private.h
+--- openchange-openchange-2.3-VULCAN.orig/libmapi/libmapi_private.h 2024-04-09 11:55:51.604916638 +0200
++++ openchange-openchange-2.3-VULCAN/libmapi/libmapi_private.h 2024-04-09 12:17:25.852448420 +0200
+@@ -37,6 +37,12 @@
+ #include <gthread.h>
+ #endif
+
++#include <samba/version.h>
++
++#if SAMBA_VERSION_MAJOR == 4 && SAMBA_VERSION_MINOR < 20
++#define ndr_flags_type int
++#endif
++
+ #undef _PRINTF_ATTRIBUTE
+ #define _PRINTF_ATTRIBUTE(a1, a2) PRINTF_ATTRIBUTE(a1, a2)
+
+@@ -71,8 +77,8 @@
+ enum ndr_err_code ndr_pull_AppointmentRecurrencePattern(struct ndr_pull *, int, struct AppointmentRecurrencePattern *);
+ enum ndr_err_code ndr_push_PersistDataArray(struct ndr_push *ndr, int ndr_flags, const struct PersistDataArray *r);
+ enum ndr_err_code ndr_pull_PersistDataArray(struct ndr_pull *ndr, int ndr_flags, struct PersistDataArray *r);
+-enum ndr_err_code ndr_push_PersistElementArray(struct ndr_push *ndr, int ndr_flags, const struct PersistElementArray *r);
+-enum ndr_err_code ndr_pull_PersistElementArray(struct ndr_pull *ndr, int ndr_flags, struct PersistElementArray *r);
++enum ndr_err_code ndr_push_PersistElementArray(struct ndr_push *ndr, ndr_flags_type ndr_flags, const struct PersistElementArray *r);
++enum ndr_err_code ndr_pull_PersistElementArray(struct ndr_pull *ndr, ndr_flags_type ndr_flags, struct PersistElementArray *r);
+
+ /* The following private definitions come from libmapi/nspi.c */
+ int nspi_disconnect_dtor(void *);
+diff --color -ur openchange-openchange-2.3-VULCAN.orig/ndr_mapi.c openchange-openchange-2.3-VULCAN/ndr_mapi.c
+--- openchange-openchange-2.3-VULCAN.orig/ndr_mapi.c 2024-04-09 11:55:51.698247417 +0200
++++ openchange-openchange-2.3-VULCAN/ndr_mapi.c 2024-04-09 12:13:43.629291263 +0200
+@@ -207,7 +207,7 @@
+ }
+
+
+-_PUBLIC_ enum ndr_err_code ndr_pull_mapi2k7_request(struct ndr_pull *ndr, int ndr_flags, struct mapi2k7_request *r)
++_PUBLIC_ enum ndr_err_code ndr_pull_mapi2k7_request(struct ndr_pull *ndr, ndr_flags_type ndr_flags, struct mapi2k7_request *r)
+ {
+ if (ndr_flags & NDR_SCALARS) {
+ NDR_CHECK(ndr_pull_align(ndr, 4));
+@@ -258,7 +258,7 @@
+ }
+
+
+-_PUBLIC_ enum ndr_err_code ndr_pull_mapi2k7_response(struct ndr_pull *ndr, int ndr_flags, struct mapi2k7_response *r)
++_PUBLIC_ enum ndr_err_code ndr_pull_mapi2k7_response(struct ndr_pull *ndr, ndr_flags_type ndr_flags, struct mapi2k7_response *r)
+ {
+ if (ndr_flags & NDR_SCALARS) {
+ NDR_CHECK(ndr_pull_RPC_HEADER_EXT(ndr, NDR_SCALARS, &r->header));
+@@ -323,7 +323,7 @@
+ }
+
+
+-_PUBLIC_ enum ndr_err_code ndr_pull_AUX_HEADER(struct ndr_pull *ndr, int ndr_flags, struct AUX_HEADER *r)
++_PUBLIC_ enum ndr_err_code ndr_pull_AUX_HEADER(struct ndr_pull *ndr, ndr_flags_type ndr_flags, struct AUX_HEADER *r)
+ {
+ struct ndr_pull *_ndr_buffer;
+ uint32_t _flags_save_STRUCT = ndr->flags;
+@@ -358,7 +358,7 @@
+ }
+
+
+-_PUBLIC_ enum ndr_err_code ndr_push_AUX_HEADER(struct ndr_push *ndr, int ndr_flags, const struct AUX_HEADER *r)
++_PUBLIC_ enum ndr_err_code ndr_push_AUX_HEADER(struct ndr_push *ndr, ndr_flags_type ndr_flags, const struct AUX_HEADER *r)
+ {
+ uint32_t _flags_save_STRUCT = ndr->flags;
+ ndr_set_flags(&ndr->flags, LIBNDR_FLAG_NOALIGN);
+@@ -404,7 +404,7 @@
+ }
+
+
+-_PUBLIC_ enum ndr_err_code ndr_pull_mapi2k7_AuxInfo(struct ndr_pull *ndr, int ndr_flags, struct mapi2k7_AuxInfo *r)
++_PUBLIC_ enum ndr_err_code ndr_pull_mapi2k7_AuxInfo(struct ndr_pull *ndr, ndr_flags_type ndr_flags, struct mapi2k7_AuxInfo *r)
+ {
+ if (ndr_flags & NDR_SCALARS) {
+
+@@ -477,7 +477,7 @@
+ }
+
+
+-_PUBLIC_ enum ndr_err_code ndr_push_mapi2k7_AuxInfo(struct ndr_push *ndr, int ndr_flags, const struct mapi2k7_AuxInfo *r)
++_PUBLIC_ enum ndr_err_code ndr_push_mapi2k7_AuxInfo(struct ndr_push *ndr, ndr_flags_type ndr_flags, const struct mapi2k7_AuxInfo *r)
+ {
+ uint32_t i;
+
+@@ -594,7 +594,7 @@
+ (uint16_t) and next subtract when pushing the content blob
+ */
+
+-enum ndr_err_code ndr_push_mapi_request(struct ndr_push *ndr, int ndr_flags, const struct mapi_request *r)
++enum ndr_err_code ndr_push_mapi_request(struct ndr_push *ndr, ndr_flags_type ndr_flags, const struct mapi_request *r)
+ {
+ uint32_t cntr_mapi_req_0;
+ uint32_t count;
+@@ -614,7 +614,7 @@
+ return NDR_ERR_SUCCESS;
+ }
+
+-enum ndr_err_code ndr_push_mapi_response(struct ndr_push *ndr, int ndr_flags, const struct mapi_response *r)
++enum ndr_err_code ndr_push_mapi_response(struct ndr_push *ndr, ndr_flags_type ndr_flags, const struct mapi_response *r)
+ {
+ uint32_t cntr_mapi_repl_0;
+ uint32_t count;
+@@ -640,7 +640,7 @@
+ pull mapi_request / mapi_response from the wire
+ */
+
+-enum ndr_err_code ndr_pull_mapi_request(struct ndr_pull *ndr, int ndr_flags, struct mapi_request *r)
++enum ndr_err_code ndr_pull_mapi_request(struct ndr_pull *ndr, ndr_flags_type ndr_flags, struct mapi_request *r)
+ {
+ uint32_t length,count;
+ uint32_t cntr_mapi_req_0;
+@@ -687,7 +687,7 @@
+ return NDR_ERR_SUCCESS;
+ }
+
+-enum ndr_err_code ndr_pull_mapi_response(struct ndr_pull *ndr, int ndr_flags, struct mapi_response *r)
++enum ndr_err_code ndr_pull_mapi_response(struct ndr_pull *ndr, ndr_flags_type ndr_flags, struct mapi_response *r)
+ {
+ uint32_t length,count;
+ uint32_t cntr_mapi_repl_0;
+@@ -736,7 +736,7 @@
+ We stop processing the IDL if MAPISTATUS is different from MAPI_E_SUCCESS
+ */
+
+-_PUBLIC_ enum ndr_err_code ndr_push_EcDoRpc_MAPI_REPL(struct ndr_push *ndr, int ndr_flags, const struct EcDoRpc_MAPI_REPL *r)
++_PUBLIC_ enum ndr_err_code ndr_push_EcDoRpc_MAPI_REPL(struct ndr_push *ndr, ndr_flags_type ndr_flags, const struct EcDoRpc_MAPI_REPL *r)
+ {
+ if (r->opnum != op_MAPI_Release)
+ {
+@@ -790,7 +790,7 @@
+ return NDR_ERR_SUCCESS;
+ }
+
+-enum ndr_err_code ndr_pull_EcDoRpc_MAPI_REPL(struct ndr_pull *ndr, int ndr_flags, struct EcDoRpc_MAPI_REPL *r)
++enum ndr_err_code ndr_pull_EcDoRpc_MAPI_REPL(struct ndr_pull *ndr, ndr_flags_type ndr_flags, struct EcDoRpc_MAPI_REPL *r)
+ {
+ {
+ uint32_t _flags_save_STRUCT = ndr->flags;
+@@ -913,7 +913,7 @@
+ }
+
+
+-_PUBLIC_ enum ndr_err_code ndr_pull_EcDoRpc(struct ndr_pull *ndr, int flags, struct EcDoRpc *r)
++_PUBLIC_ enum ndr_err_code ndr_pull_EcDoRpc(struct ndr_pull *ndr, ndr_flags_type flags, struct EcDoRpc *r)
+ {
+ TALLOC_CTX *_mem_save_handle_0;
+ TALLOC_CTX *_mem_save_mapi_request_0;
+@@ -1006,7 +1006,7 @@
+ }
+
+
+-_PUBLIC_ enum ndr_err_code ndr_push_EcDoRpc(struct ndr_push *ndr, int flags, const struct EcDoRpc *r)
++_PUBLIC_ enum ndr_err_code ndr_push_EcDoRpc(struct ndr_push *ndr, ndr_flags_type flags, const struct EcDoRpc *r)
+ {
+ if (flags & NDR_IN) {
+ if (r->in.handle == NULL) {
+@@ -1068,7 +1068,7 @@
+ }
+
+
+-_PUBLIC_ enum ndr_err_code ndr_push_EcDoConnectEx(struct ndr_push *ndr, int flags, const struct EcDoConnectEx *r)
++_PUBLIC_ enum ndr_err_code ndr_push_EcDoConnectEx(struct ndr_push *ndr, ndr_flags_type flags, const struct EcDoConnectEx *r)
+ {
+ uint32_t cntr_rgwClientVersion_0;
+ uint32_t cntr_rgwServerVersion_0;
+@@ -1213,7 +1213,7 @@
+ return NDR_ERR_SUCCESS;
+ }
+
+-_PUBLIC_ enum ndr_err_code ndr_pull_EcDoConnectEx(struct ndr_pull *ndr, int flags, struct EcDoConnectEx *r)
++_PUBLIC_ enum ndr_err_code ndr_pull_EcDoConnectEx(struct ndr_pull *ndr, ndr_flags_type flags, struct EcDoConnectEx *r)
+ {
+ uint32_t _ptr_szDNPrefix;
+ uint32_t _ptr_szDisplayName;
+@@ -1452,7 +1452,7 @@
+ return NDR_ERR_SUCCESS;
+ }
+
+-_PUBLIC_ void ndr_print_EcDoConnectEx(struct ndr_print *ndr, const char *name, int flags, const struct EcDoConnectEx *r)
++_PUBLIC_ void ndr_print_EcDoConnectEx(struct ndr_print *ndr, const char *name, ndr_flags_type flags, const struct EcDoConnectEx *r)
+ {
+ uint32_t cntr_rgwClientVersion_0;
+ uint32_t cntr_rgwServerVersion_0;
+@@ -1587,7 +1587,7 @@
+ ndr->depth--;
+ }
+
+-_PUBLIC_ void ndr_print_EcDoRpcExt(struct ndr_print *ndr, const char *name, int flags, const struct EcDoRpcExt *r)
++_PUBLIC_ void ndr_print_EcDoRpcExt(struct ndr_print *ndr, const char *name, ndr_flags_type flags, const struct EcDoRpcExt *r)
+ {
+ DATA_BLOB rgbIn;
+ DATA_BLOB rgbOut;
+@@ -1705,7 +1705,7 @@
+ talloc_free(mem_ctx);
+ }
+
+-_PUBLIC_ void ndr_print_EcDoRpcExt2(struct ndr_print *ndr, const char *name, int flags, const struct EcDoRpcExt2 *r)
++_PUBLIC_ void ndr_print_EcDoRpcExt2(struct ndr_print *ndr, const char *name, ndr_flags_type flags, const struct EcDoRpcExt2 *r)
+ {
+ uint32_t cntr_rgbAuxOut_0;
+ DATA_BLOB rgbIn;
+@@ -1852,7 +1852,7 @@
+ If we have no results, do not push/pull the DATA_BLOB
+ */
+
+-enum ndr_err_code ndr_push_QueryRows_repl(struct ndr_push *ndr, int ndr_flags, const struct QueryRows_repl *r)
++enum ndr_err_code ndr_push_QueryRows_repl(struct ndr_push *ndr, ndr_flags_type ndr_flags, const struct QueryRows_repl *r)
+ {
+ {
+ uint32_t _flags_save_STRUCT = ndr->flags;
+@@ -1876,7 +1876,7 @@
+ return NDR_ERR_SUCCESS;
+ }
+
+-enum ndr_err_code ndr_pull_QueryRows_repl(struct ndr_pull *ndr, int ndr_flags, struct QueryRows_repl *r)
++enum ndr_err_code ndr_pull_QueryRows_repl(struct ndr_pull *ndr, ndr_flags_type ndr_flags, struct QueryRows_repl *r)
+ {
+ {
+ uint32_t _flags_save_STRUCT = ndr->flags;
+@@ -1906,7 +1906,7 @@
+ }
+
+
+-enum ndr_err_code ndr_push_Logon_req(struct ndr_push *ndr, int ndr_flags, const struct Logon_req *r)
++enum ndr_err_code ndr_push_Logon_req(struct ndr_push *ndr, ndr_flags_type ndr_flags, const struct Logon_req *r)
+ {
+ {
+ uint32_t _flags_save_STRUCT = ndr->flags;
+@@ -1933,7 +1933,7 @@
+ }
+
+ /* MoveFolder */
+-enum ndr_err_code ndr_push_MoveFolder_repl(struct ndr_push *ndr, int ndr_flags, const struct MoveFolder_repl *r)
++enum ndr_err_code ndr_push_MoveFolder_repl(struct ndr_push *ndr, ndr_flags_type ndr_flags, const struct MoveFolder_repl *r)
+ {
+ {
+ uint32_t _flags_save_STRUCT = ndr->flags;
+@@ -1952,7 +1952,7 @@
+ return NDR_ERR_SUCCESS;
+ }
+
+-enum ndr_err_code ndr_pull_MoveFolder_repl(struct ndr_pull *ndr, int ndr_flags, struct MoveFolder_repl *r)
++enum ndr_err_code ndr_pull_MoveFolder_repl(struct ndr_pull *ndr, ndr_flags_type ndr_flags, struct MoveFolder_repl *r)
+ {
+ {
+ uint32_t _flags_save_STRUCT = ndr->flags;
+@@ -1990,7 +1990,7 @@
+ /* /MoveFolder */
+
+ /* CopyFolder */
+-enum ndr_err_code ndr_push_CopyFolder_repl(struct ndr_push *ndr, int ndr_flags, const struct CopyFolder_repl *r)
++enum ndr_err_code ndr_push_CopyFolder_repl(struct ndr_push *ndr, ndr_flags_type ndr_flags, const struct CopyFolder_repl *r)
+ {
+ {
+ uint32_t _flags_save_STRUCT = ndr->flags;
+@@ -2009,7 +2009,7 @@
+ return NDR_ERR_SUCCESS;
+ }
+
+-enum ndr_err_code ndr_pull_CopyFolder_repl(struct ndr_pull *ndr, int ndr_flags, struct CopyFolder_repl *r)
++enum ndr_err_code ndr_pull_CopyFolder_repl(struct ndr_pull *ndr, ndr_flags_type ndr_flags, struct CopyFolder_repl *r)
+ {
+ {
+ uint32_t _flags_save_STRUCT = ndr->flags;
+@@ -2098,12 +2098,12 @@
+ * Fake wrapper over mapi_SRestriction. Workaround the no-pointer deep
+ * recursion problem in pidl
+ */
+-enum ndr_err_code ndr_push_mapi_SRestriction_wrap(struct ndr_push *ndr, int ndr_flags, const struct mapi_SRestriction_wrap *r)
++enum ndr_err_code ndr_push_mapi_SRestriction_wrap(struct ndr_push *ndr, ndr_flags_type ndr_flags, const struct mapi_SRestriction_wrap *r)
+ {
+ return ndr_push_mapi_SRestriction(ndr, ndr_flags, (struct mapi_SRestriction *)r);
+ }
+
+-enum ndr_err_code ndr_pull_mapi_SRestriction_wrap(struct ndr_pull *ndr, int ndr_flags, struct mapi_SRestriction_wrap *r)
++enum ndr_err_code ndr_pull_mapi_SRestriction_wrap(struct ndr_pull *ndr, ndr_flags_type ndr_flags, struct mapi_SRestriction_wrap *r)
+ {
+ return ndr_pull_mapi_SRestriction(ndr, ndr_flags, (struct mapi_SRestriction *)r);
+ }
+@@ -2117,13 +2117,13 @@
+ * Fake wrapper over mapi_SPropValue. Workaround the no-pointer deep
+ * recursion problem in pidl
+ */
+-enum ndr_err_code ndr_push_mapi_SPropValue_wrap(struct ndr_push *ndr, int ndr_flags, const struct mapi_SPropValue_wrap *r)
++enum ndr_err_code ndr_push_mapi_SPropValue_wrap(struct ndr_push *ndr, ndr_flags_type ndr_flags, const struct mapi_SPropValue_wrap *r)
+ {
+ NDR_CHECK(ndr_push_align(ndr, 8));
+ return ndr_push_mapi_SPropValue(ndr, NDR_SCALARS, (const struct mapi_SPropValue *)r);
+ }
+
+-enum ndr_err_code ndr_pull_mapi_SPropValue_wrap(struct ndr_pull *ndr, int ndr_flags, struct mapi_SPropValue_wrap *r)
++enum ndr_err_code ndr_pull_mapi_SPropValue_wrap(struct ndr_pull *ndr, ndr_flags_type ndr_flags, struct mapi_SPropValue_wrap *r)
+ {
+ return ndr_pull_mapi_SPropValue(ndr, NDR_SCALARS, (struct mapi_SPropValue *)r);
+ }
+@@ -2138,13 +2138,13 @@
+ * Fake wrapper over mapi_SPropValue_array. Workaround the no-pointer deep
+ * recursion problem in pidl
+ */
+-enum ndr_err_code ndr_push_mapi_SPropValue_array_wrap(struct ndr_push *ndr, int ndr_flags, const struct mapi_SPropValue_array_wrap *r)
++enum ndr_err_code ndr_push_mapi_SPropValue_array_wrap(struct ndr_push *ndr, ndr_flags_type ndr_flags, const struct mapi_SPropValue_array_wrap *r)
+ {
+ NDR_CHECK(ndr_push_align(ndr, 8));
+ return ndr_push_mapi_SPropValue_array(ndr, NDR_SCALARS, (const struct mapi_SPropValue_array *)r);
+ }
+
+-enum ndr_err_code ndr_pull_mapi_SPropValue_array_wrap(struct ndr_pull *ndr, int ndr_flags, struct mapi_SPropValue_array_wrap *r)
++enum ndr_err_code ndr_pull_mapi_SPropValue_array_wrap(struct ndr_pull *ndr, ndr_flags_type ndr_flags, struct mapi_SPropValue_array_wrap *r)
+ {
+ return ndr_pull_mapi_SPropValue_array(ndr, NDR_SCALARS, (struct mapi_SPropValue_array *)r);
+ }
+@@ -2154,7 +2154,7 @@
+ ndr_print_mapi_SPropValue_array(ndr, name, (const struct mapi_SPropValue_array *)r);
+ }
+
+-enum ndr_err_code ndr_push_RestrictionVariable(struct ndr_push *ndr, int ndr_flags, const union RestrictionVariable *r)
++enum ndr_err_code ndr_push_RestrictionVariable(struct ndr_push *ndr, ndr_flags_type ndr_flags, const union RestrictionVariable *r)
+ {
+ {
+ uint32_t _flags_save_STRUCT = ndr->flags;
+@@ -2200,7 +2200,7 @@
+ return NDR_ERR_SUCCESS;
+ }
+
+-enum ndr_err_code ndr_pull_RestrictionVariable(struct ndr_pull *ndr, int ndr_flags, union RestrictionVariable *r)
++enum ndr_err_code ndr_pull_RestrictionVariable(struct ndr_pull *ndr, ndr_flags_type ndr_flags, union RestrictionVariable *r)
+ {
+ uint32_t level;
+ TALLOC_CTX *_mem_save_res_0;
+@@ -2272,28 +2272,28 @@
+ }
+ }
+
+-enum ndr_err_code ndr_push_Release_req(struct ndr_push *ndr, int ndr_flags, const struct Release_req *r)
++enum ndr_err_code ndr_push_Release_req(struct ndr_push *ndr, ndr_flags_type ndr_flags, const struct Release_req *r)
+ {
+ return NDR_ERR_SUCCESS;
+ }
+
+-enum ndr_err_code ndr_pull_Release_req(struct ndr_pull *ndr, int ndr_flags, struct Release_req *r)
++enum ndr_err_code ndr_pull_Release_req(struct ndr_pull *ndr, ndr_flags_type ndr_flags, struct Release_req *r)
+ {
+ return NDR_ERR_SUCCESS;
+ }
+
+-enum ndr_err_code ndr_push_Release_repl(struct ndr_push *ndr, int ndr_flags, const struct Release_repl *r)
++enum ndr_err_code ndr_push_Release_repl(struct ndr_push *ndr, ndr_flags_type ndr_flags, const struct Release_repl *r)
+ {
+ return NDR_ERR_SUCCESS;
+ }
+
+-enum ndr_err_code ndr_pull_Release_repl(struct ndr_pull *ndr, int ndr_flags, struct Release_repl *r)
++enum ndr_err_code ndr_pull_Release_repl(struct ndr_pull *ndr, ndr_flags_type ndr_flags, struct Release_repl *r)
+ {
+ return NDR_ERR_SUCCESS;
+ }
+
+
+-enum ndr_err_code ndr_push_GetSearchCriteria_repl(struct ndr_push *ndr, int ndr_flags, const struct GetSearchCriteria_repl *r)
++enum ndr_err_code ndr_push_GetSearchCriteria_repl(struct ndr_push *ndr, ndr_flags_type ndr_flags, const struct GetSearchCriteria_repl *r)
+ {
+ uint32_t cntr_FolderIds_0;
+ {
+@@ -2324,7 +2324,7 @@
+ }
+
+
+-enum ndr_err_code ndr_pull_GetSearchCriteria_repl(struct ndr_pull *ndr, int ndr_flags, struct GetSearchCriteria_repl *r)
++enum ndr_err_code ndr_pull_GetSearchCriteria_repl(struct ndr_pull *ndr, ndr_flags_type ndr_flags, struct GetSearchCriteria_repl *r)
+ {
+ uint32_t cntr_FolderIds_0;
+ TALLOC_CTX *_mem_save_FolderIds_0;
+@@ -2392,42 +2392,42 @@
+ }
+ }
+
+-enum ndr_err_code ndr_push_Backoff_req(struct ndr_push *ndr, int ndr_flags, const struct Backoff_req *r)
++enum ndr_err_code ndr_push_Backoff_req(struct ndr_push *ndr, ndr_flags_type ndr_flags, const struct Backoff_req *r)
+ {
+ return NDR_ERR_SUCCESS;
+ }
+
+-enum ndr_err_code ndr_pull_Backoff_req(struct ndr_pull *ndr, int ndr_flags, struct Backoff_req *r)
++enum ndr_err_code ndr_pull_Backoff_req(struct ndr_pull *ndr, ndr_flags_type ndr_flags, struct Backoff_req *r)
+ {
+ return NDR_ERR_SUCCESS;
+ }
+
+-enum ndr_err_code ndr_push_Backoff_repl(struct ndr_push *ndr, int ndr_flags, const struct Backoff_repl *r)
++enum ndr_err_code ndr_push_Backoff_repl(struct ndr_push *ndr, ndr_flags_type ndr_flags, const struct Backoff_repl *r)
+ {
+ return NDR_ERR_SUCCESS;
+ }
+
+-enum ndr_err_code ndr_pull_Backoff_repl(struct ndr_pull *ndr, int ndr_flags, struct Backoff_repl *r)
++enum ndr_err_code ndr_pull_Backoff_repl(struct ndr_pull *ndr, ndr_flags_type ndr_flags, struct Backoff_repl *r)
+ {
+ return NDR_ERR_SUCCESS;
+ }
+
+-enum ndr_err_code ndr_push_BufferTooSmall_req(struct ndr_push *ndr, int ndr_flags, const struct BufferTooSmall_req *r)
++enum ndr_err_code ndr_push_BufferTooSmall_req(struct ndr_push *ndr, ndr_flags_type ndr_flags, const struct BufferTooSmall_req *r)
+ {
+ return NDR_ERR_SUCCESS;
+ }
+
+-enum ndr_err_code ndr_pull_BufferTooSmall_req(struct ndr_pull *ndr, int ndr_flags, struct BufferTooSmall_req *r)
++enum ndr_err_code ndr_pull_BufferTooSmall_req(struct ndr_pull *ndr, ndr_flags_type ndr_flags, struct BufferTooSmall_req *r)
+ {
+ return NDR_ERR_SUCCESS;
+ }
+
+-enum ndr_err_code ndr_push_BufferTooSmall_repl(struct ndr_push *ndr, int ndr_flags, const struct BufferTooSmall_repl *r)
++enum ndr_err_code ndr_push_BufferTooSmall_repl(struct ndr_push *ndr, ndr_flags_type ndr_flags, const struct BufferTooSmall_repl *r)
+ {
+ return NDR_ERR_SUCCESS;
+ }
+
+-enum ndr_err_code ndr_pull_BufferTooSmall_repl(struct ndr_pull *ndr, int ndr_flags, struct BufferTooSmall_repl *r)
++enum ndr_err_code ndr_pull_BufferTooSmall_repl(struct ndr_pull *ndr, ndr_flags_type ndr_flags, struct BufferTooSmall_repl *r)
+ {
+ return NDR_ERR_SUCCESS;
+ }
+@@ -2730,7 +2730,7 @@
+ return NDR_ERR_SUCCESS;
+ }
+
+-_PUBLIC_ enum ndr_err_code ndr_push_PersistElementArray(struct ndr_push *ndr, int ndr_flags, const struct PersistElementArray *r)
++_PUBLIC_ enum ndr_err_code ndr_push_PersistElementArray(struct ndr_push *ndr, ndr_flags_type ndr_flags, const struct PersistElementArray *r)
+ {
+ uint32_t cntr_lpPersistElement_1;
+ {
+@@ -2748,7 +2748,7 @@
+ return NDR_ERR_SUCCESS;
+ }
+
+-_PUBLIC_ enum ndr_err_code ndr_pull_PersistElementArray(struct ndr_pull *ndr, int ndr_flags, struct PersistElementArray *r)
++_PUBLIC_ enum ndr_err_code ndr_pull_PersistElementArray(struct ndr_pull *ndr, ndr_flags_type ndr_flags, struct PersistElementArray *r)
+ {
+ uint32_t cntr_lpPersistElement_0;
+ TALLOC_CTX *_mem_save_lpPersistElement_0;
+Only in openchange-openchange-2.3-VULCAN: ndr_mapi.c.orig