summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Rękorajski2019-11-02 21:30:44 (GMT)
committerJan Rękorajski2019-11-02 21:30:44 (GMT)
commit224a9b8cea9df2218e37815c2e345b1f6df201d5 (patch)
treecf469e6e80a07b6c856e27e9356a84a0eedeed1c
parent4db9cff8ec1abbbbb80786d245f37bb9f1f87078 (diff)
downloadopenchange-224a9b8cea9df2218e37815c2e345b1f6df201d5.zip
openchange-224a9b8cea9df2218e37815c2e345b1f6df201d5.tar.gz
- fix building with samba 4.11auto/th/openchange-2.3-44
- rel 44
-rw-r--r--openchange.spec4
-rw-r--r--samba-4.11.patch41
2 files changed, 44 insertions, 1 deletions
diff --git a/openchange.spec b/openchange.spec
index edb2c59..a7f84aa 100644
--- a/openchange.spec
+++ b/openchange.spec
@@ -12,7 +12,7 @@ Summary: OpenChange - portable implementation of MS Exchange Server and Exchange
Summary(pl.UTF-8): OpenChange - przenośna implementacja serwera oraz protokołów MS Exchange
Name: openchange
Version: 2.3
-Release: 43
+Release: 44
License: GPL v3+
Group: Libraries
Source0: https://github.com/openchange/openchange/archive/%{name}-%{version}-%{cname}.tar.gz
@@ -26,6 +26,7 @@ Patch5: samba-4.4.patch
Patch6: %{name}-covscan.patch
Patch7: %{name}-samba-4.10-macros.patch
Patch8: %{name}-libical.patch
+Patch9: samba-4.11.patch
URL: https://github.com/openchange
BuildRequires: QtCore-devel >= 4.3.0
BuildRequires: QtGui-devel >= 4.3.0
@@ -218,6 +219,7 @@ Wtyczka Nagiosa do sprawdzania usług Exchange/OpenChange.
%patch6 -p1
%patch7 -p1
%patch8 -p1
+%patch9 -p1
# no switch for verbose mode, enable manually :/
%{__sed} -i -e 's/^ @\(\$(\(PIDL\|CC\|CXX\|MOC\)\)/ \1/' Makefile
diff --git a/samba-4.11.patch b/samba-4.11.patch
new file mode 100644
index 0000000..b95a21f
--- /dev/null
+++ b/samba-4.11.patch
@@ -0,0 +1,41 @@
+diff -up openchange-openchange-2.3-VULCAN/exchange.idl.samba-4.11 openchange-openchange-2.3-VULCAN/exchange.idl
+--- openchange-openchange-2.3-VULCAN/exchange.idl.samba-4.11 2015-05-16 17:22:04.000000000 +0200
++++ openchange-openchange-2.3-VULCAN/exchange.idl 2019-08-30 07:23:02.172309353 +0200
+@@ -465,12 +465,12 @@ System Attendant Private Interface
+ would otherwise break the data alignment on wire operations.
+ However, they must be defined here as they make use of the same array types. */
+
+- typedef [nopush,nopull,noprint] struct {
++ typedef [public] struct {
+ [range(0,100000)] uint32 cValues;
+ [size_is(cValues)] hyper *lpui8;
+ } UI8Array_r;
+
+- typedef [switch_type(uint32),nopush,nopull,noprint] union {
++ typedef [switch_type(uint32)] union {
+ [case(PT_I2)] uint16 i;
+ [case(PT_LONG)] uint32 l;
+ [case(PT_DOUBLE)] double dbl;
+@@ -495,19 +495,19 @@ System Attendant Private Interface
+ [case(PT_OBJECT)] uint32 object;
+ } SPropValue_CTR;
+
+- typedef [public,noprint,nopush,nopull] struct {
++ typedef [public] struct {
+ MAPITAGS ulPropTag;
+ uint32 dwAlignPad;
+ [switch_is(ulPropTag & 0xFFFF)] SPropValue_CTR value;
+ } SPropValue;
+
+- typedef [public,noprint,nopush,nopull] struct {
++ typedef [public] struct {
+ uint32 ulAdrEntryPad;
+ [range(0,100000)] uint32 cValues;
+ [size_is(cValues)]SPropValue *lpProps;
+ } SRow;
+
+- typedef [public,noprint,nopush,nopull] struct {
++ typedef [public] struct {
+ [range(0,100000)] uint32 cRows;
+ [size_is(cRows)] SRow aRow[];
+ } SRowSet;