summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichal Moskal2004-01-26 12:32:09 (GMT)
committercvs2git2012-06-24 12:13:13 (GMT)
commit28268a84c4543d7e8e16f8d355ba701e33ae62e7 (patch)
tree9e0be04ba9f5808067cb31c33b18602dd14c7ab0
downloadnemerle-28268a84c4543d7e8e16f8d355ba701e33ae62e7.zip
nemerle-28268a84c4543d7e8e16f8d355ba701e33ae62e7.tar.gz
- initial
Changed files: nemerle.spec -> 1.1
-rw-r--r--nemerle.spec96
1 files changed, 96 insertions, 0 deletions
diff --git a/nemerle.spec b/nemerle.spec
new file mode 100644
index 0000000..6fb7761
--- /dev/null
+++ b/nemerle.spec
@@ -0,0 +1,96 @@
+%define _rev 1418
+Summary: Nemerle compiler
+Summary(pl): Kompilator języka Nemerle
+Name: nemerle
+Version: 0.0.1.%{_rev}
+Release: 1
+Epoch: 0
+License: BSD
+Group: Development/Languages
+Vendor: Nemerle Development Team <feedback@nemerle.org>
+Source0: http://nemerle.org/download/%{name}-%{_rev}.tar.gz
+# Source0-md5: f728c023ba373f2c55586e84c4086b39
+BuildArch: noarch
+URL: http://nemerle.org/
+Requires(post): mono >= 0.29
+Requires: mono >= 0.29
+BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+Nemerle is a new functional language designed from the ground up for
+the .NET platform. Nemerle supports: object oriented and imperative
+.NET concepts, variant datatypes, matching, higher order functions and
+powerful macro system. It has simple, C-like syntax and makes access
+to imperative features easy, and thus is easy to learn.
+
+%description -l pl
+Nemerle jest nowym językiem funkcjonalnym zaprojektowym od początku z
+myślą o platformie .NET. Nemerle wspiera programowanie obiektowe i
+imperatywne, typy wariantowe, dopasowanie wzorca, funkcje wyższych
+rzędów oraz poteżny system makr. Składnia Nemerle jest prosta,
+przypomina trochę C. Nemerle umożliwa łatwy dostęp do swych
+imperatywnych oraz obiektowych cech, co powinno ułatwić uczenie się
+go.
+
+%package libs
+Summary: Nemerle runtime environment
+Summary(pl): Środowisko uruchomieniowe języka Nemerle
+BuildArch: noarch
+Group: Libraries
+
+%description libs
+Libraries needed to run programs written in Nemerle.
+
+%description libs -l pl
+Biblioteki niezbędne do uruchamiania programów napisanych w Nemerle.
+
+%prep
+%setup -q -n %{name}-%{_rev}
+
+%build
+
+%install
+rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT{%{_libdir},%{_bindir}}
+
+install boot/*.dll $RPM_BUILD_ROOT%{_libdir}
+install lib/aliases.n $RPM_BUILD_ROOT%{_libdir}
+install boot/ncc.exe $RPM_BUILD_ROOT%{_bindir}
+
+for f in $RPM_BUILD_ROOT%{_bindir}/*.exe $RPM_BUILD_ROOT%{_libdir}/*.dll ; do
+ touch $f.so
+done
+
+cat > $RPM_BUILD_ROOT%{_bindir}/ncc <<EOF
+#!/bin/sh
+mono %{_bindir}/ncc.exe "\$@"
+EOF
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%post
+mono --aot %{_libdir}/Nemerle.Compiler.dll || :
+mono --aot %{_libdir}/stdmacros.dll || :
+mono --aot %{_bindir}/ncc.exe || :
+
+%post libs
+mono --aot %{_libdir}/Nemerle.dll || :
+
+%files
+%defattr(644,root,root,755)
+%doc AUTHORS README
+%attr(755,root,root) %{_bindir}/ncc
+%attr(755,root,root) %{_bindir}/ncc.exe
+%attr(755,root,root) %{_libdir}/stdmacros.dll
+%attr(755,root,root) %{_libdir}/Nemerle.Compiler.dll
+%{_libdir}/aliases.n
+%ghost %attr(755,root,root) %{_bindir}/ncc.exe.so
+%ghost %attr(755,root,root) %{_libdir}/stdmacros.dll.so
+%ghost %attr(755,root,root) %{_libdir}/Nemerle.Compiler.dll.so
+
+%files libs
+%defattr(644,root,root,755)
+%doc COPYRIGHT
+%attr(755,root,root) %{_libdir}/Nemerle.dll
+%ghost %attr(755,root,root) %{_libdir}/Nemerle.dll.so