summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorcvs2git2010-08-16 06:15:47 (GMT)
committercvs2git2012-06-24 12:13:13 (GMT)
commitb93024f8ff3725576b31bc4c946a2b1b7845e26c (patch)
tree09d1474b370bb34128e0863dc838dd1ca393b0b4
parentb39335d3fb34c7ea498e19dbf241909a46264f76 (diff)
downloadmpeg4ip-AC-branch.zip
mpeg4ip-AC-branch.tar.gz
This commit was manufactured by cvs2git to create branch 'AC-branch'.AC-branch
Sprout from master 2010-08-16 06:15:47 UTC Arkadiusz Miśkiewicz <arekm@maven.pl> '- release 14' Cherrypick from master 2006-12-09 15:08:07 UTC Elan Ruusamäe <glen@pld-linux.org> '- taken from gentoo portage': mpeg4ip-types.patch -> 1.11 mpeg4ip-x.patch -> 1.1 mpeg4ip-x264.patch -> 1.1
-rw-r--r--mpeg4ip-types.patch42
-rw-r--r--mpeg4ip-x.patch11
-rw-r--r--mpeg4ip-x264.patch67
3 files changed, 120 insertions, 0 deletions
diff --git a/mpeg4ip-types.patch b/mpeg4ip-types.patch
new file mode 100644
index 0000000..8f02a2f
--- /dev/null
+++ b/mpeg4ip-types.patch
@@ -0,0 +1,42 @@
+--- mpeg4ip-1.0/server/mp4live/util.cpp.orig Mon Aug 4 22:44:06 2003
++++ mpeg4ip-1.0/server/mp4live/util.cpp Wed Feb 25 13:24:57 2004
+@@ -36,7 +36,7 @@
+ gettimeofday(&thistime, NULL);
+ // To add date, add %a %b %d to strftime
+ strftime(buffer, sizeof(buffer), "%T", localtime(&thistime.tv_sec));
+- printf("%s.%03ld-mp4live-3: ", buffer, thistime.tv_usec / 1000);
++ printf("%s.%03ld-mp4live-3: ", buffer, (long)(thistime.tv_usec / 1000));
+ va_start(ap, fmt);
+ vprintf(fmt, ap);
+ va_end(ap);
+@@ -58,7 +58,7 @@
+ gettimeofday(&thistime, NULL);
+ // To add date, add %a %b %d to strftime
+ strftime(buffer, sizeof(buffer), "%T", localtime(&thistime.tv_sec));
+- printf("%s.%03ld-mp4live-7: ", buffer, thistime.tv_usec / 1000);
++ printf("%s.%03ld-mp4live-7: ", buffer, (long)(thistime.tv_usec / 1000));
+ va_start(ap, fmt);
+ vprintf(fmt, ap);
+ va_end(ap);
+--- mpeg4ip-1.5.0.1/player/plugin/audio/ffmpeg/ffmpeg.cpp~ 2006-12-09 13:55:42.291783229 +0200
++++ mpeg4ip-1.5.0.1/player/plugin/audio/ffmpeg/ffmpeg.cpp 2006-12-09 13:55:46.431876410 +0200
+@@ -166,7 +166,7 @@
+ break;
+ }
+ if (userdata) {
+- ffmpeg->m_c->extradata = (void *)userdata;
++ ffmpeg->m_c->extradata = (uint8_t *)userdata;
+ ffmpeg->m_c->extradata_size = ud_size;
+ }
+ if (avcodec_open(ffmpeg->m_c, ffmpeg->m_codec) < 0) {
+--- mpeg4ip-1.5.0.1/player/plugin/video/ffmpeg/ffmpeg.cpp~ 2006-02-22 02:25:17.000000000 +0200
++++ mpeg4ip-1.5.0.1/player/plugin/video/ffmpeg/ffmpeg.cpp 2006-12-09 13:58:14.675212917 +0200
+@@ -255,7 +255,7 @@
+ }
+ break;
+ case CODEC_ID_SVQ3:
+- ffmpeg->m_c->extradata = (void *)userdata;
++ ffmpeg->m_c->extradata = (uint8_t *)userdata;
+ ffmpeg->m_c->extradata_size = ud_size;
+ if (vinfo != NULL) {
+ ffmpeg->m_c->width = vinfo->width;
diff --git a/mpeg4ip-x.patch b/mpeg4ip-x.patch
new file mode 100644
index 0000000..36ae686
--- /dev/null
+++ b/mpeg4ip-x.patch
@@ -0,0 +1,11 @@
+--- mpeg4ip-1.5.0.1/player/src/Makefile.am.orig 2006-03-10 19:49:44.000000000 +0100
++++ mpeg4ip-1.5.0.1/player/src/Makefile.am 2006-07-21 21:23:47.092512250 +0200
+@@ -206,7 +206,7 @@
+ $(top_builddir)/lib/audio/libaudio.la \
+ $(top_builddir)/lib/ismacryp/libismacryp.la \
+ $(top_builddir)/lib/srtp/libsrtpif.la \
+- @SDL_LIBS@ @SRTPLIB@
++ @SDL_LIBS@ -lX11 @SRTPLIB@
+
+ gmp4player_LDFLAGS= $(SDL_AUDIO_FLAGS)
+ gmp4player_LDADD = $(mp4player_LDADD) \
diff --git a/mpeg4ip-x264.patch b/mpeg4ip-x264.patch
new file mode 100644
index 0000000..ff74651
--- /dev/null
+++ b/mpeg4ip-x264.patch
@@ -0,0 +1,67 @@
+--- mpeg4ip-1.5.0.1/server/mp4live/video_x264.cpp 2006-05-11 22:23:19.000000000 +0200
++++ /home/alexis/mpeg4ip/mpeg4ip/server/mp4live/video_x264.cpp 2006-09-29 21:55:42.000000000 +0200
+@@ -32,7 +32,9 @@
+
+ static config_index_t CFG_X264_FORCE_BASELINE;
+ static config_index_t CFG_X264_USE_CABAC;
++#ifndef HAVE_X264_PARAM_T_RC_I_RC_METHOD
+ static config_index_t CFG_X264_USE_CBR;
++#endif
+ static config_index_t CFG_X264_BIT_RATE_TOLERANCE;
+ static config_index_t CFG_X264_USE_VBV;
+ static config_index_t CFG_X264_VBV_BITRATE_MULT;
+@@ -44,7 +46,9 @@
+ static SConfigVariable X264EncoderVariables[] = {
+ CONFIG_BOOL(CFG_X264_FORCE_BASELINE, "x264ForceBaseline", false),
+ CONFIG_BOOL(CFG_X264_USE_CABAC, "x264UseCabac", true),
++#ifndef HAVE_X264_PARAM_T_RC_I_RC_METHOD
+ CONFIG_BOOL(CFG_X264_USE_CBR, "x264UseCbr", true),
++#endif
+ CONFIG_FLOAT(CFG_X264_BIT_RATE_TOLERANCE, "x264BitRateTolerance", 1.0),
+ CONFIG_BOOL(CFG_X264_USE_VBV, "x264UseVbv", false),
+ CONFIG_FLOAT(CFG_X264_VBV_BITRATE_MULT, "x264VbvBitRateMult", 1.0),
+@@ -56,7 +60,9 @@
+
+ GUI_BOOL(gui_baseline, CFG_X264_FORCE_BASELINE, "Force Baseline (overrides below)");
+ GUI_BOOL(gui_cabac, CFG_X264_USE_CABAC, "Use Cabac");
++#ifndef HAVE_X264_PARAM_T_RC_I_RC_METHOD
+ GUI_BOOL(gui_cbr, CFG_X264_USE_CBR, "Use CBR");
++#endif
+ GUI_BOOL(gui_bframe, CFG_VIDEO_USE_B_FRAMES, "Use B Frames");
+ GUI_INT_RANGE(gui_bframenum, CFG_VIDEO_NUM_OF_B_FRAMES, "Number of B frames", 1, 4);
+
+@@ -75,7 +81,9 @@
+ DECLARE_TABLE(x264_gui_options) = {
+ TABLE_GUI(gui_baseline),
+ TABLE_GUI(gui_cabac),
++#ifndef HAVE_X264_PARAM_T_RC_I_RC_METHOD
+ TABLE_GUI(gui_cbr),
++#endif
+ TABLE_GUI(gui_bframe),
+ TABLE_GUI(gui_bframenum),
+ TABLE_GUI(gui_brate),
+@@ -168,7 +176,11 @@
+ m_param.i_bframe = 0;
+ //debug_message("h264 b frames %d", m_param.i_bframe);
+ m_param.rc.i_bitrate = Profile()->GetIntegerValue(CFG_VIDEO_BIT_RATE);
++#ifndef HAVE_X264_PARAM_T_RC_I_RC_METHOD
+ m_param.rc.b_cbr = Profile()->GetBoolValue(CFG_X264_USE_CBR) ? 1 : 0;
++#else
++ m_param.rc.i_rc_method = X264_RC_ABR;
++#endif
+ m_param.rc.f_rate_tolerance = Profile()->GetFloatValue(CFG_X264_BIT_RATE_TOLERANCE);
+ if (Profile()->GetBoolValue(CFG_X264_USE_VBV)) {
+ if (Profile()->GetBoolValue(CFG_X264_FORCE_BASELINE)) {
+--- mpeg4ip-1.5.0.1/server/mp4live/video_x264.h.old 2006-11-11 20:56:48.000000000 +0100
++++ mpeg4ip-1.5.0.1/server/mp4live/video_x264.h 2006-11-11 20:57:49.000000000 +0100
+@@ -33,6 +33,10 @@
+ }
+ #endif
+
++#if X264_BUILD > 47
++#define HAVE_X264_PARAM_T_RC_I_RC_METHOD
++#endif
++
+ class CX264VideoEncoder : public CVideoEncoder {
+ public:
+ CX264VideoEncoder(CVideoProfile *vp,