summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mp3info-rmc-build.patch20
-rw-r--r--mp3info-rmc.spec6
2 files changed, 24 insertions, 2 deletions
diff --git a/mp3info-rmc-build.patch b/mp3info-rmc-build.patch
new file mode 100644
index 0000000..0316f3c
--- /dev/null
+++ b/mp3info-rmc-build.patch
@@ -0,0 +1,20 @@
+--- mp3info-0.8.5a/textfunc.c~ 2006-11-06 09:59:12.000000000 +0100
++++ mp3info-0.8.5a/textfunc.c 2015-12-12 23:22:24.349626380 +0100
+@@ -227,7 +227,7 @@ void format_output (char *format_string,
+
+ while((percent=strchr(format,'%'))) {
+ *percent=0;
+- printf(format);
++ printf("%s", format);
+ *percent='%';
+ code=percent+1;
+ while(*code && (code[0] != '%' && !isalpha(*code))) code++;
+@@ -354,7 +354,7 @@ void format_output (char *format_string,
+ }
+
+ }
+- printf(format);
++ printf("%s", format);
+ }
+
+
diff --git a/mp3info-rmc.spec b/mp3info-rmc.spec
index 89b7f95..5f8d77c 100644
--- a/mp3info-rmc.spec
+++ b/mp3info-rmc.spec
@@ -3,11 +3,12 @@ Summary(pl.UTF-8): Program do manipulowania znacznikami ID3 plików w formacie M
Summary(tr.UTF-8): MP3 ses dosyası bilgileri düzenleme aracı
Name: mp3info-rmc
Version: 0.8.5a
-Release: 5
+Release: 6
License: GPL v2+
Group: Applications/Sound
Source0: ftp://ftp.ibiblio.org/pub/linux/apps/sound/mp3-utils/mp3info/mp3info-%{version}.tgz
# Source0-md5: cb7b619a10a40aaac2113b87bb2b2ea2
+Patch0: %{name}-build.patch
URL: http://www.ibiblio.org/mp3info/
BuildRequires: gtk+2-devel >= 1:2.0
BuildRequires: ncurses-devel
@@ -43,11 +44,12 @@ formacie MP3.
%prep
%setup -q -n mp3info-%{version}
+%patch0 -p1
%build
%{__make} mp3info gmp3info \
CC="%{__cc}" \
- CFLAGS="%{rpmcflags} -I/usr/include/ncurses"
+ CFLAGS="%{rpmcppflags} %{rpmcflags} -I/usr/include/ncurses"
%install
rm -rf $RPM_BUILD_ROOT