summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArkadiusz Miśkiewicz2013-04-22 05:13:10 (GMT)
committerArkadiusz Miśkiewicz2013-04-22 05:13:10 (GMT)
commite25197c99404b0d636ede47050d68d23101a724f (patch)
tree725a84f9e7cbbcd78437451b240ad847fc220299
parentb4bade381f2daf10dd3422ff8da2b1d0a1cc3acf (diff)
downloadmlt-e25197c99404b0d636ede47050d68d23101a724f.zip
mlt-e25197c99404b0d636ede47050d68d23101a724f.tar.gz
- up to 0.8.8auto/th/mlt-0.8.8-1
-rw-r--r--ffmpeg10.patch60
-rw-r--r--mlt-linuxppc.patch68
-rw-r--r--mlt.spec12
3 files changed, 3 insertions, 137 deletions
diff --git a/ffmpeg10.patch b/ffmpeg10.patch
deleted file mode 100644
index b72ceb1..0000000
--- a/ffmpeg10.patch
+++ /dev/null
@@ -1,60 +0,0 @@
-commit 1a6470a0344e61c9561a637e370eb36bb0daf2d3
-Author: Dan Dennedy <dan@dennedy.org>
-Date: Wed Sep 19 10:02:28 2012 -0700
-
- fix build due to removal of deprecated encode() from AVCodec
-
-diff --git a/src/modules/avformat/consumer_avformat.c b/src/modules/avformat/consumer_avformat.c
-index 4b0896d..640e2b0 100644
---- a/src/modules/avformat/consumer_avformat.c
-+++ b/src/modules/avformat/consumer_avformat.c
-@@ -237,7 +237,9 @@ static int consumer_start( mlt_consumer consumer )
- mlt_properties_set_data( properties, "acodec", codecs, 0, (mlt_destructor) mlt_properties_close, NULL );
- mlt_properties_set_data( doc, "audio_codecs", codecs, 0, NULL, NULL );
- while ( ( codec = av_codec_next( codec ) ) )
--#if LIBAVCODEC_VERSION_INT >= ((54<<16)+(0<<8)+0)
-+#if LIBAVCODEC_VERSION_INT >= ((54<<16)+(56<<8)+100)
-+ if ( codec->encode2 && codec->type == CODEC_TYPE_AUDIO )
-+#elif LIBAVCODEC_VERSION_INT >= ((54<<16)+(0<<8)+0)
- if ( ( codec->encode || codec->encode2 ) && codec->type == CODEC_TYPE_AUDIO )
- #else
- if ( codec->encode && codec->type == CODEC_TYPE_AUDIO )
-@@ -261,7 +263,9 @@ static int consumer_start( mlt_consumer consumer )
- mlt_properties_set_data( properties, "vcodec", codecs, 0, (mlt_destructor) mlt_properties_close, NULL );
- mlt_properties_set_data( doc, "video_codecs", codecs, 0, NULL, NULL );
- while ( ( codec = av_codec_next( codec ) ) )
--#if LIBAVCODEC_VERSION_INT >= ((54<<16)+(0<<8)+0)
-+#if LIBAVCODEC_VERSION_INT >= ((54<<16)+(56<<8)+100)
-+ if ( codec->encode2 && codec->type == CODEC_TYPE_VIDEO )
-+#elif LIBAVCODEC_VERSION_INT >= ((54<<16)+(0<<8)+0)
- if ( (codec->encode || codec->encode2) && codec->type == CODEC_TYPE_VIDEO )
- #else
- if ( codec->encode && codec->type == CODEC_TYPE_VIDEO )
-commit a5f11c2ad1d4aab20a0b69ff167bded6455ced81
-Author: Dan Dennedy <dan@dennedy.org>
-Date: Sun Sep 23 16:39:25 2012 -0700
-
- fix build against libav master
-
-diff --git a/src/modules/avformat/consumer_avformat.c b/src/modules/avformat/consumer_avformat.c
-index 640e2b0..da7f7af 100644
---- a/src/modules/avformat/consumer_avformat.c
-+++ b/src/modules/avformat/consumer_avformat.c
-@@ -237,7 +237,7 @@ static int consumer_start( mlt_consumer consumer )
- mlt_properties_set_data( properties, "acodec", codecs, 0, (mlt_destructor) mlt_properties_close, NULL );
- mlt_properties_set_data( doc, "audio_codecs", codecs, 0, NULL, NULL );
- while ( ( codec = av_codec_next( codec ) ) )
--#if LIBAVCODEC_VERSION_INT >= ((54<<16)+(56<<8)+100)
-+#if (defined(FFUDIV) && LIBAVCODEC_VERSION_INT >= ((54<<16)+(56<<8)+100)) || (LIBAVCODEC_VERSION_INT >= ((54<<16)+(27<<8)+0))
- if ( codec->encode2 && codec->type == CODEC_TYPE_AUDIO )
- #elif LIBAVCODEC_VERSION_INT >= ((54<<16)+(0<<8)+0)
- if ( ( codec->encode || codec->encode2 ) && codec->type == CODEC_TYPE_AUDIO )
-@@ -263,7 +263,7 @@ static int consumer_start( mlt_consumer consumer )
- mlt_properties_set_data( properties, "vcodec", codecs, 0, (mlt_destructor) mlt_properties_close, NULL );
- mlt_properties_set_data( doc, "video_codecs", codecs, 0, NULL, NULL );
- while ( ( codec = av_codec_next( codec ) ) )
--#if LIBAVCODEC_VERSION_INT >= ((54<<16)+(56<<8)+100)
-+#if (defined(FFUDIV) && LIBAVCODEC_VERSION_INT >= ((54<<16)+(56<<8)+100)) || (LIBAVCODEC_VERSION_INT >= ((54<<16)+(27<<8)+0))
- if ( codec->encode2 && codec->type == CODEC_TYPE_VIDEO )
- #elif LIBAVCODEC_VERSION_INT >= ((54<<16)+(0<<8)+0)
- if ( (codec->encode || codec->encode2) && codec->type == CODEC_TYPE_VIDEO )
diff --git a/mlt-linuxppc.patch b/mlt-linuxppc.patch
deleted file mode 100644
index 25edbad..0000000
--- a/mlt-linuxppc.patch
+++ /dev/null
@@ -1,68 +0,0 @@
---- mlt-0.2.2/src/modules/avformat/consumer_avformat.c.bak 2005-11-10 13:26:32.000000000 +0100
-+++ mlt-0.2.2/src/modules/avformat/consumer_avformat.c 2006-12-17 17:20:28.252460177 +0100
-@@ -926,7 +926,7 @@
- n = ( width + 7 ) / 8;
- p = output->data[ 0 ] + i * output->linesize[ 0 ];
-
-- #ifndef __DARWIN__
-+ #ifndef __powerpc__
- p += 3;
- #endif
-
---- mlt-0.2.2/src/modules/motion_est/filter_motion_est.c.bak 2005-10-28 08:59:28.000000000 +0200
-+++ mlt-0.2.2/src/modules/motion_est/filter_motion_est.c 2006-12-17 17:21:35.389036545 +0100
-@@ -34,7 +34,7 @@
- #include <sys/time.h>
- #include <unistd.h>
-
--#ifndef __DARWIN__
-+#ifdef HAVE_SSE
- #include "sad_sse.h"
- #endif
-
-@@ -612,7 +612,7 @@
- } /* End column loop */
- } /* End row loop */
-
--#ifndef __DARWIN__
-+#ifdef HAVE_SSE
- asm volatile ( "emms" );
- #endif
-
-@@ -656,7 +656,7 @@
- static void init_optimizations( struct motion_est_context_s *c )
- {
- switch(c->mb_w){
--#ifndef __DARWIN__
-+#ifdef HAVE_SSE
- case 4: if(c->mb_h == 4) c->compare_optimized = sad_sse_422_luma_4x4;
- else c->compare_optimized = sad_sse_422_luma_4w;
- break;
---- mlt-0.2.2/configure.bak 2006-12-06 17:59:19.115902271 +0100
-+++ mlt-0.2.2/configure 2006-12-17 17:24:50.666713281 +0100
-@@ -74,6 +74,13 @@
- *)
- ;;
- esac
-+ case $targetarch in
-+ i386|x86_64)
-+ echo "CFLAGS+=-DHAVE_SSE"
-+ ;;
-+ *)
-+ ;;
-+ esac
- echo "LIBSUF=$LIBSUF"
- ) > config.mak
-
-@@ -135,6 +142,11 @@
- LIBSUF=".so"
- ;;
- esac
-+# Determine ARCH
-+targetarch=$(uname -m)
-+if expr $targetarch : 'i[3-9]86' >/dev/null; then
-+ targetarch=i386
-+fi
- export LIBSUF
-
- # Iterate through arguments
diff --git a/mlt.spec b/mlt.spec
index e97c13b..3d81bb7 100644
--- a/mlt.spec
+++ b/mlt.spec
@@ -6,15 +6,13 @@
Summary: MLT - open source multimedia framework
Summary(pl.UTF-8): MLT - szkielet multimedialny o otwartych źródłach
Name: mlt
-Version: 0.8.2
-Release: 2
+Version: 0.8.8
+Release: 1
License: GPL
Group: X11/Applications/Multimedia
Source0: http://downloads.sourceforge.net/mlt/%{name}-%{version}.tar.gz
-# Source0-md5: c7a8c4ca7485bb615cbcf851d8742a1c
+# Source0-md5: 06de4052cffd6760c468d7da9557edae
URL: http://www.mltframework.org/
-Patch0: %{name}-linuxppc.patch
-Patch1: ffmpeg10.patch
BuildRequires: QtGui-devel
BuildRequires: QtSvg-devel
BuildRequires: QtXml-devel
@@ -79,10 +77,6 @@ Ten pakiet zawiera pliki nagłówkowe dla MLT.
%prep
%setup -q
-%ifarch ppc ppc64
-%patch0 -p1
-%endif
-%patch1 -p1
%build
%configure \