summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArkadiusz Miśkiewicz2017-01-30 12:58:57 (GMT)
committerArkadiusz Miśkiewicz2017-01-30 12:58:57 (GMT)
commited5353efa6f61e52b843260f47afac3b69dbaef2 (patch)
treeaf2b7d8eff3b2000bbb880c0e4442c326967deb9
downloadlibyubikey-ed5353efa6f61e52b843260f47afac3b69dbaef2.zip
libyubikey-ed5353efa6f61e52b843260f47afac3b69dbaef2.tar.gz
- initial
-rw-r--r--libyubikey.spec72
1 files changed, 72 insertions, 0 deletions
diff --git a/libyubikey.spec b/libyubikey.spec
new file mode 100644
index 0000000..d1cf5fd
--- /dev/null
+++ b/libyubikey.spec
@@ -0,0 +1,72 @@
+%bcond_without tests
+#
+Summary: C library for decrypting and parsing Yubikey One-time passwords
+Name: libyubikey
+Version: 1.13
+Release: 1
+License: BSD
+Group: Development/Libraries
+Group: Libraries
+URL: http://opensource.yubico.com/yubico-c
+Source0: http://opensource.yubico.com/yubico-c/releases/%{name}-%{version}.tar.gz
+# Source0-md5: 6e84fc1914ab5b609319945c18d45835
+BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+This package holds a low-level C software development kit for the
+Yubico authentication device, the Yubikey.
+
+%package devel
+Summary: Development files for libyubikey
+Group: Development/Libraries
+Requires: %{name} = %{version}-%{release}
+
+%description devel
+This package contains the header file needed to develop applications
+that use libyubikey.
+
+%prep
+%setup -q
+
+%build
+%configure \
+ --disable-static \
+ --disable-silent-rules \
+
+%{__make}
+
+%if %{with tests}
+export LD_LIBRARY_PATH=$RPM_BUILD_DIR/%{name}-%{version}/.libs
+%{__make} check
+%endif
+
+%install
+rm -rf $RPM_BUILD_ROOT
+
+%{__make} install \
+ DESTDIR=$RPM_BUILD_ROOT \
+ INSTALL="%{__install} -p"
+
+%clean
+%{__rm} -rf $RPM_BUILD_ROOT
+
+%post -p /sbin/ldconfig
+%postun -p /sbin/ldconfig
+
+%files
+%defattr(644,root,root,755)
+%doc AUTHORS NEWS ChangeLog README
+%attr(755,root,root) %{_bindir}/modhex
+%attr(755,root,root) %{_bindir}/ykparse
+%attr(755,root,root) %{_bindir}/ykgenerate
+%attr(755,root,root) %ghost %{_libdir}/libyubikey.so.0
+%attr(755,root,root) %{_libdir}/libyubikey.so.*.*
+%{_mandir}/man1/ykgenerate.1*
+%{_mandir}/man1/ykparse.1*
+%{_mandir}/man1/modhex.1*
+
+%files devel
+%defattr(644,root,root,755)
+%{_includedir}/yubikey.h
+%attr(755,root,root) %{_libdir}/libyubikey.so
+%{_libdir}/libyubikey.la