summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Rękorajski2015-01-03 21:22:03 (GMT)
committerJan Rękorajski2015-01-03 21:22:03 (GMT)
commitedccab4246bbb12352efefb86b87e242ad366290 (patch)
tree0800f9c240857ffa3ff1e558ef2acb50e0ab08cc
parent1db5865d1ba97c64f72594b85ae853ae58c9a19c (diff)
downloadlibvoikko-edccab4246bbb12352efefb86b87e242ad366290.zip
libvoikko-edccab4246bbb12352efefb86b87e242ad366290.tar.gz
- fix building with gcc/c++ 4.9
-rw-r--r--gcc49.patch11
-rw-r--r--libvoikko.spec2
2 files changed, 13 insertions, 0 deletions
diff --git a/gcc49.patch b/gcc49.patch
new file mode 100644
index 0000000..3deb152
--- /dev/null
+++ b/gcc49.patch
@@ -0,0 +1,11 @@
+--- libvoikko-3.3.1/src/setup/DictionaryLoader.cpp~ 2011-02-22 05:06:57.000000000 +0000
++++ libvoikko-3.3.1/src/setup/DictionaryLoader.cpp 2015-01-03 21:20:27.634991966 +0000
+@@ -22,6 +22,8 @@
+ #include <string>
+ #include <fstream>
+ #include <cstdlib>
++#include <unistd.h>
++#include <sys/types.h>
+ #ifdef WIN32
+ # include <windows.h>
+ #else
diff --git a/libvoikko.spec b/libvoikko.spec
index ac53043..9a7baf1 100644
--- a/libvoikko.spec
+++ b/libvoikko.spec
@@ -12,6 +12,7 @@ License: GPL v2+
Group: Libraries
Source0: http://downloads.sourceforge.net/voikko/%{name}-%{version}.tar.gz
# Source0-md5: bb5f5b230651452c43201dffa36d2d0c
+Patch0: gcc49.patch
URL: http://voikko.sourceforge.net/
%{?with_hfst:BuildRequires: hfst-devel >= 2.4}
BuildRequires: libstdc++-devel
@@ -72,6 +73,7 @@ Statyczna biblioteka libvoikko.
%prep
%setup -q
+%patch0 -p1
%build
# NOTE: malaga compiled dictionaries are arch-dependent