summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Bogusz2015-07-05 19:20:32 (GMT)
committerJakub Bogusz2015-07-05 19:20:32 (GMT)
commitd6631e472281b7d5c7f87221fd5cc3d01fef1289 (patch)
tree9061cb66d0f37c8c8d6dc3cf06e3a3ffa43426ad
parent213a16b9442fc9afd95d7af4ac2b8e32a5275c87 (diff)
downloadlibsrtp2-d6631e472281b7d5c7f87221fd5cc3d01fef1289.zip
libsrtp2-d6631e472281b7d5c7f87221fd5cc3d01fef1289.tar.gz
- new Source0 URL, updated to 1.5.2 (soname changed to upstream value)
- updated rename_symbols patch - shared library is now supported upstream; shared patch replaced by just an install fix - use upstream .pc file
-rw-r--r--libsrtp.pc14
-rw-r--r--srtp-rename_functions.patch88
-rw-r--r--srtp-shared.patch291
-rw-r--r--srtp.spec54
4 files changed, 111 insertions, 336 deletions
diff --git a/libsrtp.pc b/libsrtp.pc
deleted file mode 100644
index e17a0df..0000000
--- a/libsrtp.pc
+++ /dev/null
@@ -1,14 +0,0 @@
-prefix=@PREFIX@
-exec_prefix=@PREFIX@
-libdir=@LIBDIR@
-includedir=@INCLUDEDIR@
-
-Name: libsrtp
-Description: Secure Real-time Transport Protocol library
-Version: 1.4.4
-URL: http://srtp.sourceforge.net
-Requires:
-Conflicts:
-Libs: -L${libdir} -lsrtp
-Libs.private:
-Cflags: -I${includedir}/srtp/
diff --git a/srtp-rename_functions.patch b/srtp-rename_functions.patch
index a5a2a03..6c07d3f 100644
--- a/srtp-rename_functions.patch
+++ b/srtp-rename_functions.patch
@@ -124,7 +124,29 @@ diff --git a/crypto/include/sha1.h b/crypto/include/sha1.h
index e3af4d4..af59b7e 100644
--- a/crypto/include/sha1.h
+++ b/crypto/include/sha1.h
-@@ -65,7 +65,7 @@ typedef struct {
+@@ -72,18 +72,18 @@ typedef EVP_MD_CTX sha1_ctx_t;
+ *
+ */
+
+-static inline void sha1_init (sha1_ctx_t *ctx)
++static inline void srtp_sha1_init (sha1_ctx_t *ctx)
+ {
+ EVP_MD_CTX_init(ctx);
+ EVP_DigestInit(ctx, EVP_sha1());
+ }
+
+-static inline void sha1_update (sha1_ctx_t *ctx, const uint8_t *M, int octets_in_msg)
++static inline void srtp_sha1_update (sha1_ctx_t *ctx, const uint8_t *M, int octets_in_msg)
+ {
+ EVP_DigestUpdate(ctx, M, octets_in_msg);
+ }
+
+-static inline void sha1_final (sha1_ctx_t *ctx, uint32_t *output)
++static inline void srtp_sha1_final (sha1_ctx_t *ctx, uint32_t *output)
+ {
+ unsigned int len = 0;
+
+@@ -107,7 +107,7 @@
*/
void
@@ -133,7 +155,7 @@ index e3af4d4..af59b7e 100644
/*
* sha1_init(&ctx) initializes the SHA1 context ctx
-@@ -79,13 +79,13 @@ sha1(const uint8_t *message, int octets_in_msg, uint32_t output[5]);
+@@ -121,13 +121,13 @@
*/
void
@@ -150,14 +172,15 @@ index e3af4d4..af59b7e 100644
/*
* The sha1_core function is INTERNAL to SHA-1, but it is declared
-@@ -103,6 +103,6 @@ sha1_final(sha1_ctx_t *ctx, uint32_t output[5]);
+@@ -145,7 +145,7 @@
*/
void
-sha1_core(const uint32_t M[16], uint32_t hash_value[5]);
+srtp_sha1_core(const uint32_t M[16], uint32_t hash_value[5]);
+
+ #endif /* else OPENSSL */
- #endif /* SHA1_H */
diff --git a/crypto/test/sha1_driver.c b/crypto/test/sha1_driver.c
index 6036022..f29d76e 100644
--- a/crypto/test/sha1_driver.c
@@ -175,3 +198,60 @@ index 6036022..f29d76e 100644
if (0 == memcmp(test_case->hash, hash_value, 20)) {
#if VERBOSE
printf("PASSED: reference value: %s\n",
+--- libsrtp-1.5.2/crypto/hash/hmac_ossl.c.orig 2015-03-11 15:02:12.000000000 +0100
++++ libsrtp-1.5.2/crypto/hash/hmac_ossl.c 2015-07-05 20:23:10.490406837 +0200
+@@ -163,11 +163,11 @@ hmac_init (hmac_ctx_t *state, const uint
+ debug_print(mod_hmac, "ipad: %s", octet_string_hex_string(ipad, sizeof(ipad)));
+
+ /* initialize sha1 context */
+- sha1_init(&state->init_ctx);
++ srtp_sha1_init(&state->init_ctx);
+ state->init_ctx_initialized = 1;
+
+ /* hash ipad ^ key */
+- sha1_update(&state->init_ctx, ipad, sizeof(ipad));
++ srtp_sha1_update(&state->init_ctx, ipad, sizeof(ipad));
+ return (hmac_start(state));
+ }
+
+@@ -192,7 +192,7 @@ hmac_update (hmac_ctx_t *state, const ui
+ octet_string_hex_string(message, msg_octets));
+
+ /* hash message into sha1 context */
+- sha1_update(&state->ctx, message, msg_octets);
++ srtp_sha1_update(&state->ctx, message, msg_octets);
+
+ return err_status_ok;
+ }
+@@ -211,8 +211,8 @@ hmac_compute (hmac_ctx_t *state, const v
+ }
+
+ /* hash message, copy output into H */
+- sha1_update(&state->ctx, message, msg_octets);
+- sha1_final(&state->ctx, H);
++ srtp_sha1_update(&state->ctx, message, msg_octets);
++ srtp_sha1_final(&state->ctx, H);
+
+ /*
+ * note that we don't need to debug_print() the input, since the
+@@ -222,16 +222,16 @@ hmac_compute (hmac_ctx_t *state, const v
+ octet_string_hex_string((uint8_t*)H, sizeof(H)));
+
+ /* re-initialize hash context */
+- sha1_init(&state->ctx);
++ srtp_sha1_init(&state->ctx);
+
+ /* hash opad ^ key */
+- sha1_update(&state->ctx, (uint8_t*)state->opad, sizeof(state->opad));
++ srtp_sha1_update(&state->ctx, (uint8_t*)state->opad, sizeof(state->opad));
+
+ /* hash the result of the inner hash */
+- sha1_update(&state->ctx, (uint8_t*)H, sizeof(H));
++ srtp_sha1_update(&state->ctx, (uint8_t*)H, sizeof(H));
+
+ /* the result is returned in the array hash_value[] */
+- sha1_final(&state->ctx, hash_value);
++ srtp_sha1_final(&state->ctx, hash_value);
+
+ /* copy hash_value to *result */
+ for (i = 0; i < tag_len; i++) {
diff --git a/srtp-shared.patch b/srtp-shared.patch
index a19b880..1d09885 100644
--- a/srtp-shared.patch
+++ b/srtp-shared.patch
@@ -1,282 +1,11 @@
---- srtp/crypto/Makefile.in.orig 2005-10-03 17:16:37.000000000 +0200
-+++ srtp/crypto/Makefile.in 2006-07-21 20:27:23.861073500 +0200
-@@ -14,9 +14,9 @@
- CPPFLAGS= @CPPFLAGS@
- CFLAGS = @CFLAGS@
- LIBS = @LIBS@
--LDFLAGS = @LDFLAGS@ -L.
-+LDFLAGS = @LDFLAGS@
- COMPILE = $(CC) $(DEFS) $(INCDIR) $(CPPFLAGS) $(CFLAGS)
--CRYPTOLIB = -lcryptomodule
-+CRYPTOLIB = libcryptomodule.la
-
- RANLIB = @RANLIB@
-
-@@ -52,7 +52,7 @@
- p=00112233445566778899aabbccddeeff
- c=69c4e0d86a7b0430d8cdb78070b4c55a
-
--runtest: libcryptomodule.a $(testapp)
-+runtest: libcryptomodule.la $(testapp)
- test/env$(EXE) # print out information on the build environment
- @echo "running libcryptomodule test applications..."
- test `test/aes_calc $k $p` = $c
-@@ -64,35 +64,35 @@
- test/rand_gen$(EXE) -n 256 >/dev/null
- @echo "libcryptomodule test applications passed."
-
--# libcryptomodule.a (the crypto engine)
-+# libcryptomodule.la (the crypto engine)
-
--ciphers = cipher/cipher.o cipher/null_cipher.o \
-- cipher/aes.o cipher/aes_icm.o \
-- cipher/aes_cbc.o
-+ciphers = cipher/cipher.lo cipher/null_cipher.lo \
-+ cipher/aes.lo cipher/aes_icm.lo \
-+ cipher/aes_cbc.lo
-
--hashes = hash/null_auth.o hash/sha1.o \
-- hash/hmac.o hash/auth.o
-+hashes = hash/null_auth.lo hash/sha1.lo \
-+ hash/hmac.lo hash/auth.lo
-
--math = math/datatypes.o math/stat.o
-+math = math/datatypes.lo math/stat.lo
-
--rng = rng/$(RNG_OBJS) rng/rand_source.o rng/prng.o rng/ctr_prng.o
-+rng = rng/$(RNG_OBJS) rng/rand_source.lo rng/prng.lo rng/ctr_prng.lo
-
--err = kernel/err.o
-+err = kernel/err.lo
-
--kernel = kernel/crypto_kernel.o kernel/alloc.o \
-- kernel/key.o $(rng) $(err)
-+kernel = kernel/crypto_kernel.lo kernel/alloc.lo \
-+ kernel/key.lo $(rng) $(err)
-
--xfm = ae_xfm/xfm.o
-+xfm = ae_xfm/xfm.lo
-
- cryptobj = $(ciphers) $(hashes) $(math) $(stat) $(kernel) $(xfm)
-
- # the rule for making object files and test apps
-
--%.o: %.c
-- $(COMPILE) -c $< -o $@
-+%.lo: %.c
-+ libtool --mode=compile --tag=CC $(COMPILE) -c $< -o $@
-
--%$(EXE): %.c libcryptomodule.a
-- $(COMPILE) $(LDFLAGS) $< -o $@ $(CRYPTOLIB) $(LIBS)
-+%$(EXE): %.c libcryptomodule.la
-+ libtool --mode=link --tag=CC $(COMPILE) $(LDFLAGS) $< -o $@ $(CRYPTOLIB) $(LIBS)
-
- ifndef AR
- AR=ar
-@@ -100,17 +100,16 @@
-
- # and the crypto module library itself
-
--libcryptomodule.a: $(cryptobj)
-- $(AR) cr libcryptomodule.a $(cryptobj)
-- $(RANLIB) libcryptomodule.a
-+libcryptomodule.la: $(cryptobj)
-+ libtool --mode=link --tag=CC $(CC) $(LDFLAGS) -o $@ $^
-
--all: libcryptomodule.a $(testapp)
-+all: libcryptomodule.la $(testapp)
-
- # housekeeping functions
-
- clean:
-- rm -f libcryptomodule.a
-- rm -f $(testapp) *.o */*.o
-+ rm -f libcryptomodule.la
-+ rm -f $(testapp) *.*o */*.*o
- for a in * .* */*; do if [ -f "$$a~" ] ; then rm $$a~; fi; done;
- rm -f `find . -name "*.[ch]~*~"`
- rm -rf latex
---- srtp-1.4.4/Makefile.in~ 2010-05-21 20:45:35.000000000 +0300
-+++ srtp-1.4.4/Makefile.in 2011-01-06 13:10:25.617052634 +0200
-@@ -7,8 +7,8 @@
- #
- # runtest runs test applications
- # test builds test applications
--# libcrypt.a static library implementing crypto engine
--# libsrtp.a static library implementing srtp
-+# libcrypt.la library implementing crypto engine
-+# libsrtp.la library implementing srtp
- # clean removes objects, libs, and executables
- # distribution cleans and builds a .tgz
- # tags builds etags file from all .c and .h files
-@@ -38,9 +38,9 @@
- CPPFLAGS= @CPPFLAGS@
- CFLAGS = @CFLAGS@
- LIBS = @LIBS@
--LDFLAGS = @LDFLAGS@ -L.
-+LDFLAGS = @LDFLAGS@
- COMPILE = $(CC) $(DEFS) $(INCDIR) $(CPPFLAGS) $(CFLAGS)
--SRTPLIB = -lsrtp
-+SRTPLIB = libsrtp.la
-
- RANLIB = @RANLIB@
- INSTALL = @INSTALL@
-@@ -66,54 +66,55 @@
-
- # implicit rules for object files and test apps
-
--%.o: %.c
-+%.lo: %.c
- $(COMPILE) -c $< -o $@
-
-+%.lo: %.c
-+ libtool --mode=compile --tag=CC $(COMPILE) -c $< -o $@
-+
- %$(EXE): %.c
-- $(COMPILE) $(LDFLAGS) $< -o $@ $(SRTPLIB) $(LIBS)
-+ libtool --mode=link --tag=CC $(COMPILE) $(LDFLAGS) $< -o $@ $(SRTPLIB) $(LIBS)
-
-
--# libcrypt.a (the crypto engine)
--ciphers = crypto/cipher/cipher.o crypto/cipher/null_cipher.o \
-- crypto/cipher/aes.o crypto/cipher/aes_icm.o \
-- crypto/cipher/aes_cbc.o
-+# libcrypt.la (the crypto engine)
-+ciphers = crypto/cipher/cipher.lo crypto/cipher/null_cipher.lo \
-+ crypto/cipher/aes.lo crypto/cipher/aes_icm.lo \
-+ crypto/cipher/aes_cbc.lo
-
--hashes = crypto/hash/null_auth.o crypto/hash/sha1.o \
-- crypto/hash/hmac.o crypto/hash/auth.o # crypto/hash/tmmhv2.o
-+hashes = crypto/hash/null_auth.lo crypto/hash/sha1.lo \
-+ crypto/hash/hmac.lo crypto/hash/auth.lo # crypto/hash/tmmhv2.lo
-
--replay = crypto/replay/rdb.o crypto/replay/rdbx.o \
-- crypto/replay/ut_sim.o
-+replay = crypto/replay/rdb.lo crypto/replay/rdbx.lo \
-+ crypto/replay/ut_sim.lo
-
--math = crypto/math/datatypes.o crypto/math/stat.o
-+math = crypto/math/datatypes.lo crypto/math/stat.lo
-
--ust = crypto/ust/ust.o
-+ust = crypto/ust/ust.lo
-
--rng = crypto/rng/$(RNG_OBJS) crypto/rng/prng.o crypto/rng/ctr_prng.o
-+rng = crypto/rng/$(RNG_OBJS) crypto/rng/prng.lo crypto/rng/ctr_prng.lo
-
--err = crypto/kernel/err.o
-+err = crypto/kernel/err.lo
-
--kernel = crypto/kernel/crypto_kernel.o crypto/kernel/alloc.o \
-- crypto/kernel/key.o $(rng) $(err) # $(ust)
-+kernel = crypto/kernel/crypto_kernel.lo crypto/kernel/alloc.lo \
-+ crypto/kernel/key.lo $(rng) $(err) # $(ust)
-
- cryptobj = $(ciphers) $(hashes) $(math) $(stat) $(kernel) $(replay)
-
--# libsrtp.a (implements srtp processing)
-+# libsrtp.la (implements srtp processing)
-
--srtpobj = srtp/srtp.o srtp/ekt.o
-+srtpobj = srtp/srtp.lo srtp/ekt.lo
-
--libsrtp.a: $(srtpobj) $(cryptobj) $(gdoi)
-- ar cr libsrtp.a $^
-- $(RANLIB) libsrtp.a
-+libsrtp.la: $(srtpobj) $(cryptobj) $(gdoi)
-+ libtool --mode=link --tag=CC $(CC) -o $@ $^ -rpath $(libdir)
-
--# libcryptomath.a contains general-purpose routines that are used to
-+# libcryptomath.la contains general-purpose routines that are used to
- # generate tables and verify cryptoalgorithm implementations - this
- # library is not meant to be included in production code
-
--cryptomath = crypto/math/math.o crypto/math/gf2_8.o
-+cryptomath = crypto/math/math.lo crypto/math/gf2_8.lo
-
--libcryptomath.a: $(cryptomath)
-- ar cr libcryptomath.a $(cryptomath)
-- $(RANLIB) libcryptomath.a
-+libcryptomath.la: $(cryptomath)
-+ libtool --mode=link --tag=CC $(CC) -o $@ $^
-
-
- # test applications
-@@ -127,19 +128,19 @@
- test/roc_driver$(EXE) test/rdbx_driver$(EXE) test/rtpw$(EXE) \
- test/dtls_srtp_driver$(EXE)
-
--$(testapp): libsrtp.a
-+$(testapp): libsrtp.la
-
- test/rtpw$(EXE): test/rtpw.c test/rtp.c test/getopt_s.c
-- $(COMPILE) $(LDFLAGS) -o $@ $^ $(LIBS) $(SRTPLIB)
-+ libtool --mode=link --tag=CC $(COMPILE) $(LDFLAGS) -o $@ $^ $(LIBS) $(SRTPLIB)
-
- test/srtp_driver$(EXE): test/srtp_driver.c test/getopt_s.c
-- $(COMPILE) $(LDFLAGS) -o $@ $^ $(LIBS) $(SRTPLIB)
-+ libtool --mode=link --tag=CC $(COMPILE) $(LDFLAGS) -o $@ $^ $(LIBS) $(SRTPLIB)
-
- test/rdbx_driver$(EXE): test/rdbx_driver.c test/getopt_s.c
-- $(COMPILE) $(LDFLAGS) -o $@ $^ $(LIBS) $(SRTPLIB)
-+ libtool --mode=link --tag=CC $(COMPILE) $(LDFLAGS) -o $@ $^ $(LIBS) $(SRTPLIB)
-
- test/dtls_srtp_driver$(EXE): test/dtls_srtp_driver.c test/getopt_s.c
-- $(COMPILE) $(LDFLAGS) -o $@ $^ $(LIBS) $(SRTPLIB)
-+ libtool --mode=link --tag=CC $(COMPILE) $(LDFLAGS) -o $@ $^ $(LIBS) $(SRTPLIB)
-
- test: $(testapp)
- @echo "Build done. Please run '$(MAKE) runtest' to run self tests."
-@@ -163,8 +164,8 @@
-
- # in the tables/ subdirectory, we use libcryptomath instead of libsrtp
-
--tables/%: tables/%.c libcryptomath.a
-- $(COMPILE) $(LDFLAGS) $< -o $@ $(LIBS) libcryptomath.a
-+tables/%: tables/%.c libcryptomath.la
-+ libtool --mode=link --tag=CC $(COMPILE) $(LDFLAGS) $< -o $@ $(LIBS) libcryptomath.la
-
- # the target 'plot' runs the timing test (test/srtp_driver -t) then
- # uses gnuplot to produce plots of the results - see the script file
-@@ -194,19 +195,19 @@
+--- libsrtp-1.5.2/Makefile.in.orig 2015-03-11 15:02:12.000000000 +0100
++++ libsrtp-1.5.2/Makefile.in 2015-07-05 20:55:06.770326476 +0200
+@@ -260,7 +260,7 @@
+ if [ -f libsrtp.dll.a ]; then cp libsrtp.dll.a $(DESTDIR)$(libdir)/; fi
+ if [ -f libsrtp.$(SHAREDLIBSUFFIX) ]; then \
+ cp libsrtp.$(SHAREDLIBSUFFIX) $(DESTDIR)$(SHAREDLIB_DIR)/; \
+- cp libsrtp.$(SHAREDLIBSUFFIXNOVER) $(DESTDIR)$(SHAREDLIB_DIR)/; \
++ cp -d libsrtp.$(SHAREDLIBSUFFIXNOVER) $(DESTDIR)$(SHAREDLIB_DIR)/; \
fi
- $(INSTALL) -d $(DESTDIR)$(includedir)/srtp
- $(INSTALL) -d $(DESTDIR)$(libdir)
-- cp $(srcdir)/include/*.h $(DESTDIR)$(includedir)/srtp
-- cp $(srcdir)/crypto/include/*.h $(DESTDIR)$(includedir)/srtp
-- if [ "$(srcdir)" != "." ]; then cp crypto/include/*.h $(DESTDIR)$(includedir)/srtp; fi
-- if [ -f libsrtp.a ]; then cp libsrtp.a $(DESTDIR)$(libdir)/; fi
-+ cp -p $(srcdir)/include/*.h $(DESTDIR)$(includedir)/srtp
-+ cp -p $(srcdir)/crypto/include/*.h $(DESTDIR)$(includedir)/srtp
-+ if [ "$(srcdir)" != "." ]; then cp -p crypto/include/*.h $(DESTDIR)$(includedir)/srtp; fi
-+ libtool --mode=install install libsrtp.la $(DESTDIR)$(libdir)
-
- uninstall:
- rm -f $(DESTDIR)$(includedir)/srtp/*.h
-- rm -f $(DESTDIR)$(libdir)/libsrtp.a
-+ rm -f $(DESTDIR)$(libdir)/libsrtp.*
- -rmdir $(DESTDIR)$(includedir)/srtp
-
- clean:
- rm -rf $(cryptobj) $(srtpobj) $(cryptomath) TAGS \
-- libcryptomath.a libsrtp.a core *.core test/core
-+ libcryptomath.la libsrtp.la core *.core test/core
- for a in * */* */*/*; do \
- if [ -f "$$a~" ] ; then rm -f $$a~; fi; \
- done;
---- srtp/configure.in.orig 2006-05-07 20:51:06.000000000 +0200
-+++ srtp/configure.in 2006-07-21 20:26:21.513177000 +0200
-@@ -35,10 +35,10 @@
-
- AC_MSG_CHECKING(which random device to use)
- if test "$enable_kernel_linux" = "yes"; then
-- RNG_OBJS=rand_linux_kernel.o
-+ RNG_OBJS=rand_linux_kernel.lo
- AC_MSG_RESULT([Linux kernel builtin])
- else
-- RNG_OBJS=rand_source.o
-+ RNG_OBJS=rand_source.lo
- if test -n "$DEV_URANDOM"; then
- AC_DEFINE_UNQUOTED(DEV_URANDOM, "$DEV_URANDOM",[Path to random device])
- AC_MSG_RESULT([$DEV_URANDOM])
+ if [ "$(pkgconfig_DATA)" != "" ]; then \
+ $(INSTALL) -d $(DESTDIR)$(pkgconfigdir); \
diff --git a/srtp.spec b/srtp.spec
index 829f6a6..191aec0 100644
--- a/srtp.spec
+++ b/srtp.spec
@@ -1,32 +1,22 @@
-#
-# Conditional build:
-%bcond_without static_libs # don't build static libraries
-
-%define rel 1
-%define subver 20121108
Summary: Open-source implementation of Secure Real-time Transport Protocol
Summary(pl.UTF-8): Otwarta implementacja protokołu Secure Real-time Transport Protocol
Name: srtp
-Version: 1.4.4
-Release: 5.%{subver}.%{rel}
+Version: 1.5.2
+Release: 1
License: BSD
Group: Libraries
-# Source0: http://srtp.sourceforge.net/%{name}-%{version}.tgz
-# Upstream 1.4.4 tarball is a bit dated, need to use cvs
-# cvs -d:pserver:anonymous@srtp.cvs.sourceforge.net:/cvsroot/srtp co -P srtp
-# tar cvfj srtp-1.4.4-20101004cvs.tar.bz2 srtp/
-Source0: http://dev.gentoo.org/~phajdan.jr/%{name}-%{version}_p%{subver}.tar.gz
-# Source0-md5: 1d1a644d3847000b8e186578867bf839
-Source1: lib%{name}.pc
+Source0: https://github.com/cisco/libsrtp/archive/v%{version}/libsrtp-%{version}.tar.gz
+# Source0-md5: 2309aa6027992810a4285b042c71e644
Patch0: %{name}-shared.patch
Patch1: %{name}-rename_functions.patch
URL: http://srtp.sourceforge.net/srtp.html
BuildRequires: autoconf
-BuildRequires: libtool
+BuildRequires: libpcap-devel
+BuildRequires: openssl-devel >= 1.0.1
+BuildRequires: pkgconfig
+BuildRequires: zlib-devel
BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
-%define specflags -fPIC
-
%description
The libSRTP library is an open-source implementation of Secure
Real-time Transport Protocol (SRTP).
@@ -40,6 +30,9 @@ Summary: Header files for SRTP library
Summary(pl.UTF-8): Pliki nagłówkowe biblioteki SRTP
Group: Development/Libraries
Requires: %{name} = %{version}-%{release}
+Requires: libpcap-devel
+Requires: openssl-devel >= 1.0.1
+Requires: zlib-devel
%description devel
Header files for SRTP library.
@@ -60,7 +53,7 @@ Static SRTP library.
Statyczna biblioteka SRTP.
%prep
-%setup -q -n %{name}
+%setup -q -n libsrtp-%{version}
%patch0 -p1
%patch1 -p1
@@ -68,25 +61,16 @@ Statyczna biblioteka SRTP.
%{__autoconf}
%{__autoheader}
%configure \
- %{?with_static_libs:--disable-static}
-%{__make}
+ --enable-openssl
+
+%{__make} shared_library
+%{__make} all
%install
rm -rf $RPM_BUILD_ROOT
%{__make} install \
DESTDIR=$RPM_BUILD_ROOT
-/sbin/ldconfig -n $RPM_BUILD_ROOT%{_libdir}
-ln -sf $(basename $RPM_BUILD_ROOT%{_libdir}/libsrtp.so.*.*.*) $RPM_BUILD_ROOT%{_libdir}/libsrtp.so
-
-# Install the pkg-config file
-install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
-sed -e "
- s|@PREFIX@|%{_prefix}|g
- s|@LIBDIR@|%{_libdir}|g
- s|@INCLUDEDIR@|%{_includedir}|g
-" < %{SOURCE1} > $RPM_BUILD_ROOT%{_pkgconfigdir}/libsrtp.pc
-
%clean
rm -rf $RPM_BUILD_ROOT
@@ -96,19 +80,15 @@ rm -rf $RPM_BUILD_ROOT
%files
%defattr(644,root,root,755)
%doc CHANGES LICENSE README TODO
-%attr(755,root,root) %{_libdir}/libsrtp.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libsrtp.so.0
+%attr(755,root,root) %{_libdir}/libsrtp.so.1
%files devel
%defattr(644,root,root,755)
%doc doc/{crypto_kernel.txt,intro.txt,references.txt,draft-irtf-cfrg-icm-00.txt,libsrtp.pdf}
%attr(755,root,root) %{_libdir}/libsrtp.so
%{_pkgconfigdir}/libsrtp.pc
-%{_libdir}/libsrtp.la
%{_includedir}/srtp
-%if %{with static_libs}
%files static
%defattr(644,root,root,755)
%{_libdir}/libsrtp.a
-%endif