summaryrefslogtreecommitdiff
path: root/libepoxy.spec
diff options
context:
space:
mode:
authorJakub Bogusz2020-12-22 21:28:23 (GMT)
committerJakub Bogusz2020-12-22 21:28:23 (GMT)
commit0d250d4eeae44d36f660a81a6f1d45820143b262 (patch)
treed417c4014f9e65e011a281f0b56e28ece15935b0 /libepoxy.spec
parent5c4ade7db8ade65c7079c20029086b96548cf0f6 (diff)
downloadlibepoxy-0d250d4eeae44d36f660a81a6f1d45820143b262.zip
libepoxy-0d250d4eeae44d36f660a81a6f1d45820143b262.tar.gz
- updated to 1.5.5 (now uses meson)auto/th/libepoxy-1.5.5-1
- removed outdated link patch - package apidocs
Diffstat (limited to 'libepoxy.spec')
-rw-r--r--libepoxy.spec58
1 files changed, 33 insertions, 25 deletions
diff --git a/libepoxy.spec b/libepoxy.spec
index 00b46b2..ee12f8c 100644
--- a/libepoxy.spec
+++ b/libepoxy.spec
@@ -1,29 +1,30 @@
#
# Conditional build:
-%bcond_without tests # "make check" call
+%bcond_without apidocs # API documentation
+%bcond_without tests # test suite
%bcond_without static_libs # static library build
Summary: Epoxy - GL dispatch library
Summary(pl.UTF-8): Epoxy - biblioteka do przekazywania funkcji GL
Name: libepoxy
-Version: 1.5.4
+Version: 1.5.5
Release: 1
License: MIT
Group: Libraries
##Source0Download: https://github.com/anholt/libepoxy/releases
#Source0: https://github.com/anholt/libepoxy/releases/download/v1.4/%{name}-%{version}.tar.xz
-Source0: http://ftp.gnome.org/pub/GNOME/sources/libepoxy/1.5/%{name}-%{version}.tar.xz
-# Source0-md5: 00f47ad447321f9dc59f85bc1c9d0467
-Patch0: %{name}-link.patch
+Source0: https://download.gnome.org/sources/libepoxy/1.5/%{name}-%{version}.tar.xz
+# Source0-md5: 516ff05a42157c86e32c6598321737af
URL: https://github.com/anholt/libepoxy
%{?with_tests:BuildRequires: Mesa-khrplatform-devel}
BuildRequires: Mesa-libEGL-devel
BuildRequires: Mesa-libGL-devel
-BuildRequires: autoconf >= 2.60
-BuildRequires: automake
-BuildRequires: libtool
+%{?with_apidocs:BuildRequires: doxygen}
+BuildRequires: meson
+BuildRequires: ninja >= 1.5
BuildRequires: pkgconfig
BuildRequires: python3 >= 1:3
+BuildRequires: rpmbuild(macros) >= 1.752
BuildRequires: tar >= 1:1.22
BuildRequires: xorg-lib-libX11-devel
BuildRequires: xorg-util-util-macros >= 1.8
@@ -64,32 +65,33 @@ Static libepoxy library.
%description static -l pl.UTF-8
Statyczna biblioteka libepoxy.
+%package apidocs
+Summary: API documentation for libepoxy library
+Summary(pl.UTF-8): Dokumentacja API biblioteki libepoxy
+Group: Documentation
+%{?noarchpackage}
+
+%description apidocs
+API documentation for libepoxy library.
+
+%description apidocs -l pl.UTF-8
+Dokumentacja API biblioteki libepoxy.
+
%prep
%setup -q
-%patch0 -p1
%build
-%{__libtoolize}
-%{__aclocal} -I m4
-%{__autoconf}
-%{__autoheader}
-%{__automake}
-%configure \
- --disable-silent-rules \
- %{?with_static_libs:--enable-static}
-
-%{__make}
+%meson build \
+ %{!?with_static_libs:--default-library=shared} \
+ %{?with_apidocs:-Ddocs=true} \
+ %{!?with_tests:-Dtests=false}
-%{?with_tests:%{__make} check}
+%ninja_build -C build
%install
rm -rf $RPM_BUILD_ROOT
-%{__make} install \
- DESTDIR=$RPM_BUILD_ROOT
-
-# obsoleted by pkg-config
-%{__rm} $RPM_BUILD_ROOT%{_libdir}/libepoxy.la
+%ninja_install -C build
%clean
rm -rf $RPM_BUILD_ROOT
@@ -114,3 +116,9 @@ rm -rf $RPM_BUILD_ROOT
%defattr(644,root,root,755)
%{_libdir}/libepoxy.a
%endif
+
+%if %{with apidocs}
+%files apidocs
+%defattr(644,root,root,755)
+%{_docdir}/epoxy
+%endif