summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Bogusz2014-11-23 20:45:02 (GMT)
committerJakub Bogusz2014-11-23 20:45:02 (GMT)
commitd4a4dbb69b78f385a1b2a5ceff90b7cc736116e8 (patch)
tree4929dae25b8609ea853a95a3cc911c30a032b47e
parent8367cb3bf6b9429c5fad2efdf67ffab69ad8eaac (diff)
downloadlemon-d4a4dbb69b78f385a1b2a5ceff90b7cc736116e8.zip
lemon-d4a4dbb69b78f385a1b2a5ceff90b7cc736116e8.tar.gz
- updated to 1.3.1 (note: new soname; build system changed to cmake)
- removed obsolete glpk patch - -static is gone
-rw-r--r--lemon-glpk.patch15
-rw-r--r--lemon.spec64
2 files changed, 16 insertions, 63 deletions
diff --git a/lemon-glpk.patch b/lemon-glpk.patch
deleted file mode 100644
index 3b1b695..0000000
--- a/lemon-glpk.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- lemon-1.2.4/m4/lx_check_glpk.m4.orig 2013-08-10 12:25:53.000000000 +0200
-+++ lemon-1.2.4/m4/lx_check_glpk.m4 2013-12-30 22:18:33.502163306 +0100
-@@ -49,9 +49,9 @@
-
- int main(int argc, char** argv)
- {
-- LPX *lp;
-- lp = lpx_create_prob();
-- lpx_delete_prob(lp);
-+ glp_prob *lp;
-+ lp = glp_create_prob();
-+ glp_delete_prob(lp);
- return 0;
- }'
-
diff --git a/lemon.spec b/lemon.spec
index 1574b5f..e67d114 100644
--- a/lemon.spec
+++ b/lemon.spec
@@ -1,7 +1,6 @@
# TODO: coin support
#
# Conditional build:
-%bcond_without static_libs # don't build static libraries
%bcond_with cplex # CPLEX support [IBM proprietary]
%bcond_without glpk # GLPK support
%bcond_with soplex # SoPlex support
@@ -9,21 +8,18 @@
Summary: Library of Efficient Models and Optimization in Networks
Summary(pl.UTF-8): Biblioteka wydajnych modeli i optymalizacji w sieciach
Name: lemon
-Version: 1.2.4
+Version: 1.3.1
Release: 1
License: Boost v1.0
Group: Libraries
Source0: http://lemon.cs.elte.hu/pub/sources/%{name}-%{version}.tar.gz
-# Source0-md5: fd89e8bf5035b02e2622a48ac7fe0641
-Patch0: %{name}-glpk.patch
+# Source0-md5: e89f887559113b68657eca67cf3329b5
URL: http://lemon.cs.elte.hu/
-BuildRequires: autoconf >= 2.59
-BuildRequires: automake
+BuildRequires: cmake >= 2.8
BuildRequires: doxygen
BuildRequires: ghostscript
%{?with_glpk:BuildRequires: glpk-devel >= 4.33}
BuildRequires: libstdc++-devel
-BuildRequires: libtool >= 2:1.5
BuildRequires: python
%{?with_soplex:BuildRequires: soplex-devel}
%{?with_glpk:Requires: glpk >= 4.33}
@@ -49,9 +45,8 @@ Summary: Header files for LEMON library
Summary(pl.UTF-8): Pliki nagłówkowe biblioteki LEMON
Group: Development/Libraries
Requires: %{name} = %{version}-%{release}
-%{?with_glpk:Requires: glpk-devel >= 4.33}
Requires: libstdc++-devel
-%{?with_soplex:Requires: soplex-devel}
+Obsoletes: lemon-static
%description devel
Header files for LEMON library.
@@ -59,18 +54,6 @@ Header files for LEMON library.
%description devel -l pl.UTF-8
Pliki nagłówkowe biblioteki LEMON.
-%package static
-Summary: Static LEMON library
-Summary(pl.UTF-8): Statyczna biblioteka LEMON
-Group: Development/Libraries
-Requires: %{name}-devel = %{version}-%{release}
-
-%description static
-Static LEMON library.
-
-%description static -l pl.UTF-8
-Statyczna biblioteka LEMON.
-
%package apidocs
Summary: LEMON API documentation
Summary(pl.UTF-8): Dokumentacja API biblioteki LEMON
@@ -84,33 +67,23 @@ Dokumentacja API biblioteki LEMON.
%prep
%setup -q
-%patch0 -p1
%build
-%{__libtoolize}
-%{__aclocal} -I m4
-%{__autoconf}
-%{__autoheader}
-%{__automake}
-%configure \
- --enable-shared \
- %{!?with_static_libs:--disable-static} \
- %{!?with_cplex:--without-cplex} \
- %{!?with_glpk:--without-glpk} \
- %{!?with_soplex:--without-soplex} \
- %{?with_soplex:--with-soplex-includedir=/usr/include/soplex}
-
+install -d build
+cd build
+%cmake .. \
+ %{!?with_coin:-DLEMON_ENABLE_COIN=OFF} \
+ %{!?with_glpk:-DLEMON_ENABLE_GLPK=OFF} \
+ %{!?with_cplex:-DLEMON_ENABLE_ILOG=OFF} \
+ %{!?with_soplex:-DLEMON_ENABLE_SOPLEX=OFF}
%{__make}
%install
rm -rf $RPM_BUILD_ROOT
-%{__make} install \
+%{__make} -C build install \
DESTDIR=$RPM_BUILD_ROOT
-# obsoleted by pkg-config
-%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
-
%clean
rm -rf $RPM_BUILD_ROOT
@@ -124,21 +97,16 @@ rm -rf $RPM_BUILD_ROOT
%attr(755,root,root) %{_bindir}/dimacs-to-lgf
%attr(755,root,root) %{_bindir}/lemon-0.x-to-1.x.sh
%attr(755,root,root) %{_bindir}/lgf-gen
-%attr(755,root,root) %{_libdir}/libemon.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libemon.so.0
+%attr(755,root,root) %{_libdir}/libemon.so.%{version}
%files devel
%defattr(644,root,root,755)
%attr(755,root,root) %{_libdir}/libemon.so
%{_includedir}/lemon
%{_pkgconfigdir}/lemon.pc
-
-%if %{with static_libs}
-%files static
-%defattr(644,root,root,755)
-%{_libdir}/libemon.a
-%endif
+%dir %{_datadir}/lemon
+%{_datadir}/lemon/cmake
%files apidocs
%defattr(644,root,root,755)
-%doc doc/html/*
+%{_docdir}/lemon