summaryrefslogtreecommitdiff
path: root/kernel-sound-cmaudio.spec
diff options
context:
space:
mode:
authorBartłomiej Zimoń2008-01-26 15:08:48 (GMT)
committercvs2git2012-06-24 12:13:13 (GMT)
commit587fce244454fb1b2f3308c54e9d1a9aec362054 (patch)
tree8bc7bd870c357a405b2c1b23027b475dc61b3ea8 /kernel-sound-cmaudio.spec
downloadkernel-sound-cmaudio-587fce244454fb1b2f3308c54e9d1a9aec362054.zip
kernel-sound-cmaudio-587fce244454fb1b2f3308c54e9d1a9aec362054.tar.gz
- initial spec
Changed files: kernel-sound-cmaudio.spec -> 1.1
Diffstat (limited to 'kernel-sound-cmaudio.spec')
-rw-r--r--kernel-sound-cmaudio.spec70
1 files changed, 70 insertions, 0 deletions
diff --git a/kernel-sound-cmaudio.spec b/kernel-sound-cmaudio.spec
new file mode 100644
index 0000000..241c625
--- /dev/null
+++ b/kernel-sound-cmaudio.spec
@@ -0,0 +1,70 @@
+#
+# Conditional build:
+%bcond_without dist_kernel # without distribution kernel
+#
+%define _orig_name cmaudio
+
+%define _rel 1
+Summary: C-Media Linux Driver
+Summary(pl.UTF-8): Sterowniki dla Linuksa dla kart dźwiękowych opartych na C-Media
+Name: kernel-sound-%{_orig_name}
+Version: 070
+Release: %{_rel}@%{_kernel_ver_str}
+License: GPL
+Group: Base/Kernel
+Source0: http://www.cmediadrivers.info/driver/Linux/Ac97/%{_orig_name}-%{version}.tar.bz2
+# Source0-md5: 60cc9412652205d0cfc827899298b68e
+# Patch0: %{_orig_name}-Makefile.patch
+# Patch1: %{name}-types.patch
+URL: http://www.cmediadrivers.info/driver/Linux/Ac97/
+%{?with_dist_kernel:BuildRequires: kernel%{_alt_kernel}-module-build >= 3:2.6.20.2}
+BuildRequires: rpmbuild(macros) >= 1.379
+Requires(post,postun): /sbin/depmod
+Provides: cmiaudio
+ExclusiveArch: %{ix86}
+%if %{with dist_kernel}
+%requires_releq_kernel
+Requires(postun): %releq_kernel
+%endif
+BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+
+%description
+C-Media Linux Driver.
+
+%description -l pl.UTF-8
+Sterowniki do kart dźwiękowych opartych na C-Media.
+
+%prep
+%setup -q -n %{_orig_name}
+#%patch0 -p1
+#%patch1 -p1
+
+cat > Makefile <<'EOF'
+obj-m := cmiaudio.o
+cmiaudio-objs := ali_5451.o ati.o cmi9738.o cmi9739.o cmi9761.o intel_ichx.o main.o sis_7018.o via_82cxxx.o
+EOF
+
+%build
+%build_kernel_modules -C . -m cmiaudio
+%install
+rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/misc
+install -d $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}smp/misc
+#8810
+install au8810-smp.o $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}smp/misc/au8810.o
+install au8810.o $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/misc/au8810.o
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%post
+%depmod %{_kernel_ver}
+
+%postun
+%depmod %{_kernel_ver}
+
+%files
+%defattr(644,root,root,755)
+%doc README ChangeLog
+/lib/modules/%{_kernel_ver}/misc/*