summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorElan Ruusamäe2006-06-09 09:14:20 (GMT)
committercvs2git2012-06-24 12:13:13 (GMT)
commit5e7f549e4a8a09b576b36fb84127aab25070f6e9 (patch)
tree281c3c02b3b9c58ac056a515fdef0c1c5a838c09
parent232b92234033426c34e03800c50093fb9095d0c8 (diff)
downloadjpeg-mmx-5e7f549e4a8a09b576b36fb84127aab25070f6e9.zip
jpeg-mmx-5e7f549e4a8a09b576b36fb84127aab25070f6e9.tar.gz
- created -libs and -devel
- add PIC and gcc41 patches from gentoo Changed files: jpeg-mmx.spec -> 1.19
-rw-r--r--jpeg-mmx.spec50
1 files changed, 42 insertions, 8 deletions
diff --git a/jpeg-mmx.spec b/jpeg-mmx.spec
index 245244a..b878aec 100644
--- a/jpeg-mmx.spec
+++ b/jpeg-mmx.spec
@@ -1,6 +1,3 @@
-# TODO
-# - -progs subpackage?
-# - shared library?
Summary: libjpeg library with MMX support
Summary(pl): Biblioteka libjpeg z obsługą MMX
Name: jpeg-mmx
@@ -12,14 +9,18 @@ Group: Libraries
Source0: http://dl.sourceforge.net/mjpeg/%{name}-%{version}.tar.gz
# Source0-md5: 9156c429bd8c4dea65c877c50ed89e15
Patch0: %{name}-DESTDIR.patch
+Patch1: %{name}-PIC.patch
+Patch2: %{name}-gcc41.patch
# XXX: replace it with real x86_64 port or drop
-#Patch1: %{name}-x8664.patch
+#Patch1: %{name}-x8664.patch
URL: http://mjpeg.sourceforge.net/
BuildRequires: gcc >= 5:3.0
BuildRequires: nasm
ExclusiveArch: i586 i686 pentium3 pentium4 athlon
BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+%define _includedir /usr/include/jpeg-mmx
+
%description
jpeg-mmx is a modified version of IJG libjpeg library that can use MMX
extension of x86 processors (if available).
@@ -28,28 +29,61 @@ extension of x86 processors (if available).
jpeg-mmx to zmodyfikowana wersja biblioteki IJG libjpeg potrafiąca
używać rozszerzenia MMX procesorów x86 (jeśli jest dostępne).
+%package libs
+Summary: Shared jpeg-mmx library
+Group: Libraries
+
+%description libs
+Shared jpeg-mmx library
+
+%package devel
+Summary: Headers for developing programs using libjpeg
+Group: Development/Libraries
+Requires: %{name}-libs = %{version}
+
+%description devel
+The jpeg-mmx-devel package includes the header files and static
+libraries necessary for developing programs which will manipulate JPEG
+files using the libjpeg library.
+
%prep
%setup -q -n %{name}
%patch0 -p1
+%patch1 -p0
+%patch2 -p1
%build
-%configure
+%configure \
+ --enable-shared \
+ --disable-static \
+
%{__make}
%install
rm -rf $RPM_BUILD_ROOT
install -d $RPM_BUILD_ROOT{%{_includedir},%{_bindir},%{_libdir},%{_mandir}/man1}
-%{__make} install-prog install_real \
+%{__make} install_real install-prog \
DESTDIR=$RPM_BUILD_ROOT
%clean
rm -rf $RPM_BUILD_ROOT
+%post libs -p /sbin/ldconfig
+%postun libs -p /sbin/ldconfig
+
%files
%defattr(644,root,root,755)
%doc README usage.doc wizard.doc change.log libjpeg.doc example.c structure.doc filelist.doc coderules.doc
%attr(755,root,root) %{_bindir}/*
-%{_libdir}/libjpeg-mmx.a
-%{_includedir}/*.h
%{_mandir}/man1/*
+
+%files libs
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libjpeg-mmx.so.*.*.*
+
+%files devel
+%defattr(644,root,root,755)
+%{_includedir}
+%{_libdir}/libjpeg-mmx.la
+%{_libdir}/libjpeg-mmx.so