summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Bogusz2005-06-25 21:38:49 (GMT)
committercvs2git2012-06-24 12:13:13 (GMT)
commit6de5084e8e2d1490f4401256cef16bcc7b57a428 (patch)
tree9cd9514f2067717c4daeee0f561ceb6c12d43af5
parent5c31f69964a6d45699f95f68d9fc5ac55b2409e9 (diff)
downloadjob-6de5084e8e2d1490f4401256cef16bcc7b57a428.zip
job-6de5084e8e2d1490f4401256cef16bcc7b57a428.tar.gz
- pl, some cleanups
Changed files: job.spec -> 1.2
-rw-r--r--job.spec38
1 files changed, 22 insertions, 16 deletions
diff --git a/job.spec b/job.spec
index 73052d2..4a76723 100644
--- a/job.spec
+++ b/job.spec
@@ -1,11 +1,13 @@
+Summary: Linux Jobs
+Summary(pl): Narzędzia do obsługi zadań pod Linuksem
Name: job
Version: 1.5.0
Release: 0.1
-Summary: Linux Jobs
-Source0: ftp://oss.sgi.com/projects/pagg/download/%{name}-%{version}.tar.gz
License: GPL
-URL: http://oss.sgi.com/projects/pagg/
Group: Applications/System
+Source0: ftp://oss.sgi.com/projects/pagg/download/%{name}-%{version}.tar.gz
+# Source0-md5: 4cc7c983765c934e33d4078bf530a978
+URL: http://oss.sgi.com/projects/pagg/
BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
%description
@@ -16,10 +18,19 @@ administrators to control process attachment to jobs. The PAM module
allows the administrator to specify which point-of-entry services on
the system (rlogin, gdm, xdm, ftp, etc.) should create new jobs.
+%description -l pl
+Pakiet job dostarcza zestaw poleceń, moduł PAM, strony podręcznika
+oraz plik konfiguracyjny. Polecenia służą do wysyłania sygnałów do
+zadań, oczekiwania na zadania, odczytu informacji o zadaniach oraz dla
+administratorów do kontroli dołączania procesów do zadań. Moduł PAM
+umożliwia administratorowi określenie, które usługi wejściowe systemu
+(rlogin, gdm, xdm, ftp itp.) powinny tworzyć nowe zadania.
+
%prep
%setup -q -n %{name}
%build
+# TODO: optflags
%{__make} build \
ROOT="$RPM_BUILD_ROOT"
@@ -34,18 +45,19 @@ rm -rf $RPM_BUILD_ROOT
%files
%defattr(644,root,root,755)
-%attr(754,root,root) /etc/rc.d/init.d/job
-%attr(755,root,root) /lib/security/pam_job.so
-%{_includedir}/job.h
-%attr(755,root,root) %{_prefix}/lib/libjob.so
+%doc AUTHORS COPYING INSTALL README
%attr(755,root,root) %{_bindir}/jdetach
%attr(755,root,root) %{_bindir}/jkill
%attr(755,root,root) %{_bindir}/jsethid
%attr(755,root,root) %{_bindir}/jstat
%attr(755,root,root) %{_bindir}/jwait
%attr(755,root,root) %{_bindir}/jattach
+%attr(755,root,root) %{_libdir}/libjob.so
+%attr(755,root,root) /%{_lib}/security/pam_job.so
+%attr(754,root,root) /etc/rc.d/init.d/job
%{_mandir}/*/*
-%doc AUTHORS COPYING INSTALL README
+# -devel?
+#%{_includedir}/job.h
%preun
if [ "$1" = 0 ] ; then
@@ -57,18 +69,12 @@ if [ "$1" = 0 ] ; then
echo ""
exit 1
fi
- which chkconfig > /dev/null
- if [ $? -eq 0 ] ; then
- chkconfig --del job
- fi
+ /sbin/chkconfig --del job
fi
exit 0
%post
-which chkconfig > /dev/null
-if [ $? -eq 0 ] ; then
- chkconfig --add job
-fi
+/sbin/chkconfig --add job
echo "You must add references to pam_job.so in the /etc/pam.d/* config"
echo "files to enable the PAM services for creating jobs. You only"
echo "need to add the reference for services that you want to fall under"