summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--http-live-streaming-tools.spec4
-rw-r--r--input_filename.patch23
2 files changed, 26 insertions, 1 deletions
diff --git a/http-live-streaming-tools.spec b/http-live-streaming-tools.spec
index 1ada970..5433c53 100644
--- a/http-live-streaming-tools.spec
+++ b/http-live-streaming-tools.spec
@@ -1,13 +1,14 @@
Summary: HTTP Live Video Stream Segmenter and Distributor
Name: http-live-streaming-tools
Version: 0.1
-Release: 0.2
+Release: 1
License: GPL v2
Group: Applications/Networking
Source0: %{name}.tar.bz2
# Source0-md5: 90731a7168cd9393cc4c6e3704b75f11
URL: http://www.ioncannon.net/projects/http-live-video-stream-segmenter-and-distributor/
Patch0: makefile.patch
+Patch1: input_filename.patch
BuildRequires: bzip2-devel
BuildRequires: ffmpeg-devel >= 0.5
BuildRequires: rpmbuild(macros) >= 1.484
@@ -34,6 +35,7 @@ HTTP Live Video Stream Segmenter.
%prep
%setup -q -n %{name}
%patch0 -p1
+%patch1 -p1
%build
%{__make} \
diff --git a/input_filename.patch b/input_filename.patch
new file mode 100644
index 0000000..3ed26af
--- /dev/null
+++ b/input_filename.patch
@@ -0,0 +1,23 @@
+--- http-live-streaming-tools/live_segmenter.c~ 2010-08-23 16:01:30.000000000 +0300
++++ http-live-streaming-tools/live_segmenter.c 2010-09-03 18:16:09.899783952 +0300
+@@ -111,9 +111,9 @@
+
+ int main(int argc, char **argv)
+ {
+- if(argc != 5)
++ if(argc != 5 && argc != 6)
+ {
+- fprintf(stderr, "Usage: %s <segment length> <output location> <filename prefix> <encoding profile>\n", argv[0]);
++ fprintf(stderr, "Usage: %s <segment length> <output location> <filename prefix> <encoding profile> [<filename>]\n", argv[0]);
+ return 1;
+ }
+
+@@ -125,7 +125,7 @@
+ config.temp_directory = argv[2];
+ config.filename_prefix = argv[3];
+ config.encoding_profile = argv[4];
+- config.input_filename = "pipe://1";
++ config.input_filename = argc == 6 ? argv[5] : "pipe://1";
+
+ char *output_filename = malloc(sizeof(char) * (strlen(config.temp_directory) + 1 + strlen(config.filename_prefix) + 10));
+ if (!output_filename)