summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorElan Ruusamäe2010-08-23 12:53:37 (GMT)
committercvs2git2012-06-24 12:13:13 (GMT)
commitf5b0f9a35cef7111856328f96a16746d30704c9e (patch)
tree92e50874c1d72cba39fe75181110259a963e9c86
downloadhttp-live-streaming-tools-f5b0f9a35cef7111856328f96a16746d30704c9e.zip
http-live-streaming-tools-f5b0f9a35cef7111856328f96a16746d30704c9e.tar.gz
- new
Changed files: http-live-streaming-tools.spec -> 1.1 makefile.patch -> 1.1
-rw-r--r--http-live-streaming-tools.spec51
-rw-r--r--makefile.patch12
2 files changed, 63 insertions, 0 deletions
diff --git a/http-live-streaming-tools.spec b/http-live-streaming-tools.spec
new file mode 100644
index 0000000..8fba32d
--- /dev/null
+++ b/http-live-streaming-tools.spec
@@ -0,0 +1,51 @@
+Summary: HTTP Live Video Stream Segmenter and Distributor
+Name: http-live-streaming-tools
+Version: 0.1
+Release: 0.1
+License: GPL v2
+Group: Applications/Networking
+Source0: %{name}.tar.bz2
+# Source0-md5: 90731a7168cd9393cc4c6e3704b75f11
+URL: http://www.ioncannon.net/projects/http-live-video-stream-segmenter-and-distributor/
+Patch0: makefile.patch
+BuildRequires: ffmpeg-devel
+BuildRequires: rpmbuild(macros) >= 1.484
+Requires: ruby
+Requires: ruby-modules
+%{?ruby_mod_ver_requires_eq}
+BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+This project is an attempt to make it easier to set up a live
+streaming server using Apple's HTTP Live Streaming protocol. The
+source includes a Ruby script and a C program that use FFMpeg to
+encode and segment an input video stream in the correct format for use
+with the HTTP streaming protocol.
+
+%prep
+%setup -q -n %{name}
+%patch0 -p1
+
+%build
+%{__make} \
+ CC="%{__cc}" \
+ CFLAGS="%{rpmcflags}" \
+ LDFLAGS="%{rpmldflags}"
+
+%install
+rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT%{_bindir}
+install -p live_segmenter $RPM_BUILD_ROOT%{_bindir}
+install -p hs_* http_streamer* $RPM_BUILD_ROOT%{_bindir}
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(644,root,root,755)
+%doc README.md example-configs
+%attr(755,root,root) %{_bindir}/hs_config.rb
+%attr(755,root,root) %{_bindir}/hs_encoder.rb
+%attr(755,root,root) %{_bindir}/hs_transfer.rb
+%attr(755,root,root) %{_bindir}/http_streamer.rb
+%attr(755,root,root) %{_bindir}/live_segmenter
diff --git a/makefile.patch b/makefile.patch
new file mode 100644
index 0000000..ef0c9f3
--- /dev/null
+++ b/makefile.patch
@@ -0,0 +1,12 @@
+--- http-live-streaming-tools/Makefile~ 2010-08-23 15:45:40.000000000 +0300
++++ http-live-streaming-tools/Makefile 2010-08-23 15:52:12.243937112 +0300
+@@ -1,5 +1,8 @@
++CC := gcc
++CFLAGS := -g
++
+ all:
+- gcc -Wall -g live_segmenter.c -o live_segmenter -lavformat -lavcodec -lavutil -lbz2 -lm -lz -lfaac -lmp3lame -lx264 -lfaad -lpthread
++ $(CC) -Wall $(CFLAGS) live_segmenter.c -o live_segmenter $(LDFLAGS) -lavformat -lavcodec -lavutil -lbz2 -lm -lz -lfaac -lmp3lame -lx264 -lfaad -lpthread
+
+ clean:
+ rm -f live_segmenter