summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorElan Ruusamäe2010-08-30 07:28:27 (GMT)
committercvs2git2012-06-24 12:13:13 (GMT)
commit005e2d6293d7f5ec39e663859514f38698ddb088 (patch)
treefd66777d5605b680950609ea3c199c12fc1add0f
parent5ddedb2c18802618882252dcd981ca35dad59a79 (diff)
downloadhttp-live-streaming-tools-005e2d6293d7f5ec39e663859514f38698ddb088.zip
http-live-streaming-tools-005e2d6293d7f5ec39e663859514f38698ddb088.tar.gz
- use default target which is success after compilation, not compiling always over
Changed files: makefile.patch -> 1.2
-rw-r--r--makefile.patch13
1 files changed, 8 insertions, 5 deletions
diff --git a/makefile.patch b/makefile.patch
index ef0c9f3..647673b 100644
--- a/makefile.patch
+++ b/makefile.patch
@@ -1,11 +1,14 @@
---- http-live-streaming-tools/Makefile~ 2010-08-23 15:45:40.000000000 +0300
-+++ http-live-streaming-tools/Makefile 2010-08-23 15:52:12.243937112 +0300
-@@ -1,5 +1,8 @@
+--- http-live-streaming-tools/Makefile 2010-08-23 15:52:12.243937112 +0300
++++ http-live-streaming-tools/Makefile 2010-08-30 10:27:02.367948681 +0300
+@@ -1,5 +1,10 @@
+-all:
+- gcc -Wall -g live_segmenter.c -o live_segmenter -lavformat -lavcodec -lavutil -lbz2 -lm -lz -lfaac -lmp3lame -lx264 -lfaad -lpthread
+CC := gcc
+CFLAGS := -g
+
- all:
-- gcc -Wall -g live_segmenter.c -o live_segmenter -lavformat -lavcodec -lavutil -lbz2 -lm -lz -lfaac -lmp3lame -lx264 -lfaad -lpthread
++all: live_segmenter
++
++live_segmenter:
+ $(CC) -Wall $(CFLAGS) live_segmenter.c -o live_segmenter $(LDFLAGS) -lavformat -lavcodec -lavutil -lbz2 -lm -lz -lfaac -lmp3lame -lx264 -lfaad -lpthread
clean: