summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaweł Gołaszewski2005-10-23 19:55:18 (GMT)
committercvs2git2012-06-24 12:13:13 (GMT)
commit4a6f0346489c8a31e72ec30053d9fee808d20cd0 (patch)
treea8beb08b9622d6d4769cdb902274c628eb015629
parent860acc9734fa4a255efe10f73278f0f4b30de3c4 (diff)
downloadhorde-vacation-4a6f0346489c8a31e72ec30053d9fee808d20cd0.zip
horde-vacation-4a6f0346489c8a31e72ec30053d9fee808d20cd0.tar.gz
- initial, not working
Changed files: horde-vacation.spec -> 1.1
-rw-r--r--horde-vacation.spec104
1 files changed, 104 insertions, 0 deletions
diff --git a/horde-vacation.spec b/horde-vacation.spec
new file mode 100644
index 0000000..dc4dc8f
--- /dev/null
+++ b/horde-vacation.spec
@@ -0,0 +1,104 @@
+%define _hordeapp vacation
+%define _rel 0.1
+#
+%include /usr/lib/rpm/macros.php
+Summary: vacation - vacation manager module for Horde
+Name: horde-%{_hordeapp}
+Version: 2.2.2
+Release: %{?_rc:0.%{_rc}.}%{?_snap:0.%(echo %{_snap} | tr -d -).}%{_rel}
+License: ASL
+Group: Applications/WWW
+#Source0: ftp://ftp.horde.org/pub/snaps/%{_snap}/%{_hordeapp}-HEAD-%{_snap}.tar.gz
+Source0: ftp://ftp.horde.org/pub/vacation/%{_hordeapp}-%{version}.tar.gz
+# Source0-md5: 1345ff8e30a98de7085f01f0abde3007
+Source1: %{name}.conf
+URL: http://www.horde.org/vacation/
+BuildRequires: rpm-php-pearprov >= 4.0.2-98
+BuildRequires: rpmbuild(macros) >= 1.226
+BuildRequires: tar >= 1:1.15.1
+Requires: apache >= 1.3.33-2
+Requires: apache(mod_access)
+Requires: horde >= 3.0
+Requires: php-xml >= 4.1.0
+Requires: vacation
+BuildArch: noarch
+BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+# horde accesses it directly in help->about
+%define _noautocompressdoc CREDITS
+%define _noautoreq 'pear(Horde.*)'
+
+%define hordedir /usr/share/horde
+%define _sysconfdir /etc/horde.org
+%define _appdir %{hordedir}/%{_hordeapp}
+
+%description
+Vacation is a Horde module for managing user e-mail "vacation notices" or "auto-responders." It works via a local vacation program which must be installed and functioning on the server. It supports vacation programs using the .forward-style forwarding mechanism supported by several popular mailers, as well as qmail and sql based implementations. While it has been released and is in production use at many sites, it is also under heavy development in an effort to expand and improve the module.
+
+%prep
+%setup -q -c -T -n %{?_snap:%{_hordeapp}-%{_snap}}%{!?_snap:%{_hordeapp}-%{version}%{?_rc:-%{_rc}}}
+tar zxf %{SOURCE0} --strip-components=1
+
+rm -f scripts/.htaccess
+# considered harmful (horde/docs/SECURITY)
+rm -f test.php
+
+%install
+rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT%{_sysconfdir}/%{_hordeapp} \
+ $RPM_BUILD_ROOT%{_appdir}/{docs,graphics,lib,locale,scripts,templates}
+
+cp -pR *.php $RPM_BUILD_ROOT%{_appdir}
+for i in config/*.dist; do
+ cp -p $i $RPM_BUILD_ROOT%{_sysconfdir}/%{_hordeapp}/$(basename $i .dist)
+done
+echo '<?php ?>' > $RPM_BUILD_ROOT%{_sysconfdir}/%{_hordeapp}/conf.php
+touch $RPM_BUILD_ROOT%{_sysconfdir}/%{_hordeapp}/conf.php.bak
+
+cp -pR graphics/* $RPM_BUILD_ROOT%{_appdir}/graphics
+cp -pR lib/* $RPM_BUILD_ROOT%{_appdir}/lib
+cp -pR locale/* $RPM_BUILD_ROOT%{_appdir}/locale
+cp -pR templates/* $RPM_BUILD_ROOT%{_appdir}/templates
+
+ln -s %{_sysconfdir}/%{_hordeapp} $RPM_BUILD_ROOT%{_appdir}/config
+ln -s %{_docdir}/%{name}-%{version}/CREDITS $RPM_BUILD_ROOT%{_appdir}/docs
+
+install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache-%{_hordeapp}.conf
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%post
+if [ ! -f %{_sysconfdir}/%{_hordeapp}/conf.php.bak ]; then
+ install /dev/null -o root -g http -m660 %{_sysconfdir}/%{_hordeapp}/conf.php.bak
+fi
+
+%triggerin -- apache1 >= 1.3.33-2
+%apache_config_install -v 1 -c %{_sysconfdir}/apache-%{_hordeapp}.conf
+
+%triggerun -- apache1 >= 1.3.33-2
+%apache_config_uninstall -v 1
+
+%triggerin -- apache >= 2.0.0
+%apache_config_install -v 2 -c %{_sysconfdir}/apache-%{_hordeapp}.conf
+
+%triggerun -- apache >= 2.0.0
+%apache_config_uninstall -v 2
+
+%files
+%defattr(644,root,root,755)
+%doc README docs/* scripts
+%attr(750,root,http) %dir %{_sysconfdir}/%{_hordeapp}
+%attr(640,root,root) %config(noreplace) %{_sysconfdir}/apache-%{_hordeapp}.conf
+%attr(660,root,http) %config(noreplace) %{_sysconfdir}/%{_hordeapp}/conf.php
+%attr(660,root,http) %config(noreplace) %ghost %{_sysconfdir}/%{_hordeapp}/conf.php.bak
+##%attr(640,root,http) %config(noreplace) %{_sysconfdir}/%{_hordeapp}/[!c]*.php
+
+%dir %{_appdir}
+%{_appdir}/*.php
+%{_appdir}/config
+%{_appdir}/docs
+%{_appdir}/graphics
+%{_appdir}/lib
+%{_appdir}/locale
+%{_appdir}/templates