summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorpsz2006-02-17 18:34:38 (GMT)
committercvs2git2012-06-24 12:13:13 (GMT)
commit8f8d5480909addb84247b1fdd2c937120edd9b72 (patch)
tree65345259bf499dec9e907e130732146ca25ed78a
parent755229fc041bfd50a10116e3514b6fc9e6d71467 (diff)
downloadgpdf-8f8d5480909addb84247b1fdd2c937120edd9b72.zip
gpdf-8f8d5480909addb84247b1fdd2c937120edd9b72.tar.gz
- rel 4; STBR Changed files: gpdf-cve-2006-0301.patch -> 1.1 gpdf.spec -> 1.44
-rw-r--r--gpdf-cve-2006-0301.patch37
-rw-r--r--gpdf.spec4
2 files changed, 40 insertions, 1 deletions
diff --git a/gpdf-cve-2006-0301.patch b/gpdf-cve-2006-0301.patch
new file mode 100644
index 0000000..a1b5b18
--- /dev/null
+++ b/gpdf-cve-2006-0301.patch
@@ -0,0 +1,37 @@
+--- gpdf-2.10.0/splash/Splash.cc.orig 2004-05-17 20:10:49.000000000 +0200
++++ gpdf-2.10.0/splash/Splash.cc 2006-02-17 19:30:17.000000000 +0100
+@@ -734,6 +734,10 @@
+ SplashMono1P *mono1;
+ SplashBGR8P *bgr8;
+
++ if ( (unsigned) x >= (unsigned) bitmap->getWidth() ||
++ (unsigned) y >= (unsigned) bitmap->getHeight())
++ return;
++
+ if (noClip || state->clip->test(x, y)) {
+ color = pattern->getColor(x, y);
+ switch (bitmap->mode) {
+@@ -773,6 +777,11 @@
+
+ n = x1 - x0 + 1;
+
++ if ((unsigned) x0 >= (unsigned) bitmap->getWidth() ||
++ (unsigned) x1 >= (unsigned) bitmap->getWidth() ||
++ (unsigned) y >= (unsigned) bitmap->getHeight())
++ return;
++
+ switch (bitmap->mode) {
+ case splashModeMono1:
+ mono1 = &bitmap->data.mono8[y * bitmap->rowSize + (x0 >> 3)];
+@@ -858,6 +867,11 @@
+
+ n = x1 - x0 + 1;
+
++ if ((unsigned) x0 >= (unsigned) bitmap->getWidth() ||
++ (unsigned) x1 >= (unsigned) bitmap->getWidth() ||
++ (unsigned) y >= (unsigned) bitmap->getHeight())
++ return;
++
+ switch (bitmap->mode) {
+ case splashModeMono1:
+ mono1 = &bitmap->data.mono8[y * bitmap->rowSize + (x0 >> 3)];
diff --git a/gpdf.spec b/gpdf.spec
index 8133fbb..3df85a4 100644
--- a/gpdf.spec
+++ b/gpdf.spec
@@ -2,13 +2,14 @@ Summary: GNOME PDF Viewer
Summary(pl): Przeglądarka PDF-ów dla GNOME
Name: gpdf
Version: 2.10.0
-Release: 3
+Release: 4
License: GPL v2+
Group: X11/Applications/Graphics
Source0: http://ftp.gnome.org/pub/gnome/sources/gpdf/2.10/%{name}-%{version}.tar.bz2
# Source0-md5: 9278cd3b9d06e3b1d364452f0e512fa9
Patch0: %{name}-desktop.patch
Patch1: %{name}-CAN-2005-2097.patch
+Patch2: %{name}-cve-2006-0301.patch
URL: http://www.gnome.org/
BuildRequires: GConf2-devel >= 2.10.0
BuildRequires: autoconf >= 2.52
@@ -42,6 +43,7 @@ Format).
%setup -q
%patch0 -p1
%patch1 -p1
+%patch2 -p1
%build
%{__libtoolize}