summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Bogusz2014-03-24 16:55:00 (GMT)
committerJakub Bogusz2014-03-24 16:55:00 (GMT)
commitf6884811acf6a85c5beee3dda8a5fbbdbbfcf7bb (patch)
tree777ed24eb807bb8f53f397f996bd69ba5fad9045
parent6153193ad3a94a2a4dbfe4f3ae3fcc67df88cf15 (diff)
downloadgnome-online-accounts-f6884811acf6a85c5beee3dda8a5fbbdbbfcf7bb.zip
gnome-online-accounts-f6884811acf6a85c5beee3dda8a5fbbdbbfcf7bb.tar.gz
- added link patch (include convenience tpaw library dependencies in libgoa-backend linking)
- handle uoa bcond
-rw-r--r--gnome-online-accounts-link.patch20
-rw-r--r--gnome-online-accounts.spec13
2 files changed, 29 insertions, 4 deletions
diff --git a/gnome-online-accounts-link.patch b/gnome-online-accounts-link.patch
new file mode 100644
index 0000000..9d61d89
--- /dev/null
+++ b/gnome-online-accounts-link.patch
@@ -0,0 +1,20 @@
+--- gnome-online-accounts-3.10.3/telepathy-account-widgets/tp-account-widgets/Makefile.am.orig 2014-03-18 16:05:06.000000000 +0100
++++ gnome-online-accounts-3.10.3/telepathy-account-widgets/tp-account-widgets/Makefile.am 2014-03-24 16:51:19.153929421 +0100
+@@ -90,6 +90,9 @@
+ $(nocheck_sources) \
+ $(NULL)
+
++libtp_account_widgets_la_LIBADD = \
++ $(TPAW_LIBS)
++
+ # these are sources that depend on Ubuntu Online Accounts
+ uoa_sources = \
+ tpaw-uoa-utils.c \
+@@ -98,6 +101,7 @@
+
+ if HAVE_UOA
+ libtp_account_widgets_la_SOURCES += $(uoa_sources)
++libtp_account_widgets_la_LIBADD += $(UOA_LIBS)
+ EXTRA_DIST =
+ else
+ EXTRA_DIST = $(uoa_sources)
diff --git a/gnome-online-accounts.spec b/gnome-online-accounts.spec
index fa1b1f7..df2820e 100644
--- a/gnome-online-accounts.spec
+++ b/gnome-online-accounts.spec
@@ -12,9 +12,8 @@ License: LGPL v2+
Group: Libraries
Source0: http://ftp.gnome.org/pub/GNOME/sources/gnome-online-accounts/3.10/%{name}-%{version}.tar.xz
# Source0-md5: 37627e71bf5098b59947b8e1529b3991
+Patch0: %{name}-link.patch
URL: http://www.gnome.org/
-# account-plugin / libaccount-plugin / gnome-control-center-signon ???
-%{?with_uoa:BuildRequires: account-plugin-devel}
BuildRequires: autoconf >= 2.50
BuildRequires: automake >= 1:1.11
BuildRequires: dbus-glib-devel
@@ -28,9 +27,10 @@ BuildRequires: gtk-doc >= 1.3
BuildRequires: gtk-webkit3-devel >= 2.2.0
BuildRequires: intltool >= 0.50.0
BuildRequires: json-glib-devel
-%{?with_uoa:BuildRequires: libaccounts-devel >= 1.4}
+%{?with_uoa:BuildRequires: libaccount-plugin-devel}
+%{?with_uoa:BuildRequires: libaccounts-glib-devel >= 1.4}
BuildRequires: libsecret-devel >= 0.5
-%{?with_uoa:BuildRequires: libsignon-devel >= 1.1}
+%{?with_uoa:BuildRequires: libsignon-glib-devel >= 1.1}
BuildRequires: libsoup-devel >= 2.42.0
BuildRequires: libtool >= 2:2.2
BuildRequires: libxml2-devel >= 2
@@ -69,7 +69,11 @@ Group: Libraries
Requires: glib2 >= 1:2.36.0
Requires: gtk+3 >= 3.6.0
Requires: gtk-webkit3 >= 2.2.0
+%{?with_uoa:Requires: libaccounts-glib >= 1.4}
+Requires: libsecret >= 0.5
+%{?with_uoa:Requires: libsignon-glib >= 1.1}
Requires: libsoup >= 2.42.0
+Requires: telepathy-glib >= 0.20
Conflicts: gnome-online-accounts < 3.8.2-1.1
%description libs
@@ -108,6 +112,7 @@ Dokumentacja API GOA.
%prep
%setup -q
+%patch0 -p1
%build
%{__gnome_doc_prepare}