summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorElan Ruusamäe2013-10-07 06:54:33 (GMT)
committerElan Ruusamäe2013-10-07 06:54:59 (GMT)
commita81019945ee7afa2bcba7a1bbcbfe1bae456f6b7 (patch)
tree8e045fe4eeeb90f86d289a9b74e3cc00ae3ffcc3
parent423f0b7bce54e9c295ab8fb237f407332a21bffd (diff)
parenta801c4796e319d763ee14656610aac8e593e3c81 (diff)
downloadfolly-a81019945ee7afa2bcba7a1bbcbfe1bae456f6b7.zip
folly-a81019945ee7afa2bcba7a1bbcbfe1bae456f6b7.tar.gz
install more headers, used by hiphop-php
-rw-r--r--folly.spec4
-rw-r--r--install-headers.patch61
2 files changed, 64 insertions, 1 deletions
diff --git a/folly.spec b/folly.spec
index 4ea26aa..6efceae 100644
--- a/folly.spec
+++ b/folly.spec
@@ -5,13 +5,14 @@
Summary: Folly is an open-source C++ library developed and used at Facebook
Name: folly
Version: 0.1
-Release: 1
+Release: 0.9
License: Apache v2.0
Group: Libraries
Source0: https://github.com/facebook/folly/archive/master/%{name}.tar.gz
# Source0-md5: d7ff084fbd77dc34bfd9469c7a974547
Patch0: https://github.com/facebook/folly/pull/29.patch
# Patch0-md5: 8745f0742d7199a5d3b2864620812f89
+Patch1: install-headers.patch
URL: https://github.com/facebook/folly/blob/master/folly/docs/Overview.md
BuildRequires: boost-devel >= 1.20.0
BuildRequires: double-conversion-devel
@@ -64,6 +65,7 @@ Statyczna biblioteka %{name}.
%setup -qc
mv folly-*/* .
%patch0 -p1
+%patch1 -p1
# this is gtest-1.6 seem to work
ln -s %{_usrsrc}/gtest folly/test/gtest-1.6.0
diff --git a/install-headers.patch b/install-headers.patch
new file mode 100644
index 0000000..3efe2f9
--- /dev/null
+++ b/install-headers.patch
@@ -0,0 +1,61 @@
+--- folly-0.1/folly/Makefile.am 2013-10-06 18:16:51.140695708 +0300
++++ folly-0.1/folly/Makefile.am 2013-10-06 18:18:18.131398586 +0300
+@@ -26,19 +26,25 @@
+ ConcurrentSkipList.h \
+ ConcurrentSkipList-inl.h \
+ Conv.h \
++ CpuId.h \
+ detail/AtomicHashUtils.h \
+ detail/BitIteratorDetail.h \
++ detail/BitsDetail.h \
+ detail/DiscriminatedPtrDetail.h \
+ detail/FingerprintPolynomial.h \
+ detail/GroupVarintDetail.h \
+ detail/SlowFingerprint.h \
++ detail/Stats.h \
+ detail/ThreadLocalDetail.h \
+ DiscriminatedPtr.h \
++ DynamicConverter.h \
++ Exception.h \
+ dynamic.h \
+ dynamic-inl.h \
+ eventfd.h \
+ FBString.h \
+ FBVector.h \
++ FileUtil.h \
+ Fingerprint.h \
+ folly-config.h \
+ Foreach.h \
+@@ -51,10 +57,13 @@
+ Histogram-inl.h \
+ IntrusiveList.h \
+ json.h \
++ Lazy.h \
+ Likely.h \
+ Logging.h \
+ Malloc.h \
+ MapUtil.h \
++ Memory.h \
++ Optional.h \
+ PackedSyncPtr.h \
+ Portability.h \
+ Preprocessor.h \
+@@ -68,6 +77,10 @@
+ sorted_vector_types.h \
+ SpookyHashV1.h \
+ SpookyHashV2.h \
++ stats/BucketedTimeSeries.h \
++ stats/Histogram-defs.h \
++ stats/Histogram.h \
++ stats/MultiLevelTimeSeries.h \
+ StlAllocator.h \
+ String.h \
+ String-inl.h \
+@@ -83,6 +96,7 @@
+ ThreadLocal.h \
+ TimeoutQueue.h \
+ Traits.h \
++ Varint.h \
+ Unicode.h
+
+ FormatTables.cpp: build/generate_format_tables.py