summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormaciek2w2006-09-22 16:11:06 (GMT)
committercvs2git2012-06-24 12:13:13 (GMT)
commit1d512ccc9c34e89598e8f2b61ca75475920c6640 (patch)
tree90af07a097d933a6a7b9807971fa14ec3b75ccb3
parentfa1ae53ea33ed4e8ae4bff4e0def62573c9b620f (diff)
downloadeclipse-1d512ccc9c34e89598e8f2b61ca75475920c6640.zip
eclipse-1d512ccc9c34e89598e8f2b61ca75475920c6640.tar.gz
- disabled build of junit4 and apt by patch from
http://cvs.fedora.redhat.com/viewcvs/rpms/eclipse/devel/eclipse-disable-junit4-apt.patch?rev=1.4&view=auto Changed files: eclipse-disable-junit4-apt.patch -> 1.1 eclipse.spec -> 1.75
-rw-r--r--eclipse-disable-junit4-apt.patch513
-rw-r--r--eclipse.spec10
2 files changed, 519 insertions, 4 deletions
diff --git a/eclipse-disable-junit4-apt.patch b/eclipse-disable-junit4-apt.patch
new file mode 100644
index 0000000..472257f
--- /dev/null
+++ b/eclipse-disable-junit4-apt.patch
@@ -0,0 +1,513 @@
+diff -uNr assemble.org.eclipse.sdk.linux.gtk.ia64.xml assemble.org.eclipse.sdk.linux.gtk.ia64.xml
+--- assemble.org.eclipse.sdk.linux.gtk.ia64.xml 2006-07-04 13:40:47.000000000 -0400
++++ assemble.org.eclipse.sdk.linux.gtk.ia64.xml 2006-07-04 13:33:17.000000000 -0400
+@@ -106,9 +106,6 @@
+ <ant antfile="build.xml" dir="plugins/org.eclipse.jdt.ui" target="gather.bin.parts">
+ <property name="destination.temp.folder" value="${eclipse.plugins}"/>
+ </ant>
+- <ant antfile="build.xml" dir="plugins/org.eclipse.jdt.junit4.runtime" target="gather.bin.parts">
+- <property name="destination.temp.folder" value="${eclipse.plugins}"/>
+- </ant>
+ <ant antfile="build.xml" dir="plugins/org.eclipse.osgi" target="gather.bin.parts">
+ <property name="destination.temp.folder" value="${eclipse.plugins}"/>
+ </ant>
+@@ -130,9 +127,6 @@
+ <ant antfile="build.xml" dir="plugins/org.eclipse.jdt.source" target="gather.bin.parts">
+ <property name="destination.temp.folder" value="${eclipse.plugins}"/>
+ </ant>
+- <ant antfile="build.xml" dir="plugins/org.eclipse.jdt.apt.ui" target="gather.bin.parts">
+- <property name="destination.temp.folder" value="${eclipse.plugins}"/>
+- </ant>
+ <ant antfile="build.xml" dir="plugins/org.eclipse.platform.doc.user" target="gather.bin.parts">
+ <property name="destination.temp.folder" value="${eclipse.plugins}"/>
+ </ant>
+@@ -295,9 +289,6 @@
+ <ant antfile="build.xml" dir="plugins/org.eclipse.jdt.junit.runtime" target="gather.bin.parts">
+ <property name="destination.temp.folder" value="${eclipse.plugins}"/>
+ </ant>
+- <ant antfile="build.xml" dir="plugins/org.eclipse.jdt.apt.core" target="gather.bin.parts">
+- <property name="destination.temp.folder" value="${eclipse.plugins}"/>
+- </ant>
+ <ant antfile="build.xml" dir="plugins/org.eclipse.jface.text" target="gather.bin.parts">
+ <property name="destination.temp.folder" value="${eclipse.plugins}"/>
+ </ant>
+@@ -325,9 +316,6 @@
+ <ant antfile="build.xml" dir="plugins/org.apache.lucene" target="gather.bin.parts">
+ <property name="destination.temp.folder" value="${eclipse.plugins}"/>
+ </ant>
+- <ant antfile="build.xml" dir="plugins/org.junit4" target="gather.bin.parts">
+- <property name="destination.temp.folder" value="${eclipse.plugins}"/>
+- </ant>
+ <ant antfile="build.xml" dir="plugins/org.eclipse.pde.source" target="gather.bin.parts">
+ <property name="destination.temp.folder" value="${eclipse.plugins}"/>
+ </ant>
+@@ -471,10 +459,6 @@
+ </antcall>
+ <antcall target="jarUp">
+ <param name="source" value="${eclipse.plugins}"/>
+- <param name="elementName" value="org.eclipse.jdt.junit4.runtime_1.0.0.v20060605-1400"/>
+- </antcall>
+- <antcall target="jarUp">
+- <param name="source" value="${eclipse.plugins}"/>
+ <param name="elementName" value="org.eclipse.osgi_3.2.0.v20060601"/>
+ </antcall>
+ <antcall target="jarUp">
+@@ -495,10 +479,6 @@
+ </antcall>
+ <antcall target="jarUp">
+ <param name="source" value="${eclipse.plugins}"/>
+- <param name="elementName" value="org.eclipse.jdt.apt.ui_3.2.0.v20060602-1740"/>
+- </antcall>
+- <antcall target="jarUp">
+- <param name="source" value="${eclipse.plugins}"/>
+ <param name="elementName" value="org.eclipse.platform.doc.user_3.2.0.v20060605"/>
+ </antcall>
+ <antcall target="jarUp">
+@@ -675,10 +655,6 @@
+ </antcall>
+ <antcall target="jarUp">
+ <param name="source" value="${eclipse.plugins}"/>
+- <param name="elementName" value="org.eclipse.jdt.apt.core_3.2.0.v20060602-1740"/>
+- </antcall>
+- <antcall target="jarUp">
+- <param name="source" value="${eclipse.plugins}"/>
+ <param name="elementName" value="org.eclipse.jface.text_3.2.0.v20060605-1400"/>
+ </antcall>
+ <antcall target="jarUp">
+diff -uNr assemble.org.eclipse.sdk.linux.gtk.ppc64.xml assemble.org.eclipse.sdk.linux.gtk.ppc64.xml
+--- assemble.org.eclipse.sdk.linux.gtk.ppc64.xml 2006-07-04 13:40:47.000000000 -0400
++++ assemble.org.eclipse.sdk.linux.gtk.ppc64.xml 2006-07-04 13:33:54.000000000 -0400
+@@ -106,9 +106,6 @@
+ <ant antfile="build.xml" dir="plugins/org.eclipse.jdt.ui" target="gather.bin.parts">
+ <property name="destination.temp.folder" value="${eclipse.plugins}"/>
+ </ant>
+- <ant antfile="build.xml" dir="plugins/org.eclipse.jdt.junit4.runtime" target="gather.bin.parts">
+- <property name="destination.temp.folder" value="${eclipse.plugins}"/>
+- </ant>
+ <ant antfile="build.xml" dir="plugins/org.eclipse.osgi" target="gather.bin.parts">
+ <property name="destination.temp.folder" value="${eclipse.plugins}"/>
+ </ant>
+@@ -130,9 +127,6 @@
+ <ant antfile="build.xml" dir="plugins/org.eclipse.jdt.source" target="gather.bin.parts">
+ <property name="destination.temp.folder" value="${eclipse.plugins}"/>
+ </ant>
+- <ant antfile="build.xml" dir="plugins/org.eclipse.jdt.apt.ui" target="gather.bin.parts">
+- <property name="destination.temp.folder" value="${eclipse.plugins}"/>
+- </ant>
+ <ant antfile="build.xml" dir="plugins/org.eclipse.platform.doc.user" target="gather.bin.parts">
+ <property name="destination.temp.folder" value="${eclipse.plugins}"/>
+ </ant>
+@@ -292,9 +286,6 @@
+ <ant antfile="build.xml" dir="plugins/org.eclipse.jdt.junit.runtime" target="gather.bin.parts">
+ <property name="destination.temp.folder" value="${eclipse.plugins}"/>
+ </ant>
+- <ant antfile="build.xml" dir="plugins/org.eclipse.jdt.apt.core" target="gather.bin.parts">
+- <property name="destination.temp.folder" value="${eclipse.plugins}"/>
+- </ant>
+ <ant antfile="build.xml" dir="plugins/org.eclipse.jface.text" target="gather.bin.parts">
+ <property name="destination.temp.folder" value="${eclipse.plugins}"/>
+ </ant>
+@@ -322,9 +313,6 @@
+ <ant antfile="build.xml" dir="plugins/org.apache.lucene" target="gather.bin.parts">
+ <property name="destination.temp.folder" value="${eclipse.plugins}"/>
+ </ant>
+- <ant antfile="build.xml" dir="plugins/org.junit4" target="gather.bin.parts">
+- <property name="destination.temp.folder" value="${eclipse.plugins}"/>
+- </ant>
+ <ant antfile="build.xml" dir="plugins/org.eclipse.pde.source" target="gather.bin.parts">
+ <property name="destination.temp.folder" value="${eclipse.plugins}"/>
+ </ant>
+@@ -462,10 +450,6 @@
+ </antcall>
+ <antcall target="jarUp">
+ <param name="source" value="${eclipse.plugins}"/>
+- <param name="elementName" value="org.eclipse.jdt.junit4.runtime_1.0.0.v20060605-1400"/>
+- </antcall>
+- <antcall target="jarUp">
+- <param name="source" value="${eclipse.plugins}"/>
+ <param name="elementName" value="org.eclipse.osgi_3.2.0.v20060601"/>
+ </antcall>
+ <antcall target="jarUp">
+@@ -486,10 +470,6 @@
+ </antcall>
+ <antcall target="jarUp">
+ <param name="source" value="${eclipse.plugins}"/>
+- <param name="elementName" value="org.eclipse.jdt.apt.ui_3.2.0.v20060602-1740"/>
+- </antcall>
+- <antcall target="jarUp">
+- <param name="source" value="${eclipse.plugins}"/>
+ <param name="elementName" value="org.eclipse.platform.doc.user_3.2.0.v20060605"/>
+ </antcall>
+ <antcall target="jarUp">
+@@ -662,10 +642,6 @@
+ </antcall>
+ <antcall target="jarUp">
+ <param name="source" value="${eclipse.plugins}"/>
+- <param name="elementName" value="org.eclipse.jdt.apt.core_3.2.0.v20060602-1740"/>
+- </antcall>
+- <antcall target="jarUp">
+- <param name="source" value="${eclipse.plugins}"/>
+ <param name="elementName" value="org.eclipse.jface.text_3.2.0.v20060605-1400"/>
+ </antcall>
+ <antcall target="jarUp">
+diff -uNr assemble.org.eclipse.sdk.linux.gtk.ppc.xml assemble.org.eclipse.sdk.linux.gtk.ppc.xml
+--- assemble.org.eclipse.sdk.linux.gtk.ppc.xml 2006-07-04 13:40:47.000000000 -0400
++++ assemble.org.eclipse.sdk.linux.gtk.ppc.xml 2006-07-04 13:34:22.000000000 -0400
+@@ -109,9 +109,6 @@
+ <ant antfile="build.xml" dir="plugins/org.eclipse.jdt.ui" target="gather.bin.parts">
+ <property name="destination.temp.folder" value="${eclipse.plugins}"/>
+ </ant>
+- <ant antfile="build.xml" dir="plugins/org.eclipse.jdt.junit4.runtime" target="gather.bin.parts">
+- <property name="destination.temp.folder" value="${eclipse.plugins}"/>
+- </ant>
+ <ant antfile="build.xml" dir="plugins/org.eclipse.osgi" target="gather.bin.parts">
+ <property name="destination.temp.folder" value="${eclipse.plugins}"/>
+ </ant>
+@@ -133,9 +130,6 @@
+ <ant antfile="build.xml" dir="plugins/org.eclipse.jdt.source" target="gather.bin.parts">
+ <property name="destination.temp.folder" value="${eclipse.plugins}"/>
+ </ant>
+- <ant antfile="build.xml" dir="plugins/org.eclipse.jdt.apt.ui" target="gather.bin.parts">
+- <property name="destination.temp.folder" value="${eclipse.plugins}"/>
+- </ant>
+ <ant antfile="build.xml" dir="plugins/org.eclipse.platform.doc.user" target="gather.bin.parts">
+ <property name="destination.temp.folder" value="${eclipse.plugins}"/>
+ </ant>
+@@ -298,9 +292,6 @@
+ <ant antfile="build.xml" dir="plugins/org.eclipse.jdt.junit.runtime" target="gather.bin.parts">
+ <property name="destination.temp.folder" value="${eclipse.plugins}"/>
+ </ant>
+- <ant antfile="build.xml" dir="plugins/org.eclipse.jdt.apt.core" target="gather.bin.parts">
+- <property name="destination.temp.folder" value="${eclipse.plugins}"/>
+- </ant>
+ <ant antfile="build.xml" dir="plugins/org.eclipse.jface.text" target="gather.bin.parts">
+ <property name="destination.temp.folder" value="${eclipse.plugins}"/>
+ </ant>
+@@ -328,9 +319,6 @@
+ <ant antfile="build.xml" dir="plugins/org.apache.lucene" target="gather.bin.parts">
+ <property name="destination.temp.folder" value="${eclipse.plugins}"/>
+ </ant>
+- <ant antfile="build.xml" dir="plugins/org.junit4" target="gather.bin.parts">
+- <property name="destination.temp.folder" value="${eclipse.plugins}"/>
+- </ant>
+ <ant antfile="build.xml" dir="plugins/org.eclipse.pde.source" target="gather.bin.parts">
+ <property name="destination.temp.folder" value="${eclipse.plugins}"/>
+ </ant>
+@@ -471,10 +459,6 @@
+ </antcall>
+ <antcall target="jarUp">
+ <param name="source" value="${eclipse.plugins}"/>
+- <param name="elementName" value="org.eclipse.jdt.junit4.runtime_1.0.0.v20060605-1400"/>
+- </antcall>
+- <antcall target="jarUp">
+- <param name="source" value="${eclipse.plugins}"/>
+ <param name="elementName" value="org.eclipse.osgi_3.2.0.v20060601"/>
+ </antcall>
+ <antcall target="jarUp">
+@@ -495,10 +479,6 @@
+ </antcall>
+ <antcall target="jarUp">
+ <param name="source" value="${eclipse.plugins}"/>
+- <param name="elementName" value="org.eclipse.jdt.apt.ui_3.2.0.v20060602-1740"/>
+- </antcall>
+- <antcall target="jarUp">
+- <param name="source" value="${eclipse.plugins}"/>
+ <param name="elementName" value="org.eclipse.platform.doc.user_3.2.0.v20060605"/>
+ </antcall>
+ <antcall target="jarUp">
+@@ -675,10 +655,6 @@
+ </antcall>
+ <antcall target="jarUp">
+ <param name="source" value="${eclipse.plugins}"/>
+- <param name="elementName" value="org.eclipse.jdt.apt.core_3.2.0.v20060602-1740"/>
+- </antcall>
+- <antcall target="jarUp">
+- <param name="source" value="${eclipse.plugins}"/>
+ <param name="elementName" value="org.eclipse.jface.text_3.2.0.v20060605-1400"/>
+ </antcall>
+ <antcall target="jarUp">
+diff -uNr assemble.org.eclipse.sdk.linux.gtk.x86_64.xml assemble.org.eclipse.sdk.linux.gtk.x86_64.xml
+--- assemble.org.eclipse.sdk.linux.gtk.x86_64.xml 2006-07-04 13:40:47.000000000 -0400
++++ assemble.org.eclipse.sdk.linux.gtk.x86_64.xml 2006-07-04 13:34:53.000000000 -0400
+@@ -106,9 +106,6 @@
+ <ant antfile="build.xml" dir="plugins/org.eclipse.jdt.ui" target="gather.bin.parts">
+ <property name="destination.temp.folder" value="${eclipse.plugins}"/>
+ </ant>
+- <ant antfile="build.xml" dir="plugins/org.eclipse.jdt.junit4.runtime" target="gather.bin.parts">
+- <property name="destination.temp.folder" value="${eclipse.plugins}"/>
+- </ant>
+ <ant antfile="build.xml" dir="plugins/org.eclipse.osgi" target="gather.bin.parts">
+ <property name="destination.temp.folder" value="${eclipse.plugins}"/>
+ </ant>
+@@ -130,9 +127,6 @@
+ <ant antfile="build.xml" dir="plugins/org.eclipse.jdt.source" target="gather.bin.parts">
+ <property name="destination.temp.folder" value="${eclipse.plugins}"/>
+ </ant>
+- <ant antfile="build.xml" dir="plugins/org.eclipse.jdt.apt.ui" target="gather.bin.parts">
+- <property name="destination.temp.folder" value="${eclipse.plugins}"/>
+- </ant>
+ <ant antfile="build.xml" dir="plugins/org.eclipse.platform.doc.user" target="gather.bin.parts">
+ <property name="destination.temp.folder" value="${eclipse.plugins}"/>
+ </ant>
+@@ -298,9 +292,6 @@
+ <ant antfile="build.xml" dir="plugins/org.eclipse.jdt.junit.runtime" target="gather.bin.parts">
+ <property name="destination.temp.folder" value="${eclipse.plugins}"/>
+ </ant>
+- <ant antfile="build.xml" dir="plugins/org.eclipse.jdt.apt.core" target="gather.bin.parts">
+- <property name="destination.temp.folder" value="${eclipse.plugins}"/>
+- </ant>
+ <ant antfile="build.xml" dir="plugins/org.eclipse.jface.text" target="gather.bin.parts">
+ <property name="destination.temp.folder" value="${eclipse.plugins}"/>
+ </ant>
+@@ -331,9 +322,6 @@
+ <ant antfile="build.xml" dir="plugins/org.apache.lucene" target="gather.bin.parts">
+ <property name="destination.temp.folder" value="${eclipse.plugins}"/>
+ </ant>
+- <ant antfile="build.xml" dir="plugins/org.junit4" target="gather.bin.parts">
+- <property name="destination.temp.folder" value="${eclipse.plugins}"/>
+- </ant>
+ <ant antfile="build.xml" dir="plugins/org.eclipse.pde.source" target="gather.bin.parts">
+ <property name="destination.temp.folder" value="${eclipse.plugins}"/>
+ </ant>
+@@ -474,10 +462,6 @@
+ </antcall>
+ <antcall target="jarUp">
+ <param name="source" value="${eclipse.plugins}"/>
+- <param name="elementName" value="org.eclipse.jdt.junit4.runtime_1.0.0.v20060605-1400"/>
+- </antcall>
+- <antcall target="jarUp">
+- <param name="source" value="${eclipse.plugins}"/>
+ <param name="elementName" value="org.eclipse.osgi_3.2.0.v20060601"/>
+ </antcall>
+ <antcall target="jarUp">
+@@ -498,10 +482,6 @@
+ </antcall>
+ <antcall target="jarUp">
+ <param name="source" value="${eclipse.plugins}"/>
+- <param name="elementName" value="org.eclipse.jdt.apt.ui_3.2.0.v20060602-1740"/>
+- </antcall>
+- <antcall target="jarUp">
+- <param name="source" value="${eclipse.plugins}"/>
+ <param name="elementName" value="org.eclipse.platform.doc.user_3.2.0.v20060605"/>
+ </antcall>
+ <antcall target="jarUp">
+@@ -678,10 +658,6 @@
+ </antcall>
+ <antcall target="jarUp">
+ <param name="source" value="${eclipse.plugins}"/>
+- <param name="elementName" value="org.eclipse.jdt.apt.core_3.2.0.v20060602-1740"/>
+- </antcall>
+- <antcall target="jarUp">
+- <param name="source" value="${eclipse.plugins}"/>
+ <param name="elementName" value="org.eclipse.jface.text_3.2.0.v20060605-1400"/>
+ </antcall>
+ <antcall target="jarUp">
+diff -uNr assemble.org.eclipse.sdk.linux.gtk.x86.xml assemble.org.eclipse.sdk.linux.gtk.x86.xml
+--- assemble.org.eclipse.sdk.linux.gtk.x86.xml 2006-07-04 13:40:47.000000000 -0400
++++ assemble.org.eclipse.sdk.linux.gtk.x86.xml 2006-07-04 13:35:31.000000000 -0400
+@@ -112,9 +112,6 @@
+ <ant antfile="build.xml" dir="plugins/org.eclipse.jdt.ui" target="gather.bin.parts">
+ <property name="destination.temp.folder" value="${eclipse.plugins}"/>
+ </ant>
+- <ant antfile="build.xml" dir="plugins/org.eclipse.jdt.junit4.runtime" target="gather.bin.parts">
+- <property name="destination.temp.folder" value="${eclipse.plugins}"/>
+- </ant>
+ <ant antfile="build.xml" dir="plugins/org.eclipse.osgi" target="gather.bin.parts">
+ <property name="destination.temp.folder" value="${eclipse.plugins}"/>
+ </ant>
+@@ -136,9 +133,6 @@
+ <ant antfile="build.xml" dir="plugins/org.eclipse.jdt.source" target="gather.bin.parts">
+ <property name="destination.temp.folder" value="${eclipse.plugins}"/>
+ </ant>
+- <ant antfile="build.xml" dir="plugins/org.eclipse.jdt.apt.ui" target="gather.bin.parts">
+- <property name="destination.temp.folder" value="${eclipse.plugins}"/>
+- </ant>
+ <ant antfile="build.xml" dir="plugins/org.eclipse.platform.doc.user" target="gather.bin.parts">
+ <property name="destination.temp.folder" value="${eclipse.plugins}"/>
+ </ant>
+@@ -298,9 +292,6 @@
+ <ant antfile="build.xml" dir="plugins/org.eclipse.jdt.junit.runtime" target="gather.bin.parts">
+ <property name="destination.temp.folder" value="${eclipse.plugins}"/>
+ </ant>
+- <ant antfile="build.xml" dir="plugins/org.eclipse.jdt.apt.core" target="gather.bin.parts">
+- <property name="destination.temp.folder" value="${eclipse.plugins}"/>
+- </ant>
+ <ant antfile="build.xml" dir="plugins/org.eclipse.jface.text" target="gather.bin.parts">
+ <property name="destination.temp.folder" value="${eclipse.plugins}"/>
+ </ant>
+@@ -331,9 +322,6 @@
+ <ant antfile="build.xml" dir="plugins/org.apache.lucene" target="gather.bin.parts">
+ <property name="destination.temp.folder" value="${eclipse.plugins}"/>
+ </ant>
+- <ant antfile="build.xml" dir="plugins/org.junit4" target="gather.bin.parts">
+- <property name="destination.temp.folder" value="${eclipse.plugins}"/>
+- </ant>
+ <ant antfile="build.xml" dir="plugins/org.eclipse.pde.source" target="gather.bin.parts">
+ <property name="destination.temp.folder" value="${eclipse.plugins}"/>
+ </ant>
+@@ -474,10 +462,6 @@
+ </antcall>
+ <antcall target="jarUp">
+ <param name="source" value="${eclipse.plugins}"/>
+- <param name="elementName" value="org.eclipse.jdt.junit4.runtime_1.0.0.v20060605-1400"/>
+- </antcall>
+- <antcall target="jarUp">
+- <param name="source" value="${eclipse.plugins}"/>
+ <param name="elementName" value="org.eclipse.osgi_3.2.0.v20060601"/>
+ </antcall>
+ <antcall target="jarUp">
+@@ -498,10 +482,6 @@
+ </antcall>
+ <antcall target="jarUp">
+ <param name="source" value="${eclipse.plugins}"/>
+- <param name="elementName" value="org.eclipse.jdt.apt.ui_3.2.0.v20060602-1740"/>
+- </antcall>
+- <antcall target="jarUp">
+- <param name="source" value="${eclipse.plugins}"/>
+ <param name="elementName" value="org.eclipse.platform.doc.user_3.2.0.v20060605"/>
+ </antcall>
+ <antcall target="jarUp">
+@@ -678,10 +658,6 @@
+ </antcall>
+ <antcall target="jarUp">
+ <param name="source" value="${eclipse.plugins}"/>
+- <param name="elementName" value="org.eclipse.jdt.apt.core_3.2.0.v20060602-1740"/>
+- </antcall>
+- <antcall target="jarUp">
+- <param name="source" value="${eclipse.plugins}"/>
+ <param name="elementName" value="org.eclipse.jface.text_3.2.0.v20060605-1400"/>
+ </antcall>
+ <antcall target="jarUp">
+diff -uNr features/org.eclipse.jdt/build.xml features/org.eclipse.jdt/build.xml
+--- features/org.eclipse.jdt/build.xml 2006-07-04 13:40:47.000000000 -0400
++++ features/org.eclipse.jdt/build.xml 2006-07-04 13:38:22.000000000 -0400
+@@ -12,11 +12,6 @@
+ <property name="os" value="win32"/>
+ <property name="ws" value="win32"/>
+ </ant>
+- <ant antfile="build.xml" dir="../../plugins/org.junit4" target="${target}">
+- <property name="arch" value="x86"/>
+- <property name="os" value="win32"/>
+- <property name="ws" value="win32"/>
+- </ant>
+ <ant antfile="build.xml" dir="../../plugins/org.junit" target="${target}">
+ <property name="arch" value="x86"/>
+ <property name="os" value="win32"/>
+@@ -27,11 +22,6 @@
+ <property name="os" value="win32"/>
+ <property name="ws" value="win32"/>
+ </ant>
+- <ant antfile="build.xml" dir="../../plugins/org.eclipse.jdt.junit4.runtime" target="${target}">
+- <property name="arch" value="x86"/>
+- <property name="os" value="win32"/>
+- <property name="ws" value="win32"/>
+- </ant>
+ <ant antfile="build.xml" dir="../../plugins/org.eclipse.jdt.core" target="${target}">
+ <property name="arch" value="x86"/>
+ <property name="os" value="win32"/>
+@@ -77,16 +67,6 @@
+ <property name="os" value="win32"/>
+ <property name="ws" value="win32"/>
+ </ant>
+- <ant antfile="build.xml" dir="../../plugins/org.eclipse.jdt.apt.core" target="${target}">
+- <property name="arch" value="x86"/>
+- <property name="os" value="win32"/>
+- <property name="ws" value="win32"/>
+- </ant>
+- <ant antfile="build.xml" dir="../../plugins/org.eclipse.jdt.apt.ui" target="${target}">
+- <property name="arch" value="x86"/>
+- <property name="os" value="win32"/>
+- <property name="ws" value="win32"/>
+- </ant>
+ <ant antfile="build.xml" dir="../../plugins/org.eclipse.ant.ui" target="${target}">
+ <property name="arch" value="x86"/>
+ <property name="os" value="win32"/>
+@@ -150,7 +130,7 @@
+ <copy todir="${feature.base}/features/org.eclipse.jdt_3.2.0.v20060609m-F7snq1fxia-Z4XP" failonerror="true" overwrite="false">
+ <fileset dir="${basedir}" includes="epl-v10.html,feature.xml,feature.properties,eclipse_update_120.jpg,license.html" />
+ </copy>
+- <eclipse.idReplacer featureFilePath="${feature.base}/features/org.eclipse.jdt_3.2.0.v20060609m-F7snq1fxia-Z4XP/feature.xml" selfVersion="3.2.0.v20060609m-F7snq1fxia-Z4XP" featureIds="" pluginIds="org.eclipse.jdt,3.2.0.v20060605-1400,org.eclipse.ant.ui,3.2.0.v20060531,org.eclipse.jdt.apt.core,3.2.0.v20060602-1740,org.eclipse.jdt.apt.ui,3.2.0.v20060602-1740,org.eclipse.jdt.core,3.2.0.v_671,org.eclipse.jdt.core.manipulation,1.0.0.v20060605-1400,org.eclipse.jdt.debug.ui,3.2.0.v20060605,org.eclipse.jdt.debug,3.2.0.v20060605,org.eclipse.jdt.junit,3.2.0.v20060605-1400,org.eclipse.jdt.junit.runtime,3.2.0.v20060605-1400,org.eclipse.jdt.junit4.runtime,1.0.0.v20060605-1400,org.eclipse.jdt.launching,3.2.0.v20060605,org.eclipse.jdt.ui,3.2.0.v20060605-1400,org.junit,3.8.1,org.junit4,4.1.0,org.eclipse.jdt.doc.user,3.2.0.v20060605-1400,org.eclipse.jdt.launching.macosx,3.1.100.v20060605,"/>
++ <eclipse.idReplacer featureFilePath="${feature.base}/features/org.eclipse.jdt_3.2.0.v20060609m-F7snq1fxia-Z4XP/feature.xml" selfVersion="3.2.0.v20060609m-F7snq1fxia-Z4XP" featureIds="" pluginIds="org.eclipse.jdt,3.2.0.v20060605-1400,org.eclipse.ant.ui,3.2.0.v20060531,org.eclipse.jdt.core,3.2.0.v_671,org.eclipse.jdt.core.manipulation,1.0.0.v20060605-1400,org.eclipse.jdt.debug.ui,3.2.0.v20060605,org.eclipse.jdt.debug,3.2.0.v20060605,org.eclipse.jdt.junit,3.2.0.v20060605-1400,org.eclipse.jdt.junit.runtime,3.2.0.v20060605-1400,org.eclipse.jdt.launching,3.2.0.v20060605,org.eclipse.jdt.ui,3.2.0.v20060605-1400,org.junit,3.8.1,org.eclipse.jdt.doc.user,3.2.0.v20060605-1400,org.eclipse.jdt.launching.macosx,3.1.100.v20060605,"/>
+ <antcall target="rootFiles${os}_${ws}_${arch}"/>
+ </target>
+ <target name="rootFileswin32_win32_x86">
+diff -uNr features/org.eclipse.jdt/feature.xml features/org.eclipse.jdt/feature.xml
+--- features/org.eclipse.jdt/feature.xml 2006-07-04 13:40:47.000000000 -0400
++++ features/org.eclipse.jdt/feature.xml 2006-07-04 12:05:17.000000000 -0400
+@@ -38,20 +38,6 @@
+ unpack="false"/>
+
+ <plugin
+- id="org.eclipse.jdt.apt.core"
+- download-size="0"
+- install-size="0"
+- version="0.0.0"
+- unpack="false"/>
+-
+- <plugin
+- id="org.eclipse.jdt.apt.ui"
+- download-size="0"
+- install-size="0"
+- version="0.0.0"
+- unpack="false"/>
+-
+- <plugin
+ id="org.eclipse.jdt.core"
+ download-size="0"
+ install-size="0"
+@@ -91,13 +77,6 @@
+ version="0.0.0"/>
+
+ <plugin
+- id="org.eclipse.jdt.junit4.runtime"
+- download-size="0"
+- install-size="0"
+- version="0.0.0"
+- unpack="false"/>
+-
+- <plugin
+ id="org.eclipse.jdt.launching"
+ download-size="0"
+ install-size="0"
+@@ -118,12 +97,6 @@
+ version="3.8.1"/>
+
+ <plugin
+- id="org.junit4"
+- download-size="0"
+- install-size="0"
+- version="0.0.0"/>
+-
+- <plugin
+ id="org.eclipse.jdt.doc.user"
+ download-size="0"
+ install-size="0"
+diff -uNr plugins/org.eclipse.jdt.doc.isv/buildDoc.xml plugins/org.eclipse.jdt.doc.isv/buildDoc.xml
+--- plugins/org.eclipse.jdt.doc.isv/buildDoc.xml 2006-07-04 13:40:47.000000000 -0400
++++ plugins/org.eclipse.jdt.doc.isv/buildDoc.xml 2006-07-04 13:30:48.000000000 -0400
+@@ -75,7 +75,7 @@
+ <exec dir="." executable="${javadoc}" output="doc.bin.log">
+ <arg line="@${basedir}/${optionsFile} -J-Xmx500M" />
+ </exec>
+- <antcall target="generateJdtAptJavadoc" />
++ <!-- <antcall target="generateJdtAptJavadoc" /> -->
+ </target>
+
+ <target name="generateJdtAptJavadoc">
+diff -uNr plugins/org.eclipse.jdt.doc.isv/jdtOptions.txt plugins/org.eclipse.jdt.doc.isv/jdtOptions.txt
+--- plugins/org.eclipse.jdt.doc.isv/jdtOptions.txt 2006-07-04 13:40:47.000000000 -0400
++++ plugins/org.eclipse.jdt.doc.isv/jdtOptions.txt 2006-07-04 13:42:37.000000000 -0400
+@@ -22,12 +22,10 @@
+ ;../org.eclipse.jdt.ui/ui refactoring
+ ;../org.eclipse.jdt.ui/core extension
+ ;../org.eclipse.jdt.core.manipulation/refactoring
+-;../org.eclipse.jdt.core.manipulation/common
+-;../org.eclipse.jdt.apt.core/src"
++;../org.eclipse.jdt.core.manipulation/common"
+ -d reference/api
+ -classpath @rt@
+ ;../../baseLocation/plugins/com.ibm.icu_3.4.4.1.jar
+-;../org.eclipse.jdt.apt.core/mirrorapi.jar
+ ;../org.apache.ant/lib/ant.jar
+ ;../org.eclipse.compare/@dot
+ ;../org.eclipse.core.commands/@dot
diff --git a/eclipse.spec b/eclipse.spec
index e3c95b5..4135f2f 100644
--- a/eclipse.spec
+++ b/eclipse.spec
@@ -20,6 +20,7 @@ Source0: http://download.eclipse.org/eclipse/downloads/drops/R-%{_ver_major}-%{_
Source1: %{name}.desktop
Patch0: %{name}-core_resources-makefile.patch
Patch1: %{name}-build.patch
+Patch2: %{name}-disable-junit4-apt.patch
URL: http://www.eclipse.org/
BuildRequires: ant >= 1.6.1
BuildRequires: jdk >= 1.4
@@ -50,6 +51,7 @@ wszystkiego i niczego w szczególności.
%setup -q -c
%patch0 -p0
%patch1 -p0
+%patch2 -p0
%build
unset CLASSPATH || :
@@ -167,8 +169,8 @@ rm -rf $RPM_BUILD_ROOT
%{_libdir}/%{name}/plugins/org.eclipse.help.ui_*.*.*
%{_libdir}/%{name}/plugins/org.eclipse.help.webapp_*.*.*
%{_libdir}/%{name}/plugins/org.eclipse.jdt_*.*.*
-%{_libdir}/%{name}/plugins/org.eclipse.jdt.apt.core_*.*.*
-%{_libdir}/%{name}/plugins/org.eclipse.jdt.apt.ui_*.*.*
+#%{_libdir}/%{name}/plugins/org.eclipse.jdt.apt.core_*.*.*
+#%{_libdir}/%{name}/plugins/org.eclipse.jdt.apt.ui_*.*.*
%{_libdir}/%{name}/plugins/org.eclipse.jdt.core_*.*.*
%{_libdir}/%{name}/plugins/org.eclipse.jdt.core.manipulation*.*.*
%{_libdir}/%{name}/plugins/org.eclipse.jdt.debug_*.*.*
@@ -177,7 +179,7 @@ rm -rf $RPM_BUILD_ROOT
%{_libdir}/%{name}/plugins/org.eclipse.jdt.doc.user_*.*.*
%{_libdir}/%{name}/plugins/org.eclipse.jdt.junit_*.*.*
%{_libdir}/%{name}/plugins/org.eclipse.jdt.junit.runtime_*.*.*
-%{_libdir}/%{name}/plugins/org.eclipse.jdt.junit4.runtime_*.*.*
+#%{_libdir}/%{name}/plugins/org.eclipse.jdt.junit4.runtime_*.*.*
%{_libdir}/%{name}/plugins/org.eclipse.jdt.launching_*.*.*
%{_libdir}/%{name}/plugins/org.eclipse.jdt.source_*.*.*
%{_libdir}/%{name}/plugins/org.eclipse.jdt.ui_*.*.*
@@ -241,7 +243,7 @@ rm -rf $RPM_BUILD_ROOT
%{_libdir}/%{name}/plugins/org.eclipse.update.scheduler_*.*.*
%{_libdir}/%{name}/plugins/org.eclipse.update.ui_*.*.*
%{_libdir}/%{name}/plugins/org.junit_*.*.*
-%{_libdir}/%{name}/plugins/org.junit4_*.*.*
+#%{_libdir}/%{name}/plugins/org.junit4_*.*.*
%dir %{_datadir}/%{name}
%dir %{_datadir}/%{name}/features